Haz una pregunta
  Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

28/09/2008 #1


Salida de colector abiero a contadores ttl
Saludos

Hola, soy nuevo en el foro. Espero puedan ayudarme con un problema que se me a presentado.
En un proyecto que estoy desarrollando, debo conectar el Pin de salida de un puerto de un equipo a un contador electrónico (tipo un contador 74LS93 por ejemplo). Ese pin de salida del equipo es un colector abierto, y fue programado para generar una señal de reloj de un periodo de 1 seg, duty cycle de 50% (un segundo en alto y uno en bajo), de tal manera que al conectarle el contador, este inicie a contar los pulsos generados por el equipo.

Al colector abierto le he colocado su respectiva resistencia de pull-up a 5v, de allí conectado al contador. El problema es que en ocasiones el contador no cuenta correctamente. Muchas veces, el contador cuenta no solo en los flancos de bajada de la señal de clock, sino también en los de subida, o no cuenta en absoluto, las salidas del contador parecen ser erráticas y no una cuenta BCD correcta.

A la salida del colector abierto le coloque una resistencia en serie con la entrada del contador, además de la que ya tenía de pull up, y eso al parecer arreglo el problema, pero al mover un poco los cables o el circuito la cuenta del contador se desordena y hace conteos en falso otra vez, y no parece un problema de contactos porque me he asegurado de ello.

Espero puedan ayudarme y decirme que estoy haciendo mal, si es un problema de niveles de voltaje o necesito algún dispositivo en el medio que mejore el acople?


Muchas gracias
29/09/2008 #2


posiblemente sea la resistencia de pull-up de un valor muy alto... esto podria causar alta sensibilidad al ruido electrico.

te aconsejo que bajes el valor de dicha resistencia teniendo en cuenta siempre no sobrepasar el valor maximo de corriente que soporta el colector abierto y seria mejor utilizar cable mallado (blindado tipo coaxil) para que la comunicacion entre el equipo y el contador no se vea afectada por alguna interferencia o ruido electrico circundante.... fijate si ambas masas tienen una buena tierra.

si esto no lo soluciona proba con algun tipo de acoplador optico... como el 4n26 o simil. si no te das idea como conectarlo te lo grafico luego...

revisa bien el contador... por ahi el 74ls93 esta pinchado o la fuente que lo alimenta genera ruido electrico...

si se me ocurre algo mas te digo...

salu2
30/09/2008 #3


En algún sitio tienes un mal contacto. O soldadura o inserción. Busca, Limpia o repasa.
30/09/2008 #4


Muchas gracias por sus comentarios, estare revisando a ver si se termina de arreglar
30/09/2008 #5

Avatar de pepechip

Puedes poner un condensador en paralelo con la puerta o con la resistencia para evitar las interferencias.
16/11/2008 #6


Salida colector abierto a contadores ttl
saludos foro.

les comento que los problemas con el contador y el colector abierto continúan irremediablemente de lo que haga. les coloco una fotografía del circuito que estoy utilizando y que no me quiere funcionar bien.

la alimentación del equipo que genera los pulsos es de 12 volts, así que utilize un lm7805 para generar el vcc del cual se alimenta el contador 7493 y es el mismo vcc al que se conecta la r de pull up de 2.7k.

la cosa es que el contador sigue contando de manera incorrecta. el 7493 esta bajo la configuración de contador bcd, pero de vez en cuando salta números y va desde 000 hasta 101 en vez de ir a 001 con el siguiente pulso de entrada. realmente me parece muy extraño que sea un problema de rebotes puesto que los pulsos de la señal de entrada al contador me los esta produciendo un equipo, no vienen de un pulsador o algo mecánico. y si fuera un problema de rebotes no tendría sentido que el contador hubiera empezado a funcionar mejor cuando conecte la r de 1k en serie que esta en el diagrama (porque antes de conectarla no funcionaba ni contaba bien para nada).

también me parece extraño que sea un problema de falta de acople porque llegue a usar un optoacoplador entre la r de 1k y la entrada clock al contador pero nada de nada, seguía saltándose números en la cuenta igual.

de verdad espero que puedan ayudarme porque me quede sin ideas y no se me ocurre que pueda estar pasando. :x :x :x

muchas gracias
Imágenes Adjuntas
Tipo de Archivo: jpg circuito_456.jpg (46,6 KB (Kilobytes), 348 visitas)
16/11/2008 #7
Excluido


hola, vamos por partes.

1 -- eso de qu eel generaqdor usa 12 v y tu equipo 5v no esta del todo bien, por que veo en el diagrama que J1 debe ser la PC que emite pulsos de 12v ........supongo .0v y 12v.
bueno, le estas mandando 12v al contador, si bien le pusiste la R.1 a 5vcc pero cuando la PC manda un 1 son 12v.

si bien el integrado creo que tiene diodos entre las salidas y fuente en inversa...........si no pusiste al principio la R2 va mal.

asi que , vamos de nuevo:

en paralelo con R1 tendrias que poner un diodo en inversa, o sea el catodo o sea la rayita hacia los +5v.
mejor seria hacer un diviso rresistivo o un Dz , pero va = .

en lo demas deberia de andar.........
sino.........ORC o ir probando cdad cosa por separado con circuitos de prueba a ver donde esta la falla.

saludos
16/11/2008 #8


hola,

gracias por responder tan pronto fernandob.

estas en lo correcto, segun el diagrama el pin 2 de J1 es el que manda los pulsos (que son una onda cuadrada de 1 segundo en alto y uno en bajo). La cosa es que este pin 2 es un colector abierto, asi que coloque la R1 de 2.7k a vcc (5 volts de salida del lm7805) para que me diera los pulsos de +5 y 0 (aunque tambien lo probe con un tester y al parecer lo que me esta sacando son +5 y 0 y no +12 y 0).

No te entendi muy bien el porque no haber colocado la R2 desde un principio estaba mal, aunque debo admtir que se la puse solo por probar y funciono mejor, asi que fue pura suerte.

Tampoco entendi muy bien porque deberia haber un diodo en paralelo con R1, y para que seria necesario un divisor resistivo (divisor de tension? ) si ya tengo los 5 volts proporcionador por el lm7805

muchisimas gracias
16/11/2008 #9
Excluido


tenes razon, mencionaste lo de colector abienro y yo lo ignoreuna pregunta estupida :
colector abierto te refieres a un NPN o sea el emisor a masa ....no ?
obvio por que si no quedaria siempre en + .......pero.conviene verificar por que lo que t ehace no es logico.

la otra cosa:
muy importante:
uniste las masas de la fuente del LM de 5v y la masa de la compu ......... no ?

lo de la R. yo supuse que la PC mandaba 12v no pense en el colectro abierto.......pero es interesante y es un dato el saber que y como paso. idem lo del divisor resistivo, yo pense que te llegaban 12v..

eso de que esa R. al ponerla ayudo dice bastante.
hay ahi uyna capacidad que al agregar la R se hizo notoria una cierta constante de tiempo.
y por lo visto es util.
asi que si no tienes ORC para ver que pasa (yo tampoco tengo) a seguir probando:
subi R2 a 10K .....o mejor a 33K a ver que pasa.

saludos
17/11/2008 #10


Salida colector abierto a contadores ttl
hola fernandob,

si las masas del lm7805 y la masa de la compu es la misma, todo esta unido a la misma masa (de eso estoy seguro y descarto cualquier problema de falta de contactos o algo por el estilo).

estare revisando lo de variar la r2 a ver que pasa, espero que se arregle de verdad

muchas gracias por tu ayuda
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Cuestiones Elementales de Electrónica

Deseas aprender electrónica y necesitas ayuda para comenzar? Resuelve tus dudas en esta sección.

Cerrar
Foros de Electrónica » Principiantes » Cuestiones Elementales de Electrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.