Haz una pregunta
  Foros de Electrónica » Temas de Interés » Autotrónica, La Electrónica en movimiento
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/05/2009 #1


Problema con Air Fuel Monitor - Un integrado no funciona
Hola a todos, me presento, mi nombre es Andres, soy Colombiano

Soy ing Mecánico e intento fabricar algo similar a lo que discuten en otro post:

http://www.forosdeelectronica.com/po...50.html#194650

Pero mis conocimientos de electronica son muy basicos por no decir nulos, me ayudan por favor:

Fabriqué en un board este circuito:

http://www.pelicanparts.com/techarti...el_monitor.htm



Logré conectar a la zonda lambda pero solo la mitad de los leds se mueven con la señal (es entre 0 y 1.1v), los otros 10 leds se encienden continuamente y no muestran ninguna reaccion a la señal de la sonda.

Adjunto algunas imagenes, por favor me ayudan a buscar el problema, creo que todo esta bien conectado, del diagrama todo es muy claro para mi excepto la conexión del potenciometro...

Ademas el regulador de 5v se está calentando mucho la laminita para disipar el calor, ya tiene disipador pero aun asi en segundos es imposible tocarlo, ¿es normal?...

Por favor ayudenme, muchas gracias
28/05/2009 #2


Holas Master te dejo otro ej: q funciona...



Componentes:

1 un LM 3914
2 un capacitor electrolítico de 2.2 microfaradio / 16 V o mayor.
3 una resistencia eléctrica 330 OHM 1/8 W
4 un Potenciómetro 4k7s
5 dos leds rojos (ALTO BRILLO)
6 dos leds amarillos (ALTO BRILLO)
7 seis leds verdes (ALTO BRILLO)
8 un zócalo para C.I. de 18 pernos (opcional)

Notas:
La pista que comunica a todos los leds es el positivo de estos.
Se indica que se puede poner una resistencia de 1ohms entre la entrada de la señar y masa para apagar el primer led, yo no lo hice ya que creo que puede cargar mas la señal de la zonda causando falsas lecturas (si me equivoco que me corrijan plz)
La conexión es: positivo puede ser de la posicion acc, de la llave, contacto, del encendedor, o directo a la bateria u otro lugar (en este caso es obligatorio meter fusible de 5 amp de por medio)
masa de cualquier lugar, y la señal directo de la zonda (cable blanco) o del ecu (mirando los conectores por detras con la tapa del ecu hacia arriba, es el de la derecha, cable blanco de abajo, quinto contando de derecha a izquieda)
Tambien se puede puentear donde dice jumper para lograr el efecto grafico de barras.
28/05/2009 #3


Excelente, mil gracias, en caso de no encontrar el problema con el que construí me fabrico ese pues tengo casi todas las piezas. Qué pasa si uso el LM3915 en lugar del LM3914?

Esto dice en esta pagina: http://www.neoteo.com/lm3914-y-lm3915.neo

"El LM3915 difiere del LM3914 solamente en que en lugar de tener una escala lineal, posee una escala logarítmica"

La gráfica de la señal de las zondas Lambda y su comportamiento respecto a la relacion aire combustible es logaritmica, no lineal, ¿no sería mejor usar el 15?



Por otro lado, no hay problema con alimentar el circuito con 12V? El otro tiene regulador de 5V? Obviamente la idea es usar el circuito en un vehiculo...

Saludos desde Colombia.

Andres Posada
28/05/2009 #4


ardillabike en Argentina un flaco lo tiene en un auto de 4 tiempos y va de 10.. usa un zonda buena esas q son mas gordas.. ya que tiene mas presicion...
Master... tenes el datsheet... asi lo imprimi y lo hago = q el tuyo y veo dif con el q publique...
Saludos y provemos hasta sastifacernos.
Salu2.
28/05/2009 #5


Gracias...
...me tomará un poco entender lo que escribes, definitivamente en cada pais usamos formas diferentes de expresarnos...

Te cuento que solo tengo lo que figura en esta pagina:
http://www.pelicanparts.com/techarti...el_monitor.htm

Tambien descargué el manual del LM3915, pero ese no es dificil encontrarlo en internet...

Estoy de acuerdo con lo que propones, si puedes intentar construir el que yo fabriqué excelente, asi comparamos los resultados, yo por mi parte me comprometo a intentar construir el que usted muestra...

Saludos

Andres Posada
29/05/2009 #6


Perfecto Andres, lo diseño para estos días.
pd: sorry por hablar como porteño jajaja..
05/10/2009 #7


Respuesta: Problema con Air Fuel Monitor - Un integrado no funciona
Hola,

Disculpame ardillabike pero me parece que logaritmico significa que va de 10,100,1000,10000,....etc
Podria ser que use semilogaritmico y que la parte de la tension sea lineal.

Otra cosa:

Lei por ahi que las sondas Lambda:

*Temperatura ideal de trabajo son entre 600º y 800º a esta temperatura la respuesta de la sonda es muy rapida.
*la sonda lambda solo produce tension cuando supera los 300º

* la sonda lambda el punto medio de tension es 400 a 500mV
pero caliente y trabajando correctamente debe oscilar entre 200mV a 700mv esta constantemente en estado de transicion
Segun el cuadro:

800mv a 600mv mezcla rica excases de aire
400mv para abajo la mezcla es pobre exceso de aire

Podriamos hacer con un micro las lecturas el problema es que no se cuanto es la frecuencia de transicion de 200mv a 800mv



Saludos
06/10/2009 #8


Respuesta: Problema con Air Fuel Monitor - Un integrado no funciona
amigo el primer circuito que posteas, funciona perfectamente, te enviare algunas fotos del trabajo (MENUDO TRABAJO), ahora por el tema del calor, te recomiendo que uses la siguiente regulacion para el voltaje con el tip35c, que fue lo que hize yo, ya que tube que poner disipadores de calor al LM3915 y se calentaban mucho porque 20 leds, consumen casi 1 amper, la que te propongo yo soporta hasta 4 amperes disipados
y para el 7905 es muy preciso, utiliza un tip35C, una resistencia de 680 ohms y un dido zener de 3.9 volts o de 4.3 voltsj espero ayudarte con algunos tips, saludos
Imágenes Adjuntas
Tipo de Archivo: jpg S5000536.JPG (124,8 KB (Kilobytes), 226 visitas)
Tipo de Archivo: jpg REGULADOR ESTABILIZADO(CONTIP35C).jpg (33,4 KB (Kilobytes), 202 visitas)
Tipo de Archivo: jpg S5000557.JPG (119,5 KB (Kilobytes), 191 visitas)
Tipo de Archivo: jpg S5000561.JPG (107,8 KB (Kilobytes), 158 visitas)
Tipo de Archivo: jpg S5000601.JPG (70,0 KB (Kilobytes), 168 visitas)
Tipo de Archivo: jpg S5000603.JPG (79,2 KB (Kilobytes), 143 visitas)
Tipo de Archivo: jpg S5000602.JPG (84,7 KB (Kilobytes), 170 visitas)
Tipo de Archivo: jpg S5000605.JPG (105,6 KB (Kilobytes), 186 visitas)
14/10/2009 #9


Respuesta: Problema con Air Fuel Monitor - Un integrado no funciona
buenas me presento soy maxi y solo queria hacer mi aporte y es el siguiente yo lo simule por que estoy interezado en armarlo, y por lo menos por simulacion andubo excelente asi que lo unico que tengo para decir es que acompaño a broko poximamente en cuanto lo arme lo subo espero que les sirva de algo saludos a todos
29/01/2010 #10


Respuesta: Problema con Air Fuel Monitor - Un integrado no funciona
Mil Gracias por toda la información, soy nuevo en este Foro y me parece Genial.. Ya empece a armarlo para mi auto (Gol G3), asi que esperemos que funcione todo.. Saludos
12/02/2010 #11


Respuesta: Problema con Air Fuel Monitor - Un integrado no funciona
Haganlo tranquilos porque lo acabo de terminar y probar (no en el auto) y anda. A lo mejor no es la mejor implementacion, pero en cuanto lo calibre bien les digo como me quedo.
Saludos y gracias
26/02/2010 #12


Respuesta: Problema con Air Fuel Monitor - Un integrado no funciona
hola como les va a todos? bueno felicito a bronko por su aporte y su experiensa, queria mas que nada preguntarte si serias tan amable de subir el diseño de tu placa ya que estoy interezado en armal y me gusto mucho como lo armastes vos. saludos a todos
07/03/2010 #13


Respuesta: Problema con Air Fuel Monitor - Un integrado no funciona
Por que usas el lm3915?
la diferencia entre el 3914 y el 3915 es que el 14 es lineal y el 15 es logaritmico. Esto significa que para prender cada led hacia el maximo requiere una variacion de tension (de senal) logaritmica, y no lineal.

A modo de ejemplo:
en el 3914 por cada 1v se prende un led (de 1 a 10)
en el 3915 el primer led se prende a los 10mv, el segundo a los 100mv , el tercero a 1v...etc

No lo veo aplicable a este caso (a menos que la zona se comporte de forma logaritmica)
Si usas el 3915 te va a dar lecturas equivocadas. La zona "verde" en los leds no va a ser la zona verde de la zonda.

la otra es usar algun pic o avr con ADC y conectarle uno o dos displays de 7 segmentos.
Ahi podes representar variaciones de 0-9 o 0-99 con mucha mayor presicion y mas barato.
saludos.
20/11/2010 #14


acabo de armar este en un protoboard ..pero como pruebo si funciona corectamente en la pagina donde tome el circuitodicen que si funciona pero no dicen como probarlo ...me pueden ayudar
07/12/2010 #15


buenas, creo que lo que intentas hacer no te funcionara como crees

te pongo una imagen que capte con un osciloscopio en mi coche de la señal de la sonda lambda (la variacion rapida que se produce es acelerando a 2000rpm), cuando es oscilante en mayor tiempo es en ralenti, y cuando se queda arriba es despues de acelerar.



como ves esta oscilando continuamente, esto es porque no es posible regular la mezcla tan fina que los gases siempre sean los mismos, yo en mi coche llevo una wideband (sonda lambda de banda ancha) y esta siempre oscilando, por ejemplo 14,7 luego cambia 14,8 luego 15, 14,5 luego...... y asi continuamente... y esto que el reloj tiene un delay para que sea posible su lectura ya que si no seria imposible leer los digitos.

Si lo que buscas es marcar la mezcla necesitaras una sonda de banda ancha la cual te marca de 0-5v en un rango de 10:1 a 19:1, seria lineal la señal

seria algo asi (dependiendo de la marca)


Con lo que quieres hacer estaria constantemente variando los leds de pobre a rico.
07/12/2010 #16


mmmmm...creo que comprare uno ya armado....los diseños que ponen en la red me parece no son correctos .....
23/08/2011 #17


fasjpelon7 dijo: Ver Mensaje
mmmmm...creo que comprare uno ya armado....los diseños que ponen en la red me parece no son correctos .....
Ya se que es viejo, pero no puedo creer lo que estoy leyendo. Hay esquemas probados que funcionan, obio si no queres pensarlo un poquito o ponerte a experimentar lo podes comprar.

---------

Estoy laburandolo también, con un 7805 para cada LM3915 ya que a mi también me calienta demasiado.
Adema agregue un realay configurable entre los primeros 5 leds para tirar un shiftlight de mezcla pobre (muy utiles en preparaciones turbo) y otro relay para poder conectar el hallmeter en una linea directa a la batería y que prenda automaticamente cuando el auto esta en contacto.
Ademas de un fusible por seguridad.
Saludos!
23/08/2011 #18


es que el problema no es del esquema, el problema es que con una sonda lambda de banda corta solo puedes ver si va rico o va pobre, osea si vas por encima de 14,7:1 o por debajo de este. Sin embargo eso no tiene ninguna utilidad, seria un adorno ya que no sabria a que relacion de gasolina vas actualmente.

Si os quereis currar uno siempre podeis comprar una sonda de banda ancha (unos 60€ la bosh) y a partir de ahi hacer vuestro diseño, con esta tendreis un rango de 10:1 hasta 17:1 creo recordar, y eso de 0-5V, con una precision de 0,1.

Por ejemplo, en una preparacion turbo, si vas a 13:1 el sensor te marca que vas rico de mezcla, sin embargo vas pobre si vas a una presion considerable, probablemente fundas los pistones. Para esto tendrias que ir a 12:1 o 11:1 dependiendo
23/08/2011 #19


MerLiNz dijo: Ver Mensaje
es que el problema no es del esquema, el problema es que con una sonda lambda de banda corta solo puedes ver si va rico o va pobre, osea si vas por encima de 14,7:1 o por debajo de este. Sin embargo eso no tiene ninguna utilidad, seria un adorno ya que no sabria a que relacion de gasolina vas actualmente.

Si os quereis currar uno siempre podeis comprar una sonda de banda ancha (unos 60€ la bosh) y a partir de ahi hacer vuestro diseño, con esta tendreis un rango de 10:1 hasta 17:1 creo recordar, y eso de 0-5V, con una precision de 0,1.

Por ejemplo, en una preparacion turbo, si vas a 13:1 el sensor te marca que vas rico de mezcla, sin embargo vas pobre si vas a una presion considerable, probablemente fundas los pistones. Para esto tendrias que ir a 12:1 o 11:1 dependiendo
Como decis, para mi la utilidad es ver cuando va pobre de nafta, para una preparación con turbo es util ya que si andas fino de nafta levanta temperatura y podes rompes todo.
23/08/2011 #20


el problema como te digo, es que si vas a 13:1 te marcara como que vas bien de mezcla, sin embargo es una mezcla demasiada pobre para un motor turbo, creeras que vas bien, y sin embargo no sera asi.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Autotrónica, La Electrónica en movimiento

Sistemas electrónicos utilizados en vehículos de transporte.

Cerrar
Foros de Electrónica » Temas de Interés » Autotrónica, La Electrónica en movimiento

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.