Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Pequeña señal
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/03/2012 #1


Vumetro Estereo con un solo LM3916
Bueno, hace rato no pasaba por aqui... (mas de un año).

Estuve haciendo proebas en el Proteus y creo que logre hacer un vumetro estereo con un solo LM3916 (que bueno ya que es caro)... no es la gran cosa, y probablemente sea mejorable.

No lo he probado fisicamente aun, pero estoy optimista, supongo que va a funcionar, si me equivoco corrijanme


Genios, si me dicen que esta bien (o aceptable), seguire aprendiendo a manejar estos ICs e intentare hacer un analizador de espectro. Se que hay mil maneras de hacer vumetros y analizadores de espectro, y de hecho, hoy en dia los uC (PIC) son muy economicos, asi que no ta mala idea tampoco, pero no me llevo bien con los ADC jajaja

Les adjunto el esquematico de proteus.


EDIT:

Adjunto imagen (en zip) de la simulacion y la visualizacion del (des)muxtiplexado de la señal.

Durante el pulso alto usa la señal de audio (entrada x1 del U3) (Canal B-Azul). Durante el pulso bajo usa la señal senoidal (entrada x0 del U3) (canal A-Amarillo). Al parecer funciona como debe, lo que no se es si el LM3916 tendra suficiente tiempo de responder a los cambios de señales o si necesita cierto tiempo para "vaciarse".

Deberia tener una frecuencia de al menos 120hz (si el LM3916 lo permitiera seria mejor 240hz, 120hs para cada barra, seria imperceptible al ojo realmente) para que se vea bien al ojo, pero no se bien como calcular el clock del 555 (algo demasiado basico, pero nunca lo aprendi bien jaja).
03/03/2012 #2
Moderador general

Avatar de Fogonazo

Aquí tienes tu idea sobre el uso multiplexado del LM391x ya desarrollada

Vumetro de leds con peak-hold
03/03/2012 #3


Hola fogonazo, gracias por comentar.

Ya conocia ese vumetro que mensionas, pero no queria algo tan complejo, solo queria hacer un vumetro estereo sin peak hold, osea, solo quiero el vumetro del LM391x, pero estereo.

Que te parece mi circuito?, habria que corregir algo?

Para hacer un VU con peak hold no es mas simple un uC (pic por ej)?, seria un solo integrado de 5/10 dolares y los leds, me parece mas simple y mejor si se quiere un vumetro complejo con peak hold y descenso lento.
03/03/2012 #4

Avatar de mnicolau

Hola SERBice, te dejo un vu multiplexado tal cual estás haciendo, pero con pocos detalles extra necesarios. Funciona OK, si querés te subo un PCB.

Saludos
Archivos Adjuntos
Tipo de Archivo: pdf Vúmetro Estéreo Multiplexado.pdf (88,4 KB (Kilobytes), 528 visitas)
03/03/2012 #5


Ya veo, lo unico que cambia es la forma de darle positivo a los leds, y me parece mejor el que tu me muestras, por el tema del consumo, no se si el multiplexor aguanta tantos leds (150mA teoricamente, quizas si los soporte).

Igual me parece que plaquetodo esta usando un multiplexor mas grande de lo que hace falta o me equivoco?, en X e Y pasa a negativo cuando no se lo usa, si se usa el multiplexor invertido como yo lo use no se usaria una compuerta menos?.

Luego subo la modificacion.
Realmente esto me pone mas contento de lo que esperaba, no lo estaba haciendo tan mal despeus de todo jeje.

Gracias por la ayuda mnicolau.
03/03/2012 #6

Avatar de Tavo

mnicolau dijo: Ver Mensaje
Hola SERBice, te dejo un vu multiplexado tal cual estás haciendo, pero con pocos detalles extra necesarios. Funciona OK, si querés te subo un PCB.

Saludos
YO me apunto para el PCB, lo quiero.

Saludos!
03/03/2012 #7
Moderador general

Avatar de Fogonazo

SERBice dijo: Ver Mensaje
Ya veo, lo unico que cambia es la forma de darle positivo a los leds, y me parece mejor el que tu me muestras, por el tema del consumo, no se si el multiplexor aguanta tantos leds (150mA teoricamente, quizas si los soporte).........
El multiplexor NO suministra la corriente de consumo de los LED´s, para eso están los transistores T1 y T2
03/03/2012 #8


Fogonazo dijo: Ver Mensaje
El multiplexor NO suministra la corriente de consumo de los LED´s, para eso están los transistores T1 y T2
Claro claro, ese era el error de mi diseño.
03/03/2012 #9


Bueno si bien me parece un ahorro monetario "significativo" (entre 20 y 25AR$ al suprimir un 3916) creo que el LM3916 no llega a responder a tiempo y mezcla los canales, al menos en el simulador.

He ingresaro una onda senoidal en una de las entradas y en la otra tierra, para mi sorpresa (en el entorno simulado) la barra de leds que no deberia marcar nada si lo hace (aveces poco, como si fuera un residuo de la otra señal decreciendo y aveces llega a marcar como el canal que si tiene señal), presumo que puede ser que el LM3916 necesite de cierto tiempo para "cargarse y descargarse", y por lo tanto este arrojando la medicion de un canal en el otro.... la barra que representa el canal sin señal eventualmente marca señal y generalmente lo hace con baja intensidad, no se si se deba al simulador o si realmente podria llegar a pasar esto.


Podria ser esto asi o es un error del simulador?

Nota: hoy no tuve tiempo de ir a la tienda de electronica, por eso aun sigo con el simulador, y asi seguire hasta el lunes :(
04/03/2012 #10

Avatar de mnicolau

Tavo dijo: Ver Mensaje
YO me apunto para el PCB, lo quiero.

Saludos!
Cumpliendo...



Saludos
Imágenes Adjuntas
Tipo de Archivo: png Vumetro Estereo Multiplexado 3D.png (40,6 KB (Kilobytes), 661 visitas)
Archivos Adjuntos
Tipo de Archivo: zip Vúmetro Estéreo Multiplexado.zip (119,7 KB (Kilobytes), 240 visitas)
04/03/2012 #11
Moderador general

Avatar de Fogonazo

SERBice dijo: Ver Mensaje
...... creo que el LM3916 no llega a responder a tiempo y mezcla los canales, al menos en el simulador......
El LM3916 responde perfectamente, es extremadamente rápido en actualizar la lectura, yo lo he multiplexado hasta a 20 canales sin ningún problema.
05/03/2012 #12


Entonces debe ser un problema del simulador supongo.

Armare el circuito en un protoboard para probarlo. Gracias Fogonazo.
19/03/2012 #13


mnicolau dijo: Ver Mensaje
Cumpliendo...



Saludos
Hola mnicolau, gracias por subir el PCB.

- ¿Podrías subir el diagrama?

Saludos! Gracias.
19/03/2012 #14

Avatar de mnicolau

j0nA dijo: Ver Mensaje
Hola mnicolau, gracias por subir el PCB.

- ¿Podrías subir el diagrama?

Saludos! Gracias.
De nada! el esquema está en el post #4. Es ese mismo (con algunos componentes de distinto valor) y con el agregado de un pre simple no inversor con operacional.

Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Pequeña señal

Preamplificadores, Ecualizadores, Mezcladores, Controles de tono y volumen, Filtros activos, Efectos y pedales.

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Pequeña señal

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.