Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Gran señal
Foros Registrarse ¿Olvidaste tu contraseña?
15/03/2016 #1661

Avatar de pilm

Saludos a todos…


Hace ya algunos años que armé este amplificador, en dos versiones; uno para mi casa y otro como parte de un bajo amplificado para mi carro. Debo decir que funciona espectacular, expelente calidad de sonido y expelente potencia. Eso sí, para poderlo disfrutar al máximo es necesario un buen parlante y una caja bien calculada.


Cuando lo construí realicé barias mediciones para verificar su funcionamiento. Si mal no recuerdo, la señal PWM a la salida de los mosfets casi llega a los 200KHz, razón por la que los núcleos en las fuentes de PC no sirven para la bobina del filtro de salida. Si no es posible conseguir un núcleo capaz de trabajar a esa frecuencia (como fue mi caso), lo mas adecuado es construir la bobina con núcleo de aire.

Por cierto, para calcular el filtro de salida se usa:



C = 1/(2*pi*fc*RL*0,7)
L = (RL*0,7)/(2*pi*fc)


“RL” es la resistencia interna del parlante y “fc” la frecuencia de corte del filtro, que se suele estimar entre 20 Khz y 60 Khz.


Información ampliada al respecto la pueden encontrar en el PDF que adjunto.


Les muestro además una foto del amplificador que construí para el bajo del carro. Incluye en la misma placa la fuente de alimentación, para esta reciclé componente de una fuente de PC.
Saludos y espero que sirva lo que acabo de comentar…
17/03/2016 #1662


carbajal dijo: Ver Mensaje
Hola, nuevamente con una duda, talvez puedan ayudarme. Resulta que hice la bobina con nucleo de aire y esta vez si me funciono; pero ahora tengo otro problema, me dijeron por alli que revisara la frecuencia de trabajo, como se hace? perdon pero ignoro esa parte y lo segundo es que ahora calientan bastante los drivers, se ponen que hierven y mejor desconecto todo para no tener que ver como prende fuego todo, los componentes son los originales, todo como esta especificado en el diagrama a axcepcion del capacitor de 820pf de mica que no lo consigo por ninguna parte, asi que decidi poner uno de 1nf que es el mas cercano, no se si ese sera el motivo del exceso del caletamiento en los drivers, porque los mosfet van bien, calientan pero poquito a buen volumen.
Hola carbajal cuando hice una de las placas tuve problemas cuando coloque el condensador de 1nf obtuve un voltaje a la salida y se prendio un poco el foco que uso en la alimentacion, despues concegui el de 820pf y santo remedio, ya he hecho varias placas pero con toroides respectivos y todas han salido bien, el problema d la bobina con nucleo de aire es que causa mucha interferencia y afecta tambien el buen funcionamiento del amplificador y con respecto a medir la frecuencia tienes que tener minimo un tester que mida frecuencia por encima de los 100khertz, ya que al medir despues del toroide con respecto a tierra te va dar una lectura entre 200 y 250khertz
18/03/2016 #1663

Avatar de pilm

Saludos cordiales…

El cambio de bobina no debería ser causa de calentamiento de los drivers, a menos que los mosfets tengan una falla. El capacitor al que hacen referencia tampoco, pues el usar uno de 1nF, solo ocasiona que baje ligeramente la frecuencia de la portadora, pero todo sigue funcionando; Yo particularmente siempre he usado uno de 1nF (de buena calidad por supuesto), ya que el de 820pF se me ha hecho difícil de conseguir.

Respecto de que la bobina con núcleo de aire causa interferencia, es verdad, pero se puede solucionar cuando al final se coloca todo dentro de un casis metálico (conectado a masa).

En cuanto a la medición de frecuencia, si se realiza antes de la bobina se debe registras una frecuencia elevada (la de la portadora) cercana a los 200KHz. Si se realiza después de la bobina se tendrá una media en el rango de audio < 20KHz; si aquí se registrara una alta frecuencia, solo significa que la bobina no sirve. Esto ocurre cuando el núcleo utilizado para su confección no es capaz de operar en ese rango, se habrá saturado haciendo que se pierda la inductancia y será como si se colocara un simple trozo de alambre.

Adjunto las medidas obtenidas por simulación: antes de la bobina (en verde) se observa la portadora, aproximadamente unos 30 ciclos en 200uS, lo que significa una frecuencia de 150KHz. Después de la bobina (en rojo) se ha extraído ya la información de la portadora, por acción del filtro paso bajo (bobina y capacitor), se observa una señal sinusoidal de 10KHz, que corresponde en éste caso, a la que usé en la entrada del circuito, para hacer la simulación.

Hasta la próxima…
Imágenes Adjuntas
Tipo de Archivo: jpg amp200W.jpg (131,5 KB (Kilobytes), 76 visitas)
19/03/2016 #1664


Muy bueno pilm, podrías postear la simulación con el archivo proteus?
19/03/2016 #1665

Avatar de pilm

Con gusto crazysound, aquí dejo el archivo (en Proteus 8.3).


Lo verán un poco diferente al original, es debido a que he utilizado componentes que tenía a mano y además he añadido dos cosa: primero; un filtro pasa bajos (U1:B) porque está pensado para amplificar un subwoofer, y entonces solo me interesa amplificar las bajas frecuencias; ojo que con los componentes que constan en el diagrama, por el momento, deja pasar todo el rango de audio, habría que recalcular R18, R26, C6, C2 a la frecuencia de corte deseada. Segundo; una entrada diferencial (U1:A). Me gusta mucho este tipo de entrada porque permite colocar la fuente de sonido a buena distancia del amplificador, sin tener que preocuparse por cables de audio apantallados, de hecho, la señal se puede llevar con un simple cable gemelo sin tener el problema que se ruido. Y si se quiere usar entrada simple, se lo puede hacer, eligiendo cualquiera de las entradas respecto a tierra, con la ventaja que si se elige la una o la otra se logra una salida en fase o contrafase respecto a la entrada, lo cual también es de utilidad.


A carbajal se me olvidaba decirle que revise si no se han abierto las resistencias de 680ohm (en las compuertas de los msfets), pues estas ayudan en el momento más crítico, es decir cuando se deben “apagar” los mosfets y si se han abierto, todo el trabajo lo estarán haciendo los transistor del driver. Depende además de los mosfets que se esté usando, pues cada tipo tiene su propia carga de compuerta-surtidor (Qgs), característica que si es muy alta, el driver podría no ser capaz de soportarlo, considérese además el hecho de que no siempre se consiguen componentes originales y que por tanto no tienen las características esperadas.



Saludos…
Archivos Adjuntos
Tipo de Archivo: rar ampificador_01.rar (762,0 KB (Kilobytes), 98 visitas)
20/03/2016 #1666


Hola Pilm, por qué no responde la gráfica cuando le hago modificaciones (por ejemplo la frecuencia)?

Saludos..
20/03/2016 #1667


Gracias amigos por sus sugerencias y/o soluciones dadas. Quiero comentarles a todos por si les sirve mi experiencia. Resulta que los componentes eran falsificados o truchos como dicen por aqui, los drivers se calentaban demasiado por la razon de que los mosfet eran de mala calidad, compre otros de International Rectifier y estos funcionaron de primera, los drivers calientan pero no mucho y el capacitor de 1nf no es problema, funciona muy bien, otro problema que tuve como mencionaba Pedro Yamarte es que a la salida habia voltaje, la razon era que el integrado TL074 tambien era de mala calidad, compre varios, todo lo mismo, hasta que compre la otra version TL084 y con ese integradito santo remedio, 0 voltajes a la salida, 0 calentamientos excesivos, todo en orden, la verdad que este amplificador es impresionante por la potencia que da y el pequeño tamaño, creo que todo es cuestion de ir haciendo pruebas de a poco, a mi me tomo mucho tiempo y un poquito de inversion pero al final tiene que ser uno de los componentes mayores diria yo los que den este tipo de problemas, los demas componentes no deberian dar problemas, me refiero a las resistencias, capacitores y zener, solo los mosfet, drivers o el integrado son los que ocasionan problemas.
PD: como no mucho me funcionaban los inductores con nucleo de aire, opte por comprar inductor ya fabricado, y descartados completamente los inductores de fuentes de pc amigos, no funcionan.
Les dejo imagenes de mi diseño.
Saludos!
Imágenes Adjuntas
Tipo de Archivo: jpg IMG-20160108-WA0006[1].jpg (29,2 KB (Kilobytes), 81 visitas)
Tipo de Archivo: jpg IMG-20160108-WA0008[1].jpg (33,5 KB (Kilobytes), 68 visitas)
20/03/2016 #1668

Avatar de pilm

Debería de funcionar crazysound, es solo realizar las modificaciones que estimes necesario, pulsar la barra espaciadora del teclado y esperar unos segundos; la gráfica debería actualizarse o entregar un mensaje de error en caso de que la simulación no sea posible. Si sigues teniendo problema, avísame. Creo que podría darme tiempo de hacer un video al respecto.


Carbajar, te felicito por el logro obtenido, ya me sospechaba que tu problema podría estar en los componentes utilizados, por acá donde vivo también es común los elementos truchos. Yo también, la primera vez que armé este artilugio me quedé impresionado con los resultados y desde entonces dejé completamente de lado los amplificadores AB. Recuerdo la reación de un amigo mío que se dedica a la amplificación profesional en espectáculos públicos; primero cuando se lo mostré, me dijo que estaba loco, se burló sobre todo del pequeño disipador en los transistores y dijo que a lo sumo entregaría unos 5W. Lugo cuando lo probamos e uno de sus propios bafles, se quedó sin palabras y solo lo miraba desconcertado. En fin…. Ahí les pongo una imagen de aquel que fue el primero que construí, ahora lo guardo como recuerdo de un buen logro.


Por estos días estoy empeñado en volver a construir uno y como me gusta ir introduciendo mejoras, me he propuesto modificarlo para que los dos mosfets sean canal N, pues quienes ya lo armaron abran notado que a diferencia del de canal N que casi no necesita disipador, el de canal P se calienta un poco, además los de canal P no se consiguen en variedad de tipos, en caso de querer cambiarlos para sacarle más potencia. Por el momento lo tengo ya funcionando en el simulador, después de haber cambiado por completo los drivers. Aquí les comparto una captura de pantalla, a ver qué les parece y sobre todo si alguien tiene sugerencias, bienvenidas…


Saludos…
Imágenes Adjuntas
Tipo de Archivo: jpg primero.jpg (91,9 KB (Kilobytes), 161 visitas)
Tipo de Archivo: jpg modificado.jpg (137,7 KB (Kilobytes), 137 visitas)
21/03/2016 #1669


Hola Pilm, te quedó muy prolija la placa!!

Esos to-220 que están sin disipador en que parte del circuito van? Son estabilizadores que has cambiado por los zeners?

Lo de la simulación, me pone un cartel que dice que "no corre en tiempo real porque es excesiva carga para la cpu" según lo que entiendo.

Saludos..
22/03/2016 #1670

Avatar de pilm

Pues sí, estimado Crazysound, los TO220 sin disipador que se observan en la foto corresponden al 7805 y 7905 que he usado en vez de los reguladores con zener. Lamento que tengas problema con la simulación, a mi corre perfecto...


Un saludo a todos.
22/03/2016 #1671


Hola Pilm, notás cambios "al oido" al reemplazar los zeners por los reguladores?

Saludos..
22/03/2016 #1672

Avatar de pilm

No podría contestarte esa pregunata Crazysound, pues nunca lo he armado usando zeners, siempre lo he hecho con reguladores 7805 y 7905
10/04/2016 #1673

Avatar de rafanate

carbajal dijo: Ver Mensaje
PD: como no mucho me funcionaban los inductores con nucleo de aire, opte por comprar inductor ya fabricado, y descartados completamente los inductores de fuentes de pc amigos, no funcionan.
Les dejo imagenes de mi diseño.
Saludos!
Carbajal yo he usado sin problemas en varios derivados de este diseño, el núcleo EI28 de las fuentes de PC más simples haciéndole un GAP de 1mm en el centro de la E con un Dremel, bobinado con 11 espiras (7 hilos de 0.3mm entorchados) bien pegado con resina, para potencias menores a 150W.
Otras personas en el foro han experimentado con el núcleo EI35 y el EI33 con buenos resultados para potencias mayores, que también puedes encontrarlos en las fuentes de PC AT o ATX genéricas.
Con los toroides de salida de polvo de hierro de estas fuentes no sirve, se saturan.
Si deseas usar un toroide los de la mezcla 2 de color rojo funcionan bien pero en mi país no los comercializan.
Y en mi caso una bobina mal implementada producía excesivo calentamiento en los Mosfet y los drivers por lo que esta bobina es de vital importancia para el correcto funcionamiento del circuito.

---------- Actualizado después de 15 minutos ----------

pilm dijo: Ver Mensaje
Cuando lo construí realicé barias mediciones para verificar su funcionamiento. Si mal no recuerdo, la señal PWM a la salida de los mosfets casi llega a los 200KHz, razón por la que los núcleos en las fuentes de PC no sirven para la bobina del filtro de salida. Si no es posible conseguir un núcleo capaz de trabajar a esa frecuencia (como fue mi caso), lo mas adecuado es construir la bobina con núcleo de aire.
No todos los nucleos de PC son malos, este EI28 soporta 300Khz y al realizarle un pequeño GAP de 1mm en el centro de la E, la posible saturacion se reduce considerablemente. La bobina de aire es voluminosa y genera interferencias considerables.

Adjunto prueba con osciloscopio de la bobina con EI28 conectada a un Subwoofer, se puede apreciar que no se satura a lo largo de una cancion, la prueba la hice a bajo volumen luego adjunto una imagen a maxima potencia.
Imágenes Adjuntas
Tipo de Archivo: jpg ei28.jpg (9,3 KB (Kilobytes), 62 visitas)
Tipo de Archivo: png EI28.PNG (61,4 KB (Kilobytes), 61 visitas)
Tipo de Archivo: png EI28_GAP.png (179,4 KB (Kilobytes), 73 visitas)
Tipo de Archivo: png EI28_test.PNG (46,0 KB (Kilobytes), 49 visitas)
Tipo de Archivo: png EI28_test2.png (15,2 KB (Kilobytes), 48 visitas)
14/04/2016 #1674


hola, buenas tarde gente, excelente proyecto el del ing Tagle, tengo una consulta, el hablo de una forma de implementar un driver discreto para poder usar ambos mosfet canal N, estoy hablando de la versión UCD, la que usa el lm311, alguien sabes cual es el circuito, existe algún pcb o algo?. se que hablo que para la implementación del driver discreto hacia falta el uso de unos diodos particulares, los bat54, pero nunca pude dar con ningún diagrama, existe alguna forma de modificar el driver discreto del UCD de forma fácil?, disculpen si alguien lo trato al tema, yo no pude encontrar nada concreto, vi que muchos decidieron modificarlo para poder usar el mosfet canal N pero no se si realmente funciono, ante todo gracias! saludos.
15/04/2016 #1675

Avatar de experimentador

techoo dijo: Ver Mensaje
hola, buenas tarde gente, excelente proyecto el del ing Tagle, tengo una consulta, el hablo de una forma de implementar un driver discreto para poder usar ambos mosfet canal N, estoy hablando de la versión UCD, la que usa el lm311, alguien sabes cual es el circuito, existe algún pcb o algo?. se que hablo que para la implementación del driver discreto hacia falta el uso de unos diodos particulares, los bat54, pero nunca pude dar con ningún diagrama, existe alguna forma de modificar el driver discreto del UCD de forma fácil?, disculpen si alguien lo trato al tema, yo no pude encontrar nada concreto, vi que muchos decidieron modificarlo para poder usar el mosfet canal N pero no se si realmente funciono, ante todo gracias! saludos.

No te compliques la vida en vano compañero si con el IR es mas simple de hacerlo funcionar y de comprobar si algo falla, mi humilde opinión.
18/04/2016 #1676


rafanate dijo: Ver Mensaje
Carbajal yo he usado sin problemas en varios derivados de este diseño, el núcleo EI28 de las fuentes de PC más simples haciéndole un GAP de 1mm en el centro de la E con un Dremel, bobinado con 11 espiras (7 hilos de 0.3mm entorchados) bien pegado con resina, para potencias menores a 150W.
Otras personas en el foro han experimentado con el núcleo EI35 y el EI33 con buenos resultados para potencias mayores, que también puedes encontrarlos en las fuentes de PC AT o ATX genéricas.
Con los toroides de salida de polvo de hierro de estas fuentes no sirve, se saturan.
Si deseas usar un toroide los de la mezcla 2 de color rojo funcionan bien pero en mi país no los comercializan.
Y en mi caso una bobina mal implementada producía excesivo calentamiento en los Mosfet y los drivers por lo que esta bobina es de vital importancia para el correcto funcionamiento del circuito.

Amigo me referia a los toroides de polvo de hierro, esos no sirven, lo digo porque hay quienes como yo me imagino, solo sacan los toroides ya bobinados y los ponen porque se ven como que deberian funcionar, al menos yo asi hice las primeras pruebas, el amplificador funciona con esos toroides pero se calientan extremadamente y a cierto volume el sonido se distorciona, de tal manera que no son una buena opcion. Con un nucleo de los EE-28 u otros de los que mencionas con su respectivo Gap, claro que son excelentes, ya que como el nucleo es ferrita, se logra filtrar la portadora y el amplificador suena divino, solo que por cuestiones de tiempo y carencia de materiales no hice la prueba con un nucleo de esos y ademas que no cabe en la placa que diseñe.

Saludos!
26/04/2016 #1677


buenas! ya realize la plaqueta ofrecida por diego german!, ya hice el inductor para un parlante de 4 ohm! con nucleo de aire!, solo me falta probarlo. Tengo un amigo que tiene un amplificador con un trado de +-36v. calculando con el puente rectificador se iria hacia 50.9v. Vi que lo probaron a +-45. Que dicen? podria probar con esa fuente? entrega 7amperes. cuando pueda paso fotos, ahora se me complico
26/04/2016 #1678

Avatar de experimentador

bejar dijo: Ver Mensaje
buenas! ya realize la plaqueta ofrecida por diego german!, ya hice el inductor para un parlante de 4 ohm! con nucleo de aire!, solo me falta probarlo. Tengo un amigo que tiene un amplificador con un trado de +-36v. calculando con el puente rectificador se iria hacia 50.9v. Vi que lo probaron a +-45. Que dicen? podria probar con esa fuente? entrega 7amperes. cuando pueda paso fotos, ahora se me complico

Si tenés transistores que aguanten mas de 100v probarlo, un 50% mas de 100v debería soportar
26/04/2016 #1679


experimentador dijo: Ver Mensaje
Si tenés transistores que aguanten mas de 100v probarlo, un 50% mas de 100v debería soportar
buenisimo! mañana realizo la prueba y comento quetal salio! lo que me preocupa son los dos capacitores electroliticos que soportan 50v!
26/04/2016 #1680

Avatar de experimentador

bejar dijo: Ver Mensaje
buenisimo! mañana realizo la prueba y comento quetal salio! lo que me preocupa son los dos capacitores electroliticos que soportan 50v!


Que transistores estás usando? los capacitores electrolíticos tienen que ser de mas voltaje
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Gran señal

Amplificadores de potencia en todas sus variantes: Válvulas, Transistores, Integrados.

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Gran señal

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.