Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Gran señal
Foros Registrarse ¿Olvidaste tu contraseña?
02/07/2013 #3441
Moderador

Avatar de Tacatomon

Dr. Zoidberg dijo: Ver Mensaje
Pregunto:
Por que no usan un software para diseño de PCB que sea BUENO? Uno que les permita pasar del esquemático al PCB para que no aparezcan errores de pistas mal conectadas o componentes que faltan. Lo digo por experiencia... por que esos errores son típicos de usar un soft para PCB pero teniendo el esquema en una hoja de papel....
Justo en el mes pasado empecé a ver las virtudes de lo que mencionas: Usar un programa de diseño que inmediatamente después de hacer el esquemático el mismo programa mande la PCB a trabajar.

Obviamente, el programa no lo hace todo. Hay que colocar los componentes en su lugar pero la ventaja es clara tal como lo dices. El margen de error se reduce bastante.

Don Rat ya debe de saber esto... Pero le encanta hacerla de Drama . Por falta de tiempo yo no he avanzado casi nada y los prototipos se han quedado en eso: Prototipos, ya que mis prioridades han cambiado, no planeo en estos próximos meses tratar de probar alguna PCB que salga a flote... En fin. Ya encontraré el tiempo y la manera.

Saludos!
02/07/2013 #3442


bueno pero les digo algo hay que tener un poco de compación (disculpas a las personas que se sientan ofendidas por esto) con las personas que han gastado tiempo y dinero para armar esta etapa yo propongo algo a las personas que tienen el diagrama esquemático bueno, si quieren me lo envían y yo tratare de realizar el pcb. los programas que tengo son Altium, sprinlayout, entre otros asi que en una semana se los tengo listo bueno si me lo permiten.

atte,
Ialvega
02/07/2013 #3443

Avatar de joryds

Tacatomon dijo: Ver Mensaje
Justo en el mes pasado empecé a ver las virtudes de lo que mencionas: Usar un programa de diseño que inmediatamente después de hacer el esquemático el mismo programa mande la PCB a trabajar.
hola Tacatomon, te recomiendo el programa de diseño Altium Designer 2013 versión 13.3.4, con esta herramienta vas a tener una completa sincronizacion del esquemático y el PCB.

en la imagen se obsserva la vista 3D para hacernos una idea de como va a quedar el prototipo final.

Saludos...
Imágenes Adjuntas
Tipo de Archivo: jpg Clase D-JD2000.jpg (76,5 KB (Kilobytes), 309 visitas)
02/07/2013 #3444

Avatar de Dr. Zoidberg

Tacatomon dijo: Ver Mensaje
Justo en el mes pasado empecé a ver las virtudes de lo que mencionas: Usar un programa de diseño que inmediatamente después de hacer el esquemático el mismo programa mande la PCB a trabajar.
Obviamente, el programa no lo hace todo. Hay que colocar los componentes en su lugar pero la ventaja es clara tal como lo dices. El margen de error se reduce bastante.
Es que es así, Tacato .
Vos sabés que yo uso el KiCad (que es libre y MUY bueno), pero la mayoría de los programas para diseño de PCB soportan generar un esquemático y a partir de él, generar el ratnest (JUA!!!! bueno para rat -mayor... ) que te vincula todas las conexiones a todos los componentes, y luego no podés rutear equivocado, a menos que te equivoques en el esquemático. Yo sé que al principio cuesta un poco acostumbrarse a esta técnica de trabajo, pero te garantizo que una vez que la adquieres, NUNCA JAMAS la vas a dejar .
Esta técnica yo la usaba (muy antiguamente ) con el OrCad mas el Tango PCB, pero ahora hago lo mismo con el KiCad y no es que se reduzca el margen de error.... es que directamente NO EXISTE margen de error si tenés bien el equemático.

PD: EL KiCad te hace el auto-place de los componentes en forma completamente automática (no muy recomendable para este tipo de PCB) o mitad manual y mitad automática, que es la que yo normalmente uso aunque no zafo de tener que acomodar las cosas. También tiene un par de auto-routers, pero nunca los recomiendo para PCBs mayoritariamente analógicos como los de los amplificadores.
02/07/2013 #3445
Moderador

Avatar de Ratmayor

El Express PCB puede generar el PCB a partir del esquemático, pero el momento de diseñar el PCB no tenía el esquemático sino en PDF, tenía multiples interrupciones del servicio electrico, dolores de cabeza por el trabajo y en fin toda clase de sabotaje, en estos momentos tanto tacato como este servidor andamos en otras prioridades, pero no nos hemos olvidado del proyecto y de sus mejoras, en cuanto estemos más desocupados retomaremos el nuevo diseño...

Dr. Zoidberg dijo: Ver Mensaje
Es que es así, Tacato .
Vos sabés que yo uso el KiCad (que es libre y MUY bueno), pero la mayoría de los programas para diseño de PCB soportan generar un esquemático y a partir de él, generar el ratnest (JUA!!!! bueno para rat -mayor... ) que te vincula todas las conexiones a todos los componentes, y luego no podés rutear equivocado, a menos que te equivoques en el esquemático. Yo sé que al principio cuesta un poco acostumbrarse a esta técnica de trabajo, pero te garantizo que una vez que la adquieres, NUNCA JAMAS la vas a dejar .
Esta técnica yo la usaba (muy antiguamente ) con el OrCad mas el Tango PCB, pero ahora hago lo mismo con el KiCad y no es que se reduzca el margen de error.... es que directamente NO EXISTE margen de error si tenés bien el equemático.

PD: EL KiCad te hace el auto-place de los componentes en forma completamente automática (no muy recomendable para este tipo de PCB) o mitad manual y mitad automática, que es la que yo normalmente uso aunque no zafo de tener que acomodar las cosas. También tiene un par de auto-routers, pero nunca los recomiendo para PCBs mayoritariamente analógicos como los de los amplificadores.
Bueno, lo descargaré a ver, pero solo por lo de ratnest

Saludos...
02/07/2013 #3446

Avatar de SERGIOD

Y que dicen del Eagle tiene auto-ruteo y es muy bueno
02/07/2013 #3447
Moderador

Avatar de Tacatomon

Yo creo que opciones para Diseñar la PCB no hacen falta...

El tema es Saber diseñar la PCB para este amplificador.
Como saben, este amplificador no funciona de igual manera que un Amplificador Clase AB. Requiere de técnicas de ruteo muy buenas para minimizar problemas y deficiencias de funcionamiento.
Ya el Ing. Tagle ha dicho que la forma ideal de hacer la PCB es que fuese de doble cara, tal como los diseños comerciales profesionales, pero al mismo tiempo que hacemos algo así mucha gente pierde acceso a elaborar este maravillos amplificador.

Desde el principio, mi idea fue tan solo expandir las lineas de potencia en la PCB original, ya que se podría decir que es la única deficiencia de ésta. Y debo decir que es necesaria, ya que muchos de los interesados en el montaje del amplificador, ansían mas que 200W. Y para eso, se requiere una PCB grande y más versátil a la hora del montaje.

A estas alturas, Ratmayor ha estado trabajando con los sistemas de protección del amplificador y hemos investigado por un método de control automático del Offset. Pero todo esto requiere tiempo para probarse, ya que se necesita invertir tanto dinero como tiempo en el prototipo. Cuando estén las primeras versiones del diagrama final, se las haremos saber acá en el tema. Ya luego veremos por un buen diseño de PCB.

Repito, al no ser un amplificador común, se complica bastante el tiempo de pruebas, ya que cuando normalmente un Clase AB lo arreglas y ajustas fácilmente con un multímetro Chino, un Clase D no puedes mirarlo sin Un Osciloscopio de por medio.

Todo esto que se hace, se hace para la comunidad y nada más. Así que, esperamos seguir trabajando de a poco para poder llegar a ver el amplificador en todo su esplendor.

Saludos al foro!
02/07/2013 #3448


Tacatomon dijo: Ver Mensaje
Yo creo que opciones para Diseñar la PCB no hacen falta...

El tema es Saber diseñar la PCB para este amplificador.
Como saben, este amplificador no funciona de igual manera que un Amplificador Clase AB. Requiere de técnicas de ruteo muy buenas para minimizar problemas y deficiencias de funcionamiento.
Ya el Ing. Tagle ha dicho que la forma ideal de hacer la PCB es que fuese de doble cara, tal como los diseños comerciales profesionales, pero al mismo tiempo que hacemos algo así mucha gente pierde acceso a elaborar este maravillos amplificador.

Desde el principio, mi idea fue tan solo expandir las lineas de potencia en la PCB original, ya que se podría decir que es la única deficiencia de ésta. Y debo decir que es necesaria, ya que muchos de los interesados en el montaje del amplificador, ansían mas que 200W. Y para eso, se requiere una PCB grande y más versátil a la hora del montaje.

A estas alturas, Ratmayor ha estado trabajando con los sistemas de protección del amplificador y hemos investigado por un método de control automático del Offset. Pero todo esto requiere tiempo para probarse, ya que se necesita invertir tanto dinero como tiempo en el prototipo. Cuando estén las primeras versiones del diagrama final, se las haremos saber acá en el tema. Ya luego veremos por un buen diseño de PCB.

Repito, al no ser un amplificador común, se complica bastante el tiempo de pruebas, ya que cuando normalmente un Clase AB lo arreglas y ajustas fácilmente con un multímetro Chino, un Clase D no puedes mirarlo sin Un Osciloscopio de por medio.

Todo esto que se hace, se hace para la comunidad y nada más. Así que, esperamos seguir trabajando de a poco para poder llegar a ver el amplificador en todo su esplendor.

Saludos al foro!
Tenés toda la razón, Tacatomón... El problema de los amplis clase D, es que requieren una mezcla de técnicas de diseño para alta potencia , y para RF, ya que acá estamos trabajando con frecuencias del orden de 200khz, pero las armónicas superan con creces esa frecuencia base... y con corrientes grandes. Eso complica el ruteo y lo hace más crítico de lo normal. Usar placa doble faz tiene como ventajas poder usar un lado de pantalla para aislar el ruido, y a la vez, suprimir la inductancia parásita donde no se la requiera... y con cuidado, reforzar las pistas también... Pero, requiere tiempo y paciencia el diseño... Para que se den una idea, las placas de estos amplis me llevaron 1 semana de diseño cada una, dedicándoles unas 8 horas diarias... El diseño fue hecho con Altium, como sugiere js, porque es el programa más flexible que he encontrado en diseño multifaz... Pero, el precio es que ese programa es de los más complejos que he usado alguna vez... enfin, no es la única opción.
Hay que encontrar un equilibrio entre complejidad de armado, de aprovisionamiento de componentes, de facilidad de reproducción de la placa, etc, etc... y no es sencillo realmente.. :S

Saludos!
03/07/2013 #3449

Avatar de jesus herney

si el diseño es muy fundamental en estos amplis clase d en la vercion 3.6 pude notar mucho mas el efecto de lluvia, y creo que se devio al trayecto muy largo que tenia la ruta de done se tomaba la señal de ralimetacion, notese en la vercion origuinal la ruta es supremamente corta, para el proximo diseño se deveria tener encuenta este punto
03/07/2013 #3450
Moderador

Avatar de Tacatomon

Al hacer la PCB mas grande, Si o Si necesita ser de Doble Cara... Se aumenta mucho las zonas que emiten EMI y también las que reciben, como la delicada Re-alimentación.
Anota esto @Ratmayor.

(Suspiro grande)

...

Bueno, ya veremos cuando tengamos avances en el diagrama final.
09/07/2013 #3451


Buenas noches! He estado revisando el post, voy en la pagina 240, pero me gano la curiosidad y recién he visto que ya existe una versión 3.7???
Podrían indicarme que numero de post es?
Por lo demás, prometo ir leyendo para descubrir los cambios por mi mismo.
Gracias!

---------- Actualizado después de 4 minutos ----------

Una cosa mas! desde otro foro, me arme otra versión UcD también de ejtagle, el amplificador va de perlas, lo alimento con una ATX modificada, modificación que el mismo ejtagle tuvo a bien sugerir.
El problema radica en que cuando conecto el amplificador a mi celular, el celular queda completamente bloqueado del touch screen, apenas desconecto el amplificador, se restablece l funcionalidad del toucscreen.
Se que el problema es influido por la fuente, ya que hace poco lo alimente con una fuente lineal y no me sucedió esto. Alguna sugerencia?
Se que esto es un completo Offtopic, asi que de antemano pido disculpas al moderador y si posible, pido que se mueva al lugar adecuado. Gracias.
09/07/2013 #3452

Avatar de djwash

Por el momento se recomienda que armen la version original, Taca lo dijo por aqui:

Tacatomon dijo: Ver Mensaje
Jesus Herney logró localizar el problema. Esas PCB's están con errores de diseños y no se recomiendan para armar.

Y si, esas PC's están vetadas. No se recomiendan para ensamblar. Por el momento, sigan usando la PCB Original o sus propios Diseños. En lo que Taca & Rat Inc. hacen el trabajo completo... XD

Saludos al foro!
Y el tema que se te bloquea el celular, se puede deber a EMI prodicida por el amplificador o como bien dices la fuente, a mi me paso lo mismo con la PC, pero un tanto diferente, conectada al ampli no habia problema, pero cuando yo tocaba el mouse y el ampli al mismo tiempo se congelaba la PC, al soltarlo seguia como si nada, bastante raro y eso que usaba fuente lineal...

Te recomiendo que analices el tema de bucles de masa, blindaje, y puesta a tierra.
02/08/2013 #3453


amigo soy nuevo he hecho este ampli y cuando le doy volumen hace raro la corneta y el sonido es excelente, no se de donde viene, esta hecho justo como el diagrama.

---------- Actualizado después de 3 minutos ----------

Oscar Monsalvo dijo: Ver Mensaje
Este amplificador es exelente!

Les comento que ya mi amplificador trabaja mejor, aca estan la foto de como quedó:

http://a.imageshack.us/img90/101/foto0212.jpg

Acá muestro las bobinas con las que he hecho pruebas, la grande es con la que mejor me ha trabajado, el solenoide fué la primera que usé pero con esa aparecia humm en la salida, luego intenté con el toroide pequeño, pero se me calentaban los transistores, y pues con la grande no hay ruido en la salida y los mosfet solo entibian, la bobina tampoco calienta nada de nada, las pruebas las hice con un par de 12", resultado: buen medio y buenos graves (aun no he probado frecuencias altas).

No me pregunten que calculo usé para la bobina porque la hice al tanteo ya que no poseo ningun dato del toroide de polvo de hierro, aunque pienso medirla con un inductometro para ver de cuanto quedó.

http://a.imageshack.us/img90/636/foto0213.jpg

Lo unico que noté es que cuando lo probaba con graves al subirle bastante volumen los parlantes me hacian un ruido extraño, esto solo a altos volumenes, aunque tal vez sea por el recorte o clipping .

Me tomé el atrevimiento de alimentar la fuente de corriente a través de una fuente con resistencia + zener de 15V y la disipacion de calor de los transistores asociados se redujo considerablemente. Lo hice porque pienso alimentarlo con la fuente de mi amplificador de graves de +-95Vdc y si se calientan con +-50V mucho mas con +-95v y sinceramente me preocupa que me deje tirado a la mitad de un baile.

Les comento que comencé un nuevo diseño de un PCB para alta potencia (respetando las normas del diseño original) ya que en el PCB original hay resistencias que por su gran tamaño no encajarían, cuando lo termine lo compartiré con ustedes para que le den el visto bueno y dejarlo a disposicion de todo el foro.

Por lo demás, muy buen amplificador, de nuevo gracias al Ingeniero Eduardo por compartirlo y a todos los amigos que comentaron

Saludos

"Creo que ya es hora de ir dejando a un lado las etapas lineales"
amigo a mi también me hace raro cuando le doy volumen, que podrá ser? El audio es muy lindo, solo que con graves no me suena bien, aparece ese defecto.
03/08/2013 #3454


yaniel dijo: Ver Mensaje
amigo soy nuevo he hecho este ampli y cuando le doy volumen hace raro la corneta y el sonido es excelente, no se de donde viene, esta hecho justo como el diagrama.

---------- Actualizado después de 3 minutos ----------



amigo a mi también me hace raro cuando le doy volumen, que podrá ser? El audio es muy lindo, solo que con graves no me suena bien, aparece ese defecto.
Eso son problemas de fuente... Está cayendo casi seguro la tensión ...
12/08/2013 #3455


buenas amigo el ampli no deja de sonar bien solo que cuando le pongo grabes suena con un sonido detrás de la música la fuente era de un ampli yamaha tiene por rama 60v con una corriente de 15a los filtros son de 1000mf por 100v el inductor podría estar asiendo este efecto
12/08/2013 #3456

Avatar de Delphos

Hola amigo Yaniel, 1000 mf. se me hace poco filtraje, dependiendo de la potencia de tu ampli, esto podria ser el problema, ya que con bajos demanda mas corriente, generalmente como minimo le pones filtros de 4700 mf.

Saludos
12/08/2013 #3457


Delphos dijo: Ver Mensaje
Hola amigo Yaniel, 1000 mf. se me hace poco filtraje, dependiendo de la potencia de tu ampli, esto podria ser el problema, ya que con bajos demanda mas corriente, generalmente como minimo le pones filtros de 4700 mf.

Saludos
disculparme amigo me equivoque el valor que estoy usando es 10 000 mf

---------- Actualizado después de 4 minutos ----------

yaniel dijo: Ver Mensaje
disculparme amigo me equivoque el valor que estoy usando es 10 000 mf
tengo la duda con el inductor no lo estoy asiendo correctamente debido a que no tengo la herramienta para medirlo use uno de un ampli de carros clase d pero no se su valor y ase lo mismo esta bobina puede estar asiendo la falla en el audio con volumen fuerte es el los grabes nada mas
13/08/2013 #3458

Avatar de idem258

Buenaas tardes señores... ahora los molesto para consultar lo siguiente:
Cuando recien enciendo el ampli, este capta una emisora de AM y se escucha mmuy claro en el Su woofer. Como logro elminar este problema?
Pienso ademas que como la placa la tengo aun sin colocar en algun gabinete y el cable que sale desde la pc y va hasta el ampli es largo; casi 2 mt, supongo que acturá como antena no? ahhhhh... cuando quito el plug de la pc, se oye un zumbido muy fuerte en el parlante.
13/08/2013 #3459
Moderador

Avatar de Tacatomon

yaniel dijo: Ver Mensaje
disculparme amigo me equivoque el valor que estoy usando es 10 000 mf

---------- Actualizado después de 4 minutos ----------


tengo la duda con el inductor no lo estoy asiendo correctamente debido a que no tengo la herramienta para medirlo use uno de un ampli de carros clase d pero no se su valor y ase lo mismo esta bobina puede estar asiendo la falla en el audio con volumen fuerte es el los grabes nada mas
¿Fotos de la Bobina?

idem258 dijo: Ver Mensaje
Buenaas tardes señores... ahora los molesto para consultar lo siguiente:
Cuando recien enciendo el ampli, este capta una emisora de AM y se escucha mmuy claro en el Su woofer. Como logro elminar este problema?
Pienso ademas que como la placa la tengo aun sin colocar en algun gabinete y el cable que sale desde la pc y va hasta el ampli es largo; casi 2 mt, supongo que acturá como antena no? ahhhhh... cuando quito el plug de la pc, se oye un zumbido muy fuerte en el parlante.
¿Estás usando un Preamplificador a la entrada del Amplificador?
13/08/2013 #3460


ejtagle dijo: Ver Mensaje
Eso son problemas de fuente... Está cayendo casi seguro la tensión ...
buenas amigos ejtagle cuando me dieses que tengo problemas de caída de tencion es por la falta de amperios del trasfor cuanto es lo mínimo de aperes con que trabaja el ampli e leído que trabaja con barios voltaje por rama pero la corriente no se debe variar voy a probar con otra fuente de mas corriente y les cuento
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Gran señal

Amplificadores de potencia en todas sus variantes: Válvulas, Transistores, Integrados.

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Gran señal

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.