Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Gran señal
Foros Registrarse ¿Olvidaste tu contraseña?
25/10/2009 #81


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
@ tacatomon.... No creo que haya problemas con los capacitores...

Sobre el tema del filtro de salida, no se puede sacar. El ampli UcD necesita ese filtro para operar... El porqué del núcleo de aire, en vez del núcleo de ferrite, es por una cuestión de simplicidad de armado... El núcleo de ferrite hay que conseguirlo... No es por el tema costo (porque el inductor de nucleo de ferrite lleva mucho menos cobre, y el núcleo en sí no es caro... O sea, termina saliendo más barato... Si es que se consigue el núcleo... Además, si se usa un núcleo de ferrite , la cantidad de vueltas de alambre necesario depende del núcleo que consigan...

Saludos
25/10/2009 #82


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
@ tacatomón : Cualquier circuito de protección de altavoces andará con este ampli UcD... Con el que no andaban era con el SwitchingAmp con el Tl074... Pero en el caso de este ampli, sí anda.

Saludos

Y para aquellos que preguntan... Sería posible agregar protección contra cortocircuitos a la salida usando la entrada de Shutdown del IR2110 .... Pero eso complica el diseño, por eso no lo puse...
25/10/2009 #83

Avatar de bebeto

Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Hola. una consulta.... tengo una fuente de 42 - 0 - 42 y rectificado tengo 50 - 0 - (-50)

cual tendria que hacer,¿ el que figura para 57 o el que figura para 40?
la ultima y no pegunto mas ( por ahora )
La corriente que indica es PICO por canal no?
25/10/2009 #84


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
para bebeto: el de 57v... no vas a obtenr la potencia maxima especificada, pero debería andar bien... También se podría hacer el de 40v, pero teniendo la precaución de poner capacitores que soporten la tensión de 50v

para manutec: Tengo mis dudas sobre el tema de los IGBT... No son tan rápidos como se requiere para obtener alta fidelidad (al menos 250khz de frecuencia de conmutación...) , y además, tnés el problema asociado a los transistores... Es decir... lentitud en el apagado... Para controlar motores, esos no son problemas, pero, para audio..

Saludos!
26/10/2009 #85


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
FELIBAR12 dijo: Ver Mensaje
Cuales fueron tus inconvenientes?, yo tuve un problema alguna vez de componentes de DC a la salida pero todo era por el inductor..........
Por lo que medí, no tuve inconvenientes de DC a la salida. Tenía el pre (de mic), la potencia y el inductor en un mismo gabinete (bastante cerca unos de otros). De movida, así ni arrancó (lámpara en serie destellaba y ruido de golpes en el parlante), creo yo por un problema de oscilación . Saqué el inductor del gabinete y sí anduvo..... un tiempo pero a los pocos días se terminaron quemando los mosfet. Los mosfet calentaban un poco más con el pre conectado. Sin el pre lo tuve andando super bien.
Tengo que probar todavía lo que me propone Ejtagle, blindar la etapa de potencia (o el pre, o las dos). Seguramente hacer el inductor con un toroide como mencionás, mejore las cosas cosiderablemente.
De todas formas me falta aprender mucho en esto de los clase D, pasan cosas que con un AB jamás pasarían.
Agradezco al foro!!!
Saludos
27/10/2009 #86

Avatar de Papusxxdd

Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Tengo armado la placa entera pero no me esta funcionando, sospecho que pueden ser los 4 transistores 2n5401 que en este caso los reemplacé por bf423 (cambia el sentido de las patas) estos me dieron como reemplazo pero no me creo que sirban, y tambien reemplecé los diodos 1n5817 por 1n5819 (creo que no tiene que haber problema con esto), tambien el uf4004 por un mur160; y bueno los dos capacitores de mica de 330p y 470n no conseguí puse poliester.-

Lo armé para trabajar con +/- 40 y bueno la fuente que tengo es de +/- 45 y al conectarlo sube la corriente en la salida hasta 20 voltios continua y no baja significativamente y no hay nada que caliente ni nada raro, que puede ser? igual voy a conseguir los transistores 2n5401 o recien me di cuenta que los mpsa92 andarian, alguna recomendación... escucho
Imágenes Adjuntas
Tipo de Archivo: jpg P1010942.JPG (121,1 KB (Kilobytes), 1774 visitas)
Tipo de Archivo: jpg P1010941.JPG (105,3 KB (Kilobytes), 1597 visitas)
28/10/2009 #87


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Bueno, veo que hay gente con problemas (cuando no! ) --- Por lo tanto, vamos con las mediciones necesarias...
> Medir entre la pata 8 del LM311 y masa, con la punta positiva en la pata 8. Tiene que haber 3.3v aproximadamente (+/-0.2v) -> Si no hay, revisar DZ1, C15, C11, R15...
> Medir entre la pata 4 del LM311 y masa con la punta positiva en la pata 4. Tiene que haber -3.3v aproximadamente (+/-0.2) -> Si no hay, revisar DZ2. C21, C19, R17...
== Para las próximas pruebas, desconectar L1 y no conectar nada en su lugar
> Unir las patas 3 y la 4 del LM311.. Deberán medir que entre la pata 1 del LM311 y masa (punta positiva del téster en la pata 1), la tensión baja por debajo de -1 volt (debería dar -2.2v aprox, pero, mientras sea por debajo de -1v, todo está bien)
También , tienen que poder medir que entre las patas de R8 hay al menos 10 volts, y entre las patas de R9 hay 0 volts. Si no es así, revisar Q1/Q2/Q3/Q4 y R3/R6.
También, esas mismas tensiones tienen que llegar a las patas 10 y 12 del IR2110. Es decir, poniendo el negativo del téster en -VCC, en la pata 12 del IR tiene que haber al menos 10v , y en la pata 10, 10 volts.
Medir la tensión entre la pata 9 del IR2110 y -VCC. Tiene que dar más de 11.3 volts. Si no da, revisar Q5, DZ2, R16 y los capacitores asociados
Medir la tensión entre la pata 1 del IR2110 y -VCC. Tiene que dar 10 volts al menos.
Medir la tensión entre la pata 6 y la pata 5. Tiene que haber al menos 10 volts.
Finalmente, entre la pata 5 del IR y -VCC tiene que haber 0 volts. Si no hay, revisar la polaridad de los mosfets, y las resistencias R4 y R12, y que los mosfets estén en buen estado.
> Ahora, sacar el puente entre las patas 3 y 4 del LM311, y unir las patas 3 y 8 del LM311. Deberán medir que entre la pata 1 del LM311 y masa (punta positiva del téster en la pata 1), la tensión sube por arriba de 1 volt (debería dar 2.2v aprox, pero, mientras sea por arriba de 1v, todo está bien)
También , tienen que poder medir que entre las patas de R9 hay al menos 10 volts, y entre las patas de R8 hay 0 volts. Si no es así, revisar Q1/Q2/Q3/Q4 y R3/R6.
También, esas mismas tensiones tienen que llegar a las patas 10 y 12 del IR2110. Es decir, poniendo el negativo del téster en -VCC, en la pata 10 del IR tiene que haber al menos 10v , y en la pata 12, 10 volts.
Medir la tensión entre la pata 9 del IR2110 y -VCC. Tiene que dar más de 11.3 volts. Si no da, revisar Q5, DZ2, R16 y los capacitores asociados.

Después de todo eso, colocar L1. El amplificador deberia andar bien... Por supuesto, no viene de más revisar pistas, malas soldaduras, etc,etc

Saludos!
28/10/2009 #88
Moderador

Avatar de Tacatomon

Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
El TIP31 debe de calentar demasiado???
Toca MJL4281? a +-100V???

Ejtagle, Muchas Gracias por los TestPoints del amplificador!!!

Saludos!!!

PD: Las pruebas las hacemos con la entrada del amplificador a GND?
31/10/2009 #89


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
ejtagle dijo: Ver Mensaje
Bueno, veo que hay gente con problemas (cuando no! ) --- Por lo tanto, vamos con las mediciones necesarias...
> Medir entre la pata 8 del LM311 y masa, con la punta positiva en la pata 8. Tiene que haber 3.3v aproximadamente (+/-0.2v) -> Si no hay, revisar DZ1, C15, C11, R15...
> Medir entre la pata 4 del LM311 y masa con la punta positiva en la pata 4. Tiene que haber -3.3v aproximadamente (+/-0.2) -> Si no hay, revisar DZ2. C21, C19, R17...
== Para las próximas pruebas, desconectar L1 y no conectar nada en su lugar
> Unir las patas 3 y la 4 del LM311.. Deberán medir que entre la pata 1 del LM311 y masa (punta positiva del téster en la pata 1), la tensión baja por debajo de -1 volt (debería dar -2.2v aprox, pero, mientras sea por debajo de -1v, todo está bien)
También , tienen que poder medir que entre las patas de R8 hay al menos 10 volts, y entre las patas de R9 hay 0 volts. Si no es así, revisar Q1/Q2/Q3/Q4 y R3/R6.
También, esas mismas tensiones tienen que llegar a las patas 10 y 12 del IR2110. Es decir, poniendo el negativo del téster en -VCC, en la pata 12 del IR tiene que haber al menos 10v , y en la pata 10, 10 volts.
Medir la tensión entre la pata 9 del IR2110 y -VCC. Tiene que dar más de 11.3 volts. Si no da, revisar Q5, DZ2, R16 y los capacitores asociados
Medir la tensión entre la pata 1 del IR2110 y -VCC. Tiene que dar 10 volts al menos.
Medir la tensión entre la pata 6 y la pata 5. Tiene que haber al menos 10 volts.
Finalmente, entre la pata 5 del IR y -VCC tiene que haber 0 volts. Si no hay, revisar la polaridad de los mosfets, y las resistencias R4 y R12, y que los mosfets estén en buen estado.
> Ahora, sacar el puente entre las patas 3 y 4 del LM311, y unir las patas 3 y 8 del LM311. Deberán medir que entre la pata 1 del LM311 y masa (punta positiva del téster en la pata 1), la tensión sube por arriba de 1 volt (debería dar 2.2v aprox, pero, mientras sea por arriba de 1v, todo está bien)
También , tienen que poder medir que entre las patas de R9 hay al menos 10 volts, y entre las patas de R8 hay 0 volts. Si no es así, revisar Q1/Q2/Q3/Q4 y R3/R6.
También, esas mismas tensiones tienen que llegar a las patas 10 y 12 del IR2110. Es decir, poniendo el negativo del téster en -VCC, en la pata 10 del IR tiene que haber al menos 10v , y en la pata 12, 10 volts.
Medir la tensión entre la pata 9 del IR2110 y -VCC. Tiene que dar más de 11.3 volts. Si no da, revisar Q5, DZ2, R16 y los capacitores asociados.

Después de todo eso, colocar L1. El amplificador deberia andar bien... Por supuesto, no viene de más revisar pistas, malas soldaduras, etc,etc

Saludos!

Una pequeña fe de erratas... Ésta se me pasó, perdón ops: :
Cuando digo que las mismas tensiones que se miden sobre R8 y R9 tienen que estar sobre las patas 12 y 10 del IR, significa que si sobre R8 hay 10v, entre -VCC y la pata 12 tiene que haber esa misma tensión. Y cuando digo que si sobre R8 hay 0 volts, significa que entre -VCC y la pata 10 del IR2110 tiene que haber esa misma tensión. Hay un pequeño error en el texto... Las tensiones sobre R8 y R9 son las correctas, pero hay un error en la tensión a medir entre -VCC y las patas 12 y 10. Ne equivoqué, puse que siempre había que medir 10v entre -VCC y ambas patas, pero no es cierto:
>Si sobre R8 hay 10v, entre la pata 12 y -VCC del IR tiene que haber la misma tensión.
>Si sobre R8 hay 0v, entre la pata 12 y -VCC del IR tiene que haber la misma tensión.
>Si sobre R9 hay 10v, entre la pata 10 y -VCC del IR tiene que haber la misma tensión.
>Si sobre R9 hay 0v, entre la pata 10 y -VCC del IR tiene que haber la misma tensión.

Espero que esta vez haya quedado claro... Realmente se me pasó !
Saludos

PD: Ha llegado a mis oidos la información que se están comercializando 2n5401 truchos que tienen las patas al revés... Por favor, midan los transistores antes de ponerlos en la placa... Y ni hablar si usan algún transistor sustituto... La gran mayoría de los tésters actuales tienen medidor de transistores... Si al medirlo obtienen una ganancia (Hfe) menor que 100, seguro que las patas están invertidas. Prueben intercambiar colector por emisor. La posición en que el transistor les dé mayor HFE es en la que las patas están conectadas correctamente al téster (es decir, la pata que está conectada al emisor en el zocalo del téster, es el verdadero emisor, la pata que está conectada a la base en el zócalo del téster es la verdadera base, y la pata que está conectada al colector en el zócalo del téster es el verdadero colector), y es en la posición en que tendría que ir puesto en el ampli.
02/11/2009 #90
Moderador

Avatar de Tacatomon

Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Tengo una pequeña duda: Para la configuración 1250W@4 Ohm, se necesitun trafo de 70+70VAC pero... a cuantos amperes realmente, a 12.5A? Eso da una potencia de 1750W de trafo, 500W se van en calor??? Como? si es Class D
02/11/2009 #91


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
@ tacatomon... Hay un pequeño problema de redondeo, eso es todo. La potencia da bien...
04/11/2009 #92

Avatar de mnicolau

Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Hola Eduardo, podrías subir a este tema también el anterior UCD, con canal N y P, al 1º post. Hay mucha gente que no lo conoce y es un excelente amplificador, el cual armé con unos 5U$S.

Si no se necesitan potencias exageradísimas como las que alcanza esta versión canal N, es la mejor opción ya que no necesita del IR2110, y además los mosfets canal P para potencias de unos 200[W] (mucho más que suficiente para uso hogareño) son baratos y fáciles de conseguir.

Saludos
04/11/2009 #93


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
compañero ejtagle......he estado pensando en aumentar la eficiencia de este ampli......
mi idea es la siguiente....si logrameanvos hacer conmutar mas rapidamente a los mosfet de salida se bajara la disipacion de r de los ....

la idea es la siguiente.
fraccionar cada uno de los pulsos que entran al driver 2110....
como hacerlo......

comparando la señal pwm procedente del lm 311 con una triangular de mayor frecuencia.....o implementando 2 osciladores con 555 controlados con el enable por medio de las dos señales que entran al driver......

en estos momentos no tengo esquema para mostrar pero a lo mejor mas de uno entenderala idea.....

bueno mi pregunta es ?

servira esta implementacion teniendo en cuenta que este amplificador es autooscilante?
por que de ser haci se podrian lograr muchas cosas interesantes con este proyecto...
05/11/2009 #94


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
para Rodgers: Aumentar la frecuencia de conmutación va a hacer que aumente la disipación en los mosfets... No es recomendable, además, que a mayor frecuencia de conmutación, más distorsión... Está explicado en el thread anterior del ampli UcD...
Para mnicolau: Tenés razón... El ampli anterior andaba muy bien, y no necesitaba IR2110... El problema que yo le ví es que últimamente lso componentes que se están consiguiendo (léase, transistorcitos estilo BCxxx), son, literalmente, pedazos de mie###da con patas... Cones, muy inferiores a los transistores originales. Esoha causado montones de problemas con un ampli que no debiera tenerlos... Por eso, pienso que la versión con el IR es un poquito mejor (hasta que vengan IRs truchos :( ) ...
Para walter rodriguez... Evidentemente tenés algún problema... No puede haber ruido agudo a la salida... Insisto... ¿ Usaste cable blindado para la entrada de audio ???
Saludos!
05/11/2009 #95
Moderador

Avatar de Tacatomon

Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Ejtagle, creo que este Mosfet es interesante:

http://www.irf.com/product-informaci...rfp4668pbf.pdf

Como cuanta eficiencia se puede obtener de acuerdo a la RDSon.? Será este la joya de la eficiencia??? 10$Usd que valgan la pena?
06/11/2009 #96


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Holas
Bueno lo termine al ampli y ya lo tengo funcionando y anda que es una ma-ra-vi-lla¡ ,me pellisco para no creer que es un sueño, me parece que voy a tardar unos días en caer.
Casi no tuve problemas (a pesar que no use los elementos del listado ejm use capasitores de poliéster en algunos casos)al inicio tenia un tensión en la salida del parlante ,17v aprox.(para la prueba utilice +-22v) Que era dos resistencias que limitan la corriente de los zener era muy alta 2k2(r15 & r17) las baje a 1k y problema solucionado.
El segundo problema era que calentaba la bobina y los mosfet cambie de valores las r de los gates(r4 & r12) y nada ,que era? La bobina, en ves de bobinarla para 30uH la bobine para 3uH(que bolu¡) la cambie y funciono de las mil maravillas.
Gracias antes que nada ejtagle por este ampli y al resto del foro también gracias.
Unas fotos perdón por la desprolijidad


06/11/2009 #97


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
para tacatomon: Las pérdidas en los mosfets son directamente proporcionales al Rdson... Mitad de Rdson, es mitad de pérdida de potencia... Así de fácil... , lo que no significa, desgraciadamente que la eficiencia aumente al doble.. Porque la eficiencia se calcula como potencia entregada a la carga dividida por la potencia entregada por la fuente. Como en un clase D, la potencia entregada a la carga es igual a la potencia entregada por la fuente - la que se pierde en los mosfets - algo de potencia que se va en el circuito de control, si afinás el lápiz verás que la cantidad de potencia perdida en los mosfets ya no es grande, al menos para potencias razonables... Por lo que la eficiencia no aumenta muy mucho... Ahora, si la carga del amp fuera 2 ohms, de golpe esos mosfets se vuelven muy interesantes

Saludos!
06/11/2009 #98
Moderador

Avatar de Tacatomon

Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Para una corriente de 12.5A

Pmos = I*I*Rdson / 2
Pmos = 12.5*12.5*0.009/2 = 0.7W disiparían cada uno en la configuración de +-100V 1250W

Si que son interesantes, una lastima que solo sean de 200Vdss

Saludos!!!!!!


PD: Tambien encontré unos IGBT´s que se bancan mas de 150kHz, podrían servir?
www.irf.com/product-información/datasheets/data/irgp50b60pd1.pdf
06/11/2009 #99


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Para tacatomon: Posiblemente esos IGBTs podrían usarse... Eso sí, seguro que hay que ajustar las resistencias de gate ... Por lo demás calzan directo en el circuito... Eso sí, las pérdidas son un poco grandes... (tiene 2v de caída con 50A de corriente = 100W de disipación ... Habría que ver si realmente convienen o no...
Saludos
06/11/2009 #100


Respuesta: Ampli HighEnd ClaseD UCD de 25W a 1250Wrms sólo con 2 mosfets N
Saludo a todos los foristas y muchas gracias por todos esos aportes.
Les solicito el favor de ayudarme con el inductor. Tiene que ser necesariamente de forma toroidal? o se puede utilizar otra forma ? el nucleo debe ser necesariamente de aire ? o se puede utilizar otro material permeable o no permeable?.

La fuente de alimentacion puede ser lineal como las que se utilizan en los amplificadores clase AB o requiere de elemntos adicionales como filtros de linea, etc.
Agradecere inmensamente cualquier información.

Ya arme una tarjeta con este diagrama y hechas las mediciones sugeridas por el Sr. ejtagle todo esta en orden . El amplificador sin parlante arranca bien =cero voltios DC a la salida. Le conecto el parlante y todo sigue ok. Pero cuando le inyecto señal empieza a oscilar y el -VCC se cae y aparece DC a la salida. Retiro el parlante y algo en la tarjeta queda sonando. No he podido determinar que es. Creo que es por el inductor. Luego desconecto -vcc y lo vuelvo a conectar y vuelve a arrancar el amplificador normalmente. Estas pruebas las estoy haciendo con +-78VDC a traves de una serie.
Espero comentarios
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Gran señal

Amplificadores de potencia en todas sus variantes: Válvulas, Transistores, Integrados.

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Gran señal

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.