Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Gran señal
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

24/01/2010 #1

Avatar de el-rey-julien

Control de estado de amplificador con Microcontrolador
Tengo una duda con un protector de parlantes, funciona de esta manera, oprimiendo un pulsador el pic conecta el trafo de alimentacion del amplificador, luego controla que los fusibles esten bien (los de la alimentacion), controla si el disipador de la salida no esta caliente, si no hay cc en la salida, si todo eso esta bien se conectan los rele de los parlantes, mientras queda un led rojo indicador que este encendido y otro led verde indicador que todo esta en orden.

Mientras este funcionando el pic sigue ''vigilando'' los fusibles, salida y temperatura, si algunos de estos parametros esta mal el pic desconecta los parlantes y la alimentacion de la salida, dependiendo de la falla titila unos segundos y queda encendido el led indicador de la falla detectada luego apaga todo.

Mi duda es esta, al encender el equipo los parlantes tardan en conectarce unos 3 segundos, bueno al apagar el equipo que hago? desconecto salida (parlantes) primero y despues la alimentacion o tengo que deconectar parlantes y trafo de alimentacion al mismo tiempo? ... o primero la alimentacion y despues los parlantes ? que opinan, les dejo el circuito en que me base para hacer el protector el asm,link de la pagina :

http://www.sound.whsites.net/project111.htm
29/01/2010 #2

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
ya no tengo dudas asy queda ,esta terminado
30/01/2010 #3

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
me confundi de archivo perdon estos son los correctos ,al moderador si puede borrar el archivo comprimido que se llama pcb.rar ,en este esta doto el pcb el asm
Archivos Adjuntos
Tipo de Archivo: rar asm.rar (19,1 KB (Kilobytes), 609 visitas)
13/04/2010 #4


Respuesta: Control de estado de amplificador con Microcontrolador
buenas, te funciono el circuito ?? me quedo la duda si usaste tal cual ese circuito o si te armaste un diagrama diferente...imagino usaste el pic16f84, me interesa porque pensaba hacer un circuito muy parecido nada mas con ideas diferentes....espero tu respuesta, un saludo
13/04/2010 #5

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
si funciono bien ,lo use con el pic16f84 ,cual es tu idea?
15/04/2010 #6


Respuesta: Control de estado de amplificador con Microcontrolador
Disculpame que te moleste, pero lo veo algo raro al circuito...o sea, en cuanto a la conexion con el PIC, imagino que la patilla 1 es la alimentacion (o sea, la 14 en el PIC16f84) 7, 6 y 5 seran salidas y 4 y 3 entradas verdad ? ahora la 8 y la 2 ?¿? 5 y 6 en el PIC16f84 ?
Esto que te pregunto es por lo que vi a simple vista, sinceramente todavia no me sente a leer el enlace del documento original, ni vi el pcb que colgaste (todo porque no tengo a mano el PCB WIZARD que ya lo encontrare).
Mi idea es hacer exactamente lo mismo que hiciste vos en un amplificador, y como tengo los PIC16f84 a mano sin usar los quiero aprovechar...y por ahi me sirva para el control de encendido, temperatura y vacio de un equipo viejo de ionización que estoy arreglando...tendre que leerlo con mas detalle cuando me haga un tiempito.
Bueno en fin, muchas gracias por tu ayuda!
Saludos !
15/04/2010 #7

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
no esta raro el circuito ,la alimentacion es por la patita 14 y 4 el negativo es la patita 5
5 =vss
15=vdd
4=mclr (esta pata va a pisitivo ,con o sin resistor siempre y cuando alimentes con 5 volt el circuito)
cualquier duda no dudes en preguntar
saludos
15/04/2010 #8


Respuesta: Control de estado de amplificador con Microcontrolador
Ahora si que lo entiendo !!
Hace mucho que no usaba el pic, se me cruzaron un par de cables.
Con los años mme va pasando cada vez mas seguido jajaj
Gracias !! En cuanto lo arme te comento.
Saludos !!

gustavocof115 dijo: Ver Mensaje
no esta raro el circuito ,la alimentacion es por la patita 14 y 4 el negativo es la patita 5
5 =vss
15=vdd
4=mclr (esta pata va a pisitivo ,con o sin resistor siempre y cuando alimentes con 5 volt el circuito)
cualquier duda no dudes en preguntar
saludos
15/04/2010 #9

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
cualquier cosa pregunta nomas
saludos
16/04/2010 #10


Respuesta: Control de estado de amplificador con Microcontrolador
Buenas, ya que me das pie a preguntarte...
Bien veo que usas TB6 arriba gnd y abajo +V...
Bueno creo que usaste 6v aprox. como +VE si no me fallan los cálculos y obvio usaste rele de 6v.
Bueno hasta ahi no estaria tan mal encaminado...

En cuanto a como lo diseñaste veo que usaste:

RB7=encendido
RB3=cc en salida
RB2=temperatura
RB1=encendido ok

TB1 y TB2 los usaste para Parlantes y Entrada de Amplificador respectivamente.
O sea, RB6 y RB5 los usas para conectar / desconectar los parlantes del amplificador.
RB4 para conectar el trafo...
RA2 controla el fusible quemado
RA4 para controlar cc en la salida de audio

TB5 la patilla de abajo es AC y la de arriba GND
Entonces según lo que revise y compare.
Q4,Q5,Q6 = BC546
Q1,Q2,Q3 = BC548
D1,D2,D4,D5,D6,D11,D12,D13,D14 = 1N4004

creo que hasta ahi iba bien pero aca es donde empiezo a confundirme

Q6 debe ser el Tr que hace de sensor de temperatura, que lo controla RA1
calculo que en ves Q3 y Q4 del diagrama original usaste un Tr por cada rele
D11 PORQUE ESTA AL AIRE ???
Sigo sin darme cuenta como usas TB4 y como es que chequeas el fusible quemado.
Me restaría saber eso y si quitaste el ventilador para enfriar, ya que no veo nada referido a eso en el circuito.
Bien.... R14 es 22 k, no se supone que R13 es 2.2k ? Yo porque lo estoy comparando con el del circuito de la pagina que tiraste de referencia...
ic2 no entiendo todavía porque esta y que Tr es...

Espero no haberme equivocado en nada (soy humano igual eh)

GRACIAS !!
Saludos !!
gustavocof115 dijo: Ver Mensaje
cualquier cosa pregunta nomas
saludos
16/04/2010 #11

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
ic2 es un regulador de 5 volt (de esos que parecen un transistor cb548,pero ay va un lm7805 de 100 miliamper)el circuito se alimenta con 12 volt por los rele(por eso el zener y el regulador en el esquema alimenta el pic )
en tb5 ay entra la alterna del transformador (para ver si no salto el fusible )justo en ese diodo d11 ,ay conectas la salida del transformador el diodo rectifica la alterna i marca la ra2(patita1,del pic)a trabes del q5 con un nivel alto ,si el fusible se quema en esa patita ay un 0 (sin tensión) y actúa el protector indicando que salto el fusible,
q6 es el sensor de temperatura y cuando ay temperatura apaga el equipo.
asi funciona en esta version
me di cuenta de los cooler pero nadie pregunto lo deje aci ,yo tengo armado de esta manera= una resistencia + un transistor y otro rele para los dos cooler (ventilador) conectado a la patita 8(led de temperatura) y el programa del pic lo modifique para que en ves de apagarse el amplificador cuando detecta temperatura encienda el ventilador ,
con eso logre que cuando el ampli esta funcionando a vajo volumen los ventiladores no funcionen ,pero cuando calienta el ampli si funcionan y refrigera solo cuando es necesario(en mi ampli funcionan un ratito y se apaga ventilador ,al rato encienden de vuelta,solo cuando le doy rosca(maxima potencia)funcionan casi sin parar,
si te interesa subo el asm y hex listo como lo tengo yo para esa funcion ,
creo que no me quedo nada sin explicar, pero cualquier cosa pregunta no ay problema
saludos
16/04/2010 #12

Avatar de psychatog

Respuesta: Control de estado de amplificador con Microcontrolador
y si los ventiladores andan pero la temperatura no baja? No se apaga?
16/04/2010 #13

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
no se apagan si la temperatura no baja -pero se podría implementar otra subrutina que si apague cuando la temperatura suba por encima de lo normal (con otro censor mas ),en mi ampli nunca subió mas aya de los 60 grados ,encienden los cooler en casi 40 grados y mantiene ay la temperatura ,no e tenido problemas ay,

otro sensor mas conectado a la patita de ra4 cc de audio ,pero conectado lo mas lejos posible de el disipador de salida ,para que se active solo cuando pase los 70 o 80 grados ,en ese caso si se apagaría el equipo,pero el led de cc en salida queda titilando y asta que no se enfrie no vas a saber porquese apago si por temperatura o cc en salida (si se puede poner en paralelo las dos entradas mis primeras pruebas asi las conecte)
02/05/2010 #14


Respuesta: Control de estado de amplificador con Microcontrolador
gustavocof115 dijo: Ver Mensaje
ic2 es un regulador de 5 volt...el circuito se alimenta con 12 volt por los rele(por eso el zener y el regulador en el esquema alimenta el pic )....
ahora entendi a la perfeccion...pasa que nunca use el pcb wizzard (mas tarde me di cuenta como es que pusiste los componentes)
gustavocof115 dijo: Ver Mensaje
q6 es el sensor de temperatura y cuando ay temperatura apaga el equipo.
claro cuando vi el q6 me habia dado cuenta que lo usaste de proteccion del circuito de control y no de los parlantes, es una buena variante...el resto se le puede agregar
gustavocof115 dijo: Ver Mensaje
en tb5 ay entra la alterna del transformador (para ver si no salto el fusible )justo en ese diodo d11 ,ay conectas la salida del transformador el diodo rectifica la alterna i marca la ra2(patita1,del pic)a trabes del q5 con un nivel alto ,si el fusible se quema en esa patita ay un 0 (sin tensión) y actúa el protector indicando que salto el fusible
esto si que realmente no lo entendi...suena todo logico pero no pega con el pcb que tengo delante de mis ojos
el d11 esta al aire y va a la pata 5 del pic justamente a vss, o sea, no tiene sentido alguno
por las dudas te subo el que tengo...por si hay diferencia con el que vos tenes asi le hechas un vistaso
Gracias y Saludos
Archivos Adjuntos
Tipo de Archivo: rar protector2.rar (3,9 KB (Kilobytes), 261 visitas)
02/05/2010 #15

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
ese diodo que esta al aire va conectado en donde .nose que ase ay???????????? desarmo el ampli y me fijo aver que ase ay si esta o si es que me olvide de borrar ese diodo

ya esta ese diodo d11 va conectado a el emisor de q4 (d11 es el d6 del esquema de guia )
ay esta en el comprimido el pcb corregido y el esquema de guia donde esta d6=d11
Archivos Adjuntos
Tipo de Archivo: zip Archivo comprimido.zip (12,1 KB (Kilobytes), 288 visitas)
02/05/2010 #16


Respuesta: Control de estado de amplificador con Microcontrolador
gustavocof115 dijo: Ver Mensaje
ese diodo que esta al aire va conectado en donde .nose que ase ay???????????? desarmo el ampli y me fijo aver que ase ay si esta o si es que me olvide de borrar ese diodo
jajaj yo pense lo mismo, que hace ahi ? pero bueno como lo mencionaste tan seguro al d11 en el anterior mensaje, crei que servia de algo pero que faltaban conexiones.
Bueno espero tu respuesta man, GRACIAS por todo !

gustavocof115 dijo: Ver Mensaje
ya esta ese diodo d11 va conectado a el emisor de q4 (d11 es el d6 del esquema de guia )
ay esta en el comprimido el pcb corregido y el esquema de guia donde esta d6=d11
AHHH ! ahora si ! bueno man gracias! en cuanto lo arme te comento como me fue !
saludooos!
02/05/2010 #17

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
si me confundi ,caramba que torpe se me escapo,
saludos
16/05/2010 #18


Respuesta: Control de estado de amplificador con Microcontrolador
cof115 dijo: Ver Mensaje
si me confundi ,caramba que torpe se me escapo,
saludos
no te preocupes ! a cualquiera le puede pasar !
bueno man, arme el circuito con la correccion esa pero no funciona, lo revise 40 veces a ver si habia error, medi unas 50 veces a ver si todo estaba correcto (por si se me habia arruinado algun componente)
y opte por si habia algun error en el programa...
y bueno de esto me surgieron algunas dudas...estas seguro que no usaste otro programa ?

encontre al menos un error...donde colocas el btfsc va un btfss ya que sino viviria apagado....no?
;==========================
; Inicio
;==========================
reset org 0
goto inicio
inicio
movlw b'00000000'
bsf status,rp0
movwf trisb
;==========================
;comienza apagado si ra3 esta a 0 ,con 1 enciende
;==========================
apagar
movlw b'00000000'
bcf status,rp0
movwf portb
movlw b'00011111'
bsf status,rp0
movwf trisa
bcf status,rp0
btfsc porta,ra3 ;controla encendido / apagado con un solo boton
goto apagado
goto encendido

y bueno lo otro que no me cierra es en el circuito lo del pulsador, que en realidad termina siendo lo mismo (el encendido de todo)
se supone que tb4 es un pulsador no?
usas ra3 como encendido pero siempre le llega tension...al menos como esta armado el circuito y creo que lo arme tal cual
en fin el circuito funciona tal cual esta diseñado, salvo por lo del pulsador...si me hechas una mano con esto y con el programa te agradeceria mucho, luego yo veo como sigue la cosa...
espero terminarlo asi no te molesto mas jajjaja

gracias y saludos !!
16/05/2010 #19

Avatar de el-rey-julien

Respuesta: Control de estado de amplificador con Microcontrolador
tb4 es un pulsador que va conectado a ra3 y negativo y no al positivo ,el programa esta bien.
porque comienza apagado y asta que no oprimas el pulsador no enciende
saludos
esta es la ultima correccion del pcb ,pero como ya la tenes ,solo corta la pista de tb4 que esta conectado a +5 volt(la otra pista de tb4 esta bien va a ra3) y conecta esa pista a negativo y hualaaaa pulsador ya funciona
recien probe el ams y esta bien ,comiensa con el ampli apagado ,lo enciende con el pulsador tb4 y lo apagas con el pulsador tb4
saludos

pd:
repito el progama esta bien,lo descarge lo probe y esta bien .yo soy cof115 ,compilalo y grabalo tal cual esta que funciona,el error esta solo en la conecion del pulsador

pablor09 dijo: Ver Mensaje
no te preocupes ! a cualquiera le puede pasar !


se supone que tb4 es un pulsador no?
usas ra3 como encendido pero siempre le llega tension...al menos como esta armado el circuito y creo que lo arme tal cual
en fin el circuito funciona tal cual esta diseñado, salvo por lo del pulsador...si me hechas una mano con esto y con el programa te agradeceria mucho, luego yo veo como sigue la cosa...
espero terminarlo asi no te molesto mas jajjaja

gracias y saludos !!
por eso el pulsador cuando lo aprietas tiene que dejar de tener tencion
no ay problemas consulta todas las beces que creas nesesario o tengas alguna duda

pablor09 dijo: Ver Mensaje
no te preocupes ! a cualquiera le puede pasar !


encontre al menos un error...donde colocas el btfsc va un btfss ya que sino viviria apagado....no?
;==========================
; Inicio
;==========================
reset org 0
goto inicio
inicio
movlw b'00000000'
bsf status,rp0
movwf trisb
;==========================
;comienza apagado si ra3 esta a 0 ,con 1 enciende
;==========================
apagar
movlw b'00000000'
bcf status,rp0
movwf portb
movlw b'00011111'
bsf status,rp0
movwf trisa
bcf status,rp0
btfsc porta,ra3 ;controla encendido / apagado con un solo boton
goto apagado
goto encendido



gracias y saludos !!
el unico error es
este
donde dice
;==========================
;comienza apagado si ra3 esta a 0 ,con 1 enciende
;==========================

en realidad deveria decir
;==========================
;comienza apagado si ra3 esta a 1 ,con 0 enciende
;==========================

pero como es un comentario en el prog. no afecta en nada,solo confunde jeje ,es para los que estan mas despiertos y te diste cuenta
------(mentira yo me equivoque pero menos mal que tengo esa escuza)al principio era asi pero despues lo cambie y me olvide de editar esa linea
Imágenes Adjuntas
Tipo de Archivo: jpg instantánea5.jpg (198,2 KB (Kilobytes), 207 visitas)
Archivos Adjuntos
Tipo de Archivo: zip protector3.pcb.zip (4,3 KB (Kilobytes), 229 visitas)
16/05/2010 #20


Respuesta: Control de estado de amplificador con Microcontrolador
tsunami dijo: Ver Mensaje
------(mentira yo me equivoque pero menos mal que tengo esa escuza)al principio era asi pero despues lo cambie y me olvide de editar esa linea
jajajja
si man, me quede toda la noche revisando todo y lo corregi y funciona perfecto...
lo unico que no me quedo bien es que en la tension de los rele me queda 8 v aprox... y los rele son de 12v asi que voy a hacer de nuevo la placa y los alimentare con 12v directo borrando la pista que va al zenner de 5v
en fin.... FUNCIONA A LA PERFECCION !!!

GRACIAS por TODO !!
un saludo grande !!
seguimos en contacto

PD: cuando pueda pongo alguna foto o video
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Gran señal

Amplificadores de potencia en todas sus variantes: Válvulas, Transistores, Integrados.

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Gran señal

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.