Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Gran señal
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

28/09/2012 #1

Avatar de seaarg

Distorsion al poner canal de subwoofer
Estimados,

Estoy desarrollando un pequeño ampli 2.1 clase D, que trabaja con fuente simple a 12v, con elementos sencillos y faciles de conseguir.

La frecuencia de la onda triangular es de 200khz, vista con el osciloscopio se la ve bien definida. La onda cuadrada en la etapa de potencia tambien esta bien definida, con un duty cycle estable en 50% con la entrada conectada a masa.

Aclaro que esto lo estoy desarrollando en protoboard hasta tener el diseño definitivo (tambien probe a otras frecuencias de portadora, como 80khz, 100khz, etc. sin diferencia para el problema que voy a comentar)

Adjunto esta el diagrama simplificado de la etapa de entrada, hasta llegar a los comparadores.

El problema es que, cada canal individual (con el resto desconectado el capacitor de entrada) o con solo los dos canales stereo, funciona perfecto... cuando conecto el canal de subwoofer Y los de stereo, el subwoofer tiene distorsion a cualquier volumen.

La conexion / desconexion de los canales la hago poniendo o sacando los capacitores de entrada de los canales.

Probe con todo tipo de valores de resistencias, capacitores, etc (cuando los calculos que pude hacer ya no me daban solucion) y el problema persiste.

Lo mas extraño es que, si dejo los 3 canales activados, pero quito el filtro pasabajos (quitando solo el capacitor C4) en ese momento, el subwoofer anda bastante bien, se nota una distorsion muy pequeña a alto volumen. (o sera que me tapan la misma distorsion los medios y agudos en ese parlante de sub??)

Tambien, al desconectar los parlantes de los canales de medios, y quitar C3 (con el parlante del sub conectado) Se oye muy bajito la musica distorsionada por el parlante del sub, cuando deberia NO oirse nada ya que no hay señal y/o parlantes. Supongo que en esto tiene que ver la protoboard.

Las resistencias de 47K son una forma sencilla para proveer una continua igual a VCC/2, tambien en el diseño original que hice esta masa virtual era creada por un operacional, con los mismos resultados de distorsion en el canal de sub. Tambien probe valores de resistencia bajos como 10K y menos, y altos como 330K

Capacitores de fuente: 5x4700 uF, uno de ellos en cada pareja de mosfets de salida. y 2 en la entrada de alimentacion, mas 1 x 100uF en paralelo con 100nF en cada integrado.

Tambien, antes de hacer todas estas pruebas con este esquema sencillo, la entrada estaba formada por un operacional TL074 en los cuales usaba 1 opamp para cada canal stereo, con ganancia 1:2 y los 2 opamp restantes los usaba para entrada de sub, con ganancia 1:2 y filtro pasabajos. El resultado era unos bajos muy buenos, con muy buen corte pero apenas conecto los capacitores de las entradas stereo, otra vez la distorsion.

Otras combinaciones que probe: poner el capacitor de entrada del sub antes del filtro pasabajos, poner el filtro pasabajos justo antes de los comparadores, etc. Cuando tenia puesto el pre de entrada, probe poner los canales en el operacional en modo no inversor (para que la R de realimentacion no estuviera conectada directamente de la salida a la entrada) y el mismo problema de distorsion en el sub.

Tambien probe poner el comparador del sub como un integrado separado (por si habia crosstalk) y lo mismo.

Lo UNICO que no probe de todo lo que pude pensar, es poner 1 comparador separado por cada canal (los de stereo son el mismo integrado, comparador doble)

Aun no llegue a poner realimentacion desde la potencia hacia la entrada (probe algo pero con esa distorsion es imposible, queria solucionarla primero)

Tal vez haciendo esto en PCB se solucione definitivamente el problema, pero como no estoy seguro para nada, queria consultarles por donde mas puedo buscar el problema antes de hacer una placa y soldar todo.

Desde ya, muchas gracias a quien ha leido esto, cualquier sugerencia se los agradezco enormemente. Se me "quemaron los libros" y estoy tan cerca de terminarlo!!

PD: Les cuento que los canales stereo sin subwoofer, se escuchan muy bien!

PD2: No puedo cambiar el titulo, en realidad la distorsion es netamente cuando pongo el filtro pasabajos.
02/10/2012 #2

Avatar de seaarg

Amplificar a partir de cierto nivel de señal
Tengo un problema en el cual no se como buscar la solucion.

Diseñe un ampli clase D 2.1, en el cual el canal de subwoofer se genera a partir de la señal mezclada de canal izq y der, que pasa por un filtro pasa-bajos realizado con un operacional y recien ahi va al amplificador de potencia.

El pasa bajos es razonablemente bueno, amplifica la señal en bajos y la disminuye considerablemente a partir de la FC.

El problema es que no es perfecto, y las señales de F mas alta que FC siguen pasando, aunque muy atenuadas. Esto, sumado a la extrema sensibilidad de entrada del comparador, o sea, luego de este "pre" hacen que esa señal de muy baja amplitud se amplifique, pero distorsionada. Deja de distorsionar cuando la señal empieza a tener cierto nivel vpp.

Mi pregunta es: Se puede realizar algo que haga que el amplificador recien empiece a amplificar la señal a partir de cierto nivel de señal de entrada? (algo asi como una histerisis, por no tener mejor forma de definirlo) Si se puede... bajo que terminos de busqueda podria encontrar algo asi?

O sino: Tengo que hacer un pasa-bajos aun mas fuerte? (FC mas baja) creo que el problema seguiria existiendo pero a frecuencias mas bajas, ya que no hay pasabajo con corte brusco de frecuencia sino que es una curva.

Pense en hacer algo como un divisor de tension en la entrada del ampli, luego del pasabajos, para eliminar la señal desde cierto nivel vpp hacia abajo, pero persistiria el problema porque si bien la frecuencia mas alta que FC seria eliminada (por ser muy debil) la frecuencia mas baja, antes fuerte, ahora seria mas debil y por lo tanto seria amplificada con distorsion.

Repito, la distorsion solo se da cuando la señal es debil (ya sea por entrada y/o interferencia). Si la señal es apenas mas fuerte deja de distorsionar.

Muchas gracias!
02/10/2012 #3

Avatar de Dr. Zoidberg

seaarg dijo: Ver Mensaje
Mi pregunta es: Se puede realizar algo que haga que el amplificador recien empiece a amplificar la señal a partir de cierto nivel de señal de entrada? (algo asi como una histerisis, por no tener mejor forma de definirlo) Si se puede... bajo que terminos de busqueda podria encontrar algo asi?
Es probable que pueda hacerse, pero no sé para que te serviría...

seaarg dijo: Ver Mensaje
O sino: Tengo que hacer un pasa-bajos aun mas fuerte? (FC mas baja) creo que el problema seguiria existiendo pero a frecuencias mas bajas, ya que no hay pasabajo con corte brusco de frecuencia sino que es una curva.
Para hacer un filtro pasa-bajos "mas fuerte" no hay que bajar la frecuencia de corte sino que hay que aumentar el "orden" del filtro.
En todos mis sistemas de audio he usado filtros de 4º orden, y esos requieren dos amplificadores operacionales. Hay un tema mío por ahí que se llama algo de "Filtros Linkwitz-Riley para sistemas 2.1" o algo parecido, y ahí tenes el diseño eléctrico, el PCB y las explicaciones para armar filtros pasa-altos para los satélites y pasa-bajos para el subwoofer, y todos son filtros de 4º orden....y de los mejores para audio.
02/10/2012 #4

Avatar de seaarg

Eza, me alegro mucho que hayas contestado este post. Siempre trato de leer y entender tus posts de audio

El post que te referis es: Crossover Linkwitz-Riley para sistemas 2.1 y me viene de perlas.

Mi ampli es de fuente simple, por lo que implemente un sallen-key de ganancia unitaria que encontre en una nota de aplicacion de TI (SLOA058) combinado con una etapa anterior de ganancia exclusivamente, todo esto en un TL072. Adjunto el esquematico del pasa bajos aqui.

pregunta: Para la etapa de sub veo que usas 2 TL072. Existe alguna razon particular para no usar un solo TL074?

Y no pregunto mas porque en todo caso, las hago en ese tema correspondiente Muchas gracias!

PD: A los mods: veo que unieron 2 posts. Gracias! aunque los hice separados porque el primero era sobre un class D clasico, con generador de onda triangular, etc. Este segundo intento es un clase D hecho con TL494 (tenemos de todo en ese chip!) y no queria mezclar los tantos aunque el problema de filtro que tengo es casi el mismo jeje. La verdad que con algunos ajustes en el circuito esta andando muy bonito y con mejor sonido que amplis integrados! Aun no he hecho mediciones. Obviamente apenas refine el pasabajos a una version definitiva subire este proyectito aqui para que todo principiante del audio como yo juegue con el.

PD2: Editado, removi una pregunta que acabo de ver en el post en cuestion.
Imágenes Adjuntas
Tipo de Archivo: jpg sallen-key.jpg (34,7 KB (Kilobytes), 12 visitas)
02/10/2012 #5

Avatar de seaarg

Gracias ezavalla. Parece que iba en buen camino con el filtro pero agregue otro en serie como en tu caso (eso es lo que da el 4to orden creo) y anda excelente. Bajos aun mas definidos, agudos bien filtrados. Sin distorsion

A pulirlo un poco y sale con fritas
02/10/2012 #6

Avatar de Dr. Zoidberg

seaarg dijo: Ver Mensaje
Eza, me alegro mucho que hayas contestado este post. Siempre trato de leer y entender tus posts de audio
No te hagás problema, a mi también me pasa lo mismo

seaarg dijo: Ver Mensaje
pregunta: Para la etapa de sub veo que usas 2 TL072. Existe alguna razon particular para no usar un solo TL074?
Si, por que es más facil rutear el PCB con los 2 AO dobles que con uno cuádruple, que tienen las salidas apuntando para lados contrarios

PD: Cuidado con poner filtros en cascada al boleo, por que podés terminar con cualquier fcia de corte y con cualquier ajuste del filtro. Calculalo como dice en mi tema (con el soft de ESP).

Saludos!
02/10/2012 #7

Avatar de seaarg

Exacto, calcule con el soft que esta al final del proyecto 09, que tiene la misma distribucion que la parte filtro sub de tu proyecto. Termine con valores de R = 3K9, C = 220nF y 2C = 440nF (aunque puse 470nF. voy a probar duplicar exactamente C para no tener efectos indeseados) Esto para una FC = 130hz.

Para los medios, obvie el pasaaltos ya que son parlantes chicos que de por si no reproducen bien los bajos, y el capacitor de la entrada filtra aun mas los bajos. Probablemente termine poniendo un pasaaltos pasivo ahi aprovechando el cap de desacople de entrada.

Por el lado de fuente simple, lo que hice fue poner en los AO como tierra virtual, el voltaje de bias de del ampli, que en este caso particular no va unido a la señal de entrada sino que va al + del AO de entrada del TL494, por lo que no es afectado por la señal... entonces, si bien no es VCC/2 (6v) sino 2.5 V funciona bien, me da margen de aprox. entre 1V a 1.5V hacia GND y obviamente, un monton hacia arriba. porque el AO no es rail to rail y distorsiona en los extremos. Esto lo hice para evitar un capacitor en la entrada del ampli de sub. (bastante ya tengo que aguantar uno por canal en la entrada del crossover!!!) Cosa rara pero audiblemente salio bien. Vere las mediciones

Ahora voy a ver de pulirlo para arreglar cosas como la realimentacion de los clase D, balancear un poco las ganancias, etc. Muchas gracias de nuevo por el dato! me habia clavado en este punto jeje
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Gran señal

Amplificadores de potencia en todas sus variantes: Válvulas, Transistores, Integrados.

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Gran señal

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.