Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Gran señal
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/07/2009 #1
Moderador

Avatar de Ratmayor

Problemas con proyecto de subwoofer amplificado
Que tal amigos de la comunidad, de hace unos meses estoy desarrollando un pequeño proyecto de un subwoofer amplificado. El proyecto consta de un filtro pasa bajos de entrada diferencial, amplificador y etapa de protección...

El equipo funciona muy bien siempre y cuando este sonando a todo volumen, pero sonando bajo tiene una horrible distorsion que pareciera distorsion de cruce o como si un driver no estuviese funcionando bien , a continuacion les dejo el diagrama esquematico y una foto del amplificador ya ensamblado...

Espero que puedan ayudarme a solventar ese inconveniente. Saludos...
03/07/2009 #2
Moderador general

Avatar de Cacho

Hola Ratmayor

Muy bonito el amplificador, felicitaciones.
Mirando un poco el esquema, no parece tener errores que justifiquen el mal funcionamiento, a excepción de una capacidad demasiado baja en los condensadores de filtrado de la alimentación.
4700uf por rama están bien para amplificadores de mucha menor potencia, en tu caso y con una alimentación de +-62, y destinada a un subwoofer, tendrías que tener como mínimo unos 10000uf por rama.

Revisá por Audio: Gran Señal buscando un tutorial de Fogonazo sobre el cálculo de fuentes de amplificador. Te va a sacar muchas dudas.

Todo esto lo digo suponiendo que no estén actuando las protecciones del circuito.

Saludos
03/07/2009 #3
Moderador

Avatar de Tacatomon

Todo un cuete el amplificador, tiene muy buena pinta pero no dice cuantos watts se banca, calculo unos 350W@4 Ohm, a ver que nos dice ratmayor.

Saludos.
03/07/2009 #4
Moderador general

Avatar de Cacho

No creo Tacato...

Sin protección por sobrecorriente sería bastante arriesgado conectar ese amplificador a 4Ω. Ya a una temperatura media se quedaría medio corto con la corriente (y la disipación de potencia) que puede manejar con sólo dos transistores de salida.

Más bien lo pondría en 200W/8Ω (y si se conecta a 4Ω estimo que andará por la potencia que decís vos)

Cambiando de tema:
Ahora que miré un poco mejor la protección de la derecha arriba, no me gusta cómo están orientados D503, 4 y 5. Definitivamente hay algo que me perdí o que no funciona ahí.
¿Cómo trabaja esa etapa Ratmayor?
03/07/2009 #5
Moderador

Avatar de Ratmayor

tacatomon dijo:
Todo un cuete el amplificador, tiene muy buena pinta pero no dice cuantos watts se banca, calculo unos 350W@4 Ohm, a ver que nos dice ratmayor.
En realidad, el amplificador entrega unos 175W en 8 ohms y teoricamente 300 en 4 ohms, mas no me arriesgaria a trabajarlo con 4 ohms.

Cacho dijo:
Cambiando de tema:
Ahora que miré un poco mejor la protección de la derecha arriba, no me gusta cómo están orientados D503, 4 y 5. Definitivamente hay algo que me perdí o que no funciona ahí.
¿Cómo trabaja esa etapa Ratmayor?
El circuito tiene 3 protecciones, una contra sobre carga (Q501), contra DC (Q502) y una por temperatura (D506 y Q503), los diodos D503, 4 y 5 actuan como una compuerta OR, de manera que en el caso que cualquiera de las etapas del protector detecten una anomalía estas por medio del bus que forma ese grupo de diodos polarize el Q504 lo que descargaría el flitro de retrado (C503) haciendo que el relé se desactive... Aunque tienes razón, los diodos estan al reves! ops: ya subo el plano con esto corregido y algunas fotos del subwoofer como tal. a lo que pueda subo el PCB


Será posible que por la falta de filtrado en la fuente suene como si no estuviese amplificando un semiciclo, o mejor dicho, como un viejo radio mal sintonizado? probaré con unos filtros de mayor capacidad y les aviso jeje...
Imágenes Adjuntas
Tipo de Archivo: png powered_subwoofer_340.png (335,2 KB (Kilobytes), 1016 visitas)
Tipo de Archivo: jpeg interior_162.jpeg (105,0 KB (Kilobytes), 684 visitas)
Tipo de Archivo: jpeg posterior_106.jpeg (149,9 KB (Kilobytes), 423 visitas)
Tipo de Archivo: jpeg frontal_981.jpeg (150,6 KB (Kilobytes), 637 visitas)
03/07/2009 #6
Moderador general

Avatar de Cacho

Seguimos con diodos al revés entonces...
D501 y D506. Y D601 no veo cómo (ni cuando) conducirá. ¿No está al revés?


Por otro lado, realmente no me parece bueno el circuito de protección, además de sentir que falta protección en la rama negativa.
Está pensado para proteger al parlante en caso de falla del amplificador en lugar de proteger al amplificador y así al parlante.
En la elección de los diodos tampoco coincido. Habría usado los 1N400X en lugar de varios de los 4148 que hay, sobre todo en la parte de la protección térmica.

A mi juicio esas protecciones no serán algo bueno ni funcionarán muy bien que digamos.

En lo referente a los condensadores, a mayor capacidad, mayor aguante en los pasajes más exigentes, así que será un avance en altos volúmenes. Peeeeeeeeeeeeero... releyendo el post original ¡me doy cuenta de lo dormido que estaba cuando lo leí la primera vez! ops: .
El problema está en los volúmenes más bajos... Ahora sí le pongo todas las fichas a que es la protección la que está haciendo el desastre.
Probá de sacar R501 o R502. Eso podría ayudar.


Saludos
03/07/2009 #7

Avatar de Dr. Zoidberg

Tiene razón lo que dice Cacho. Levantá TODAS las protecciones (quitá R501, R502, R504 y R607). Levantá también la pata + de C401 y por ahí meté la señal de audio SIN PROTECCIONES NI FILTROS y probá el amplificador solo, sin nada más. Ajustá el offset y la polarización estática a los valores correctos y recién entonces comenzá a probar los otros bloques por separado, para juntarlos al final, cuando te hallas asegurado que todo está en condiciones.

PD: Demás está decir que para probar el funcionamiento completo de un sistema de esta potencia, plagado de filtros previos y otras cosas medio raras, deberías tener un osciloscopio y un generador de senoides...como mínimo. Cualquier otra cosa, es jugar a las adivinanzas, como está haciendo Cacho ahora.

Saludos!
03/07/2009 #8
Moderador general

Avatar de Cacho

ezavalla dijo:
Cualquier otra cosa, es jugar a las adivinanzas, como está haciendo Cacho ahora.
Estoy practicando para recibirme de Nigromante .



Saludos
03/07/2009 #9
Moderador

Avatar de Ratmayor

Que tal, desconecte el protector por completo, y la falla perciste, note con el osciloscopio que entre semiciclos habia un periodo muerto, cosa que me parecio muy rara, otro detalle curioso es que pense que el ajuste de DC podria estar afectando la amplificación y cuando lleve la entrada del amplificador a tierra comenzo a oscilar
03/07/2009 #10

Avatar de DJ DRACO

si tienes una parte del periodo muerto o continuo es porque te sobrepasaste con los diodos y le metiste uno a la entrada de audio tambien..jejeje

puede ser que te hayas pasado de mano con tantos diodos y protecciones.


saludos
03/07/2009 #11
Moderador

Avatar de Ratmayor

jajaja al fin resolvi, ya estaba que llamaba al brujo de la pipa me puse a medir el hFE de cada transistor y fue que haye el problema, en esta topologia de amplificador, los componentes deben ser simetricos, de lo contrario pudieran haber ese tipo de fallas, contrarreste el retardo de los transistores colocando una resistencia de 100K en la base del Q410 y santo remedio...

En cuanto el protector, a mi me a funcionado muy bien, sin embargo, acepto sugerencias...
03/07/2009 #12
Moderador

Avatar de Tacatomon

Verificastes si la oscilacion continuaba?

Cuantos mV de offset tienes a la salida ahora?
03/07/2009 #13
Moderador

Avatar de Ratmayor

bien, la oscilacion se debía a una simple soldadura fria en el C403, actualmente tiene 0.1mV de offset lo que me recuerda, que al conectar la resistencia que mensione anteriormente, tuve que reajustar el DC y el BIAS...
04/07/2009 #14
Moderador general

Avatar de Cacho

ratmayor dijo:
En cuanto el protector, a mi me a funcionado muy bien, sin embargo, acepto sugerencias...
Te planteo un par de cosas sobre el protector:
¿Qué tal si uno de los transistores de la rama negativa se quemara y quedara en corto?
Suponiendo que el detector de continua funcione como debe, se desconecta el parlante y TODA la corriente que circula por los TR de salida de la rama positiva circula a -V sin que nada la limite, más que las resistencias de 0,22Ω. No es una situación muy agradable y con (mucha) suerte se cortarán las resistencias y se salvan los semiconductores..

Segunda: Si la onda que entra al amplificador tiene componentes negativa mucho mayor que la positiva (es audio, las señales no suelen ser muy simétricas) son los transistores "de abajo" los que tienen que manejar la corriente. Es probable que alguno vuele y nos deje (quizá) en la situación de más arriba.

Saludos
06/07/2009 #15
Moderador

Avatar de Ratmayor

Cacho dijo:
¿Qué tal si uno de los transistores de la rama negativa se quemara y quedara en corto?
El detector de DC si está apto para detectar tanto voltaje positivo como negativo, si alguno de los transistores finales entrara en corto, pudiera detectarse, por eso use el pequeño rectificador para que sin importar la polaridad, el transistor que detecta DC hiciera su cometido, sin embargo, me parece muy interesante tu propuesta para proteger el amplificador contra sobre corriente en ambas ramas ya que solo estoy cubriendo la rama positiva. Recuerdo haber visto en viejos amplificador General Electric en donde cubrian esas situaciones, "monitoreaban" ambas ramas, pero realmente no recuerdo como era la topologia el caso es que debo hacerlo de transistores debido a que ultimamente como en mi pais todo esta escaseando se me es muy dificil usar circuitos integrados especializados para esos casos tales como el uPC1237HA...
06/07/2009 #16
Moderador general

Avatar de Cacho

Hola Ratmayor

En este proyecto (en la figura 2) podés ver cómo se hacen protecciones con un simple par de transistores (Q4 y Q5).

Esos se encargan de sensar la corriente que pasa por los transistores de potencia y bajan el Vbe de Q6 y Q7 de ser necesario para que los TR de salida se mantengan dentro de las áreas seguras.
Es bastante simple el sistema. En tu amplificador sólo tendrás que recalcular las resistencias que hace los divisores de voltaje para que el sistema se active cuando sea necesario.

Saludos
06/07/2009 #17
Moderador

Avatar de Ratmayor

Cacho dijo:
Hola Ratmayor

En este proyecto (en la figura 2) podés ver cómo se hacen protecciones con un simple par de transistores (Q4 y Q5).

Esos se encargan de sensar la corriente que pasa por los transistores de potencia y bajan el Vbe de Q6 y Q7 de ser necesario para que los TR de salida se mantengan dentro de las áreas seguras.
Es bastante simple el sistema. En tu amplificador sólo tendrás que recalcular las resistencias que hace los divisores de voltaje para que el sistema se active cuando sea necesario.

Saludos

mmmm si, ya habia visto ese tipo de protecciones en amplificador Kenwood y tambien vi que en algunos casos esa proteccion era la causante de que se quemaran los finales supongo que era debido a alteraciones en los componentes. Bien revizando entre mis planitos jeje encontre esto de un subwoofer Yamaha, que opinas?
Imágenes Adjuntas
Tipo de Archivo: png yamaha_158.png (32,7 KB (Kilobytes), 344 visitas)
08/07/2009 #18
Moderador general

Avatar de Cacho

Hola Ratmayor

Me resulta raro lo que decís de que las protecciones esas quemen etapas de salida. No se me ocurre cómo podrían hacerlo.

Por la protección que posteaste, no sé qué hará al fin el transistor Q27, pero supongo que conecta/desconecta la salida a los parlantes usando un relé. Usa un sistema que me gusta más que el que usaste en el amplificador tuyo porque considera la rama negativa.

Eso sí: Estamos hablando de MOSFETS en la salida que posteaste.
Hay una cosa importante y es que podemos suponer que cuando hay una corriente grande circulando por el MOSFET, éste estará totalmente cerrado y la única resistencia presente será Rdson, mínima (del orden de unos pocos mΩ) y la disipación de potencia será poca. Más aún, la capacidad de corriente de los MOSFET suele ser muy alta y sería raro que se quemaran por sobrecorriente si está bien calculado todo.

Ahí sí sería lógico suponer que lo que fallará será el parlante y al separarlo del amplificador queda protegido este último.


Saludos
08/07/2009 #19
Moderador

Avatar de Ratmayor

Cacho dijo:
Me resulta raro lo que decís de que las protecciones esas quemen etapas de salida. No se me ocurre cómo podrían hacerlo.
Yo si, es que ultimamente la falsificacion de transistores a invadido las casas electronicas de mi localidad tal como si fuera un virus no me queda otra que eliminar o modificar por completo esa proteccion

Intentare rediseñar el protector tomando en cuenta los consejos que me sugeriste. Saludos
08/12/2009 #20
Moderador

Avatar de Ratmayor

Respuesta: Problemas con proyecto de subwoofer amplificado
Buenas noches, tomando los consejos del amigo Cacho modifique el protector y a lo que pueda subo los diagramas y algunas fotografias del circuito funcionando, otra cosa que mejoré fueron la fuente de alimentación y al amplificador le aumente la potencia significativamente.

Aunque he fabricado varios, y no es por nada, han quedado bastante optimos, tengo una pequeña duda, existirá forma de proteger la entrada de audio?

Dirán que ya entre en la línea de la paranoia jeje, pero resulta que un cliente me llevaba ambos subwoofers que le fabrique por garantía, y cuando revizaba siempre tenia los Amplificadores Operacionales en mal estado. Indagando un poco descubri que el cliente conectaba la entrada de los subwoofer a una salida amplificada y por si fuera poco, esta tenia un offset de 2,1V.

Bien conociendo la situacion, se me ocurrio colocar un par de diodos contrapuestos entre la entrada positiva y la negativa, pero a la vez pienso que podria traerme problemas distorsionando el audio, que me podrían sugerir?

No subo el diagrama en este momento porque estoy a 7 horas de mi ciudad jeje, pero a penas pueda comparto las modificaciones con ustedes, saludos!!!
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Gran señal

Amplificadores de potencia en todas sus variantes: Válvulas, Transistores, Integrados.

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Gran señal

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.