Haz una pregunta
  Foros de Electrónica » Reparación en General » Reparación de equipos de Audio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

21/04/2011 #1

Avatar de Pelelalo

Pre con mucho ruido.
Buenas, después de los aportes suyos en cuanto a la amplificación de audio, me he puesto a ello. Quiero adaptar la salida de audio del movil a un altavoz de 6 ohmios. Para ello, lo primero que he hecho es un Preamplificador con un LM324 en modo inversor (el no inversor no soy capaz de hacerlo funcionar). Vease diagrama adjunto.

El altavoz suena a un volumen aceptable (para un PRE claro). EL tema es el RUIDO. Hay demasiado. He cambiado el LM324 por un MCP609 de Microchip que tenía a mano (en Cáceres no tenemos muchas posibilidades de pillar chips que no sea a través de Internet). La cosa no mejora.

Os querría consultar acerca del diagrama. He estado pillando varios aportes del foro pero quizás confundí alguno.

PD: Los condensadores que supongo sirven para filtrar la continua tienen valores de 1uF y 100uF. Si cambio el valor del de entrada parece que ni funciona y a la salida del de 100uF mido hasta 4 voltios en ausencia de señal. Podrían indicarme el por qué de esos valores de Condensador.

Gracias.
21/04/2011 #2
Excluido


El LM324 es un integrado que contiene cuatro amplificadores operacionales, no es un amplificador que pueda atacar directamente un parlante.

Mejor utiliza el LM380 que tiene ganancia fija o el LM386 que es de ganancia variable.
21/04/2011 #3

Avatar de Pelelalo

Mandrake dijo: Ver Mensaje
El LM324 es un integrado que contiene cuatro amplificadores operacionales, no es un amplificador que pueda atacar directamente un parlante.

Mejor utiliza el LM380 que tiene ganancia fija o el LM386 que es de ganancia variable.
Gracias Mandrake pero como indique, este es un PRE. Obviamente voy a usar una amplificador para atacar ese altavoz, pero algo va mal, porque el altavoz suena pero CON MUCHO RUIDO. Es lo que quiero corregir antes de armar el amplificador.

Tampoco puedo disponer de los integrados que desee, puesto que los tengo que pillar por internet y pagar costes de envio. Lo hago de vez en cuando y ahora cuento con los LM324 y los MCP609 de Microchip.

PD: La polaridad del condensador de salida la dibuje al revés.
21/04/2011 #4
Excluido


Las causas del ruido:

  • Deficiente regulacion de la fuente de voltaje.
  • Elevada ganancia del pre amplificador.
22/04/2011 #5

Avatar de Pelelalo

OK. Le bajaré la ganancia a ver. De todas formas me podéis ayudar con las siguientes dudas:

- Valor de los condensadores de desacoplo de continua. ¿Por qué esos valores?.
- Puedo poner varias etapas PRE para ir amplificando progresivamente sin que aparezca ese ruido.
22/04/2011 #6
Moderador general

Avatar de Cacho

No apostaría por un tema de ganancia en este caso (-100, no es mucho). Por otro lado, si estuviera pasado de ganancia no sonaría con ruido, sino con variaciones de volumen.

Primero que nada: ¿Tenés acceso a un osciloscopio y un generador de señales?.
Si lo tenés, probá con esos aparatos .

Si no lo tenés: Poné la entrada a masa y escuchá lo que sale: Debería ser silencio.

Después poné música bien bajita a la entrada del operacional y pegá la oreja al parlante. Si el sonido sale bien, vamos bien.
Tené presente que estás alimentando eso con 9V, lo que quiere decir que tenés una excursión máxima de señal de unos 4V como máximo. Para alcanzar esos valores con una ganancia de 100 necesitás apenas 40mV a la entrada. Con más que eso ya se satura el operacional.

Para peor, como los operacionales no entregan más que 5 o 10mA (típicamente), vas a tener que agregar el problema de que se te caerá la señal al atacar el parlante. Por eso lo de escucharlo bien bajito.

Lo de los condensadores, efectivamente están ahí para desacoplar la contínua. El valor depende de la impedancia de la etapa siguiente.
Esos componentes forman un filtro pasaaltos (se "comen" los bajos) y su frecuencia depende de los valores de R y C, donde R es la impedancia de entrada (en Ω) del operacional o del parlante en tu esquema) y C (en F) es el valor del condensador.

La fórmula es f(-3dB)=1/(2pi*R*C). Tomemos el condensador de salida de 100uF y el parlante que arbitrariamente asumo de 8Ω (si es otro valor no importa, el razonamiento es el mismo).
La frecuencia en la que los graves "ya pasan sin problemas" será 1/(6,28*8*0,0001)~200Hz. Si la impedancia de lo que le conectes es mayor, la frecuencia de corte será menor.
Si la capacidad fuera mayor, de nuevo la frecuencia de corte será menor.

En el caso de los operacionales, la impedancia de entrada teórica es infinita, pero en la práctica "apenas" si llega a algunos MΩ, o unos "pobres" cientos de kΩ. No hay dramas ahí con los condensadores .

Y sí, podés poner varias etapas en cascada para lograr la ganancia final que quieras.

Saludos
22/04/2011 #7
Excluido


Quizas tambien necesite una resistencia de 50Ω en la salida del movil (entrada del pre amplificador y Gnd).

Pelelalo dijo: Ver Mensaje
. . . - Valor de los condensadores de desacoplo de continua. ¿Por qué esos valores? . . .
Solo voy a referirme al condensador conectado en la entrada del pre:
Con ese valor, el circuito tiene una frecuencia de corte, Fc=159Hz; o sea que el circuito amplificara las señales con frecuencia superior a la Fc.

Pelelalo dijo: Ver Mensaje
. . . - Puedo poner varias etapas PRE para ir amplificando progresivamente sin que aparezca ese ruido.
Si puede hacerlo de esa forma. Mejor utilice un pre con ganancia comprendida entre 1 y 3.16 (0dB y 10dB): porque pienso que el dispositivo movil (¿celular o radio?); entrega una señal suficientemente fuerte (entre 100mV y 1V), para excitar un amplificador.
22/04/2011 #8


Tienes que poner un capacitor de unos 47mf-100mf en paralelo a R2, ademas una resistencia en paralelo del nodo que hay entre R1 y C6, para limitarte la intensidad de la señal de entrada porquei quiza esta sea demaciado intensa y por ese motivo se escucha el ruido debido al limite de ganancia
23/04/2011 #9

Avatar de Pelelalo

DE ANTEMANO MUCHISIMAS GRACIAS A LOS TRES

Cacho dijo: Ver Mensaje
No apostaría por un tema de ganancia en este caso (-100, no es mucho). Por otro lado, si estuviera pasado de ganancia no sonaría con ruido, sino con variaciones de volumen.

Primero que nada: ¿Tenés acceso a un osciloscopio y un generador de señales?.
Si lo tenés, probá con esos aparatos .

Si no lo tenés: Poné la entrada a masa y escuchá lo que sale: Debería ser silencio.

Después poné música bien bajita a la entrada del operacional y pegá la oreja al parlante. Si el sonido sale bien, vamos bien.
Tené presente que estás alimentando eso con 9V, lo que quiere decir que tenés una excursión máxima de señal de unos 4V como máximo. Para alcanzar esos valores con una ganancia de 100 necesitás apenas 40mV a la entrada. Con más que eso ya se satura el operacional.
La alimentaciónes 9V pero en fuente simple. Estoy estudiando ahora la forma de alimentarlo con fuente doble ya que me han comentado que mejora el resultado.

Cuando No hay entrada se escucha silencio como bien dices, pero he puesto la ganancia a x3 y mejora muchisimo el ruido con respecto a x100.

Cacho dijo: Ver Mensaje
Para peor, como los operacionales no entregan más que 5 o 10mA (típicamente), vas a tener que agregar el problema de que se te caerá la señal al atacar el parlante. Por eso lo de escucharlo bien bajito.
Pero el altavoz se escucha perfectamente. No a la potencia que pueden entregar pero se escucha sin problemas. ¿A que te refieres con eso de "se te caerá la señal"???

Cacho dijo: Ver Mensaje
Lo de los condensadores, efectivamente están ahí para desacoplar la contínua. El valor depende de la impedancia de la etapa siguiente.
Esos componentes forman un filtro pasaaltos (se "comen" los bajos) y su frecuencia depende de los valores de R y C, donde R es la impedancia de entrada (en Ω) del operacional o del parlante en tu esquema) y C (en F) es el valor del condensador.

La fórmula es f(-3dB)=1/(2pi*R*C). Tomemos el condensador de salida de 100uF y el parlante que arbitrariamente asumo de 8Ω (si es otro valor no importa, el razonamiento es el mismo).
La frecuencia en la que los graves "ya pasan sin problemas" será 1/(6,28*8*0,0001)~200Hz. Si la impedancia de lo que le conectes es mayor, la frecuencia de corte será menor.
Si la capacidad fuera mayor, de nuevo la frecuencia de corte será menor.

En el caso de los operacionales, la impedancia de entrada teórica es infinita, pero en la práctica "apenas" si llega a algunos MΩ, o unos "pobres" cientos de kΩ. No hay dramas ahí con los condensadores .
Gracias por la explicación de los condensadores. Entiendo perfectamente lo del filtrado y el porque de sus valores, pero si la resistencia de entrada de los operacionales es del orden del MegaOhmio, eso quiere decir que el valor del condensador de entrada apenas importa, puesto que la frecuencia de corte sera bajisima??? Y de ser así, no se colaría el ruido de baja frecuencia.???

Mandrake dijo: Ver Mensaje
Quizas tambien necesite una resistencia de 50Ω en la salida del movil (entrada del pre amplificador y Gnd).

Solo voy a referirme al condensador conectado en la entrada del pre:
Con ese valor, el circuito tiene una frecuencia de corte, Fc=159Hz; o sea que el circuito amplificara las señales con frecuencia superior a la Fc.

Si puede hacerlo de esa forma. Mejor utilice un pre con ganancia comprendida entre 1 y 3.16 (0dB y 10dB): porque pienso que el dispositivo movil (¿celular o radio?); entrega una señal suficientemente fuerte (entre 100mV y 1V), para excitar un amplificador.
Le pondré esa resistencia a ver.

Al calcular la Fc no tienes en cuenta la Rin del operacional???. Madre mia, se está comiendo todos los graves???

pokerNT dijo: Ver Mensaje
Tienes que poner un capacitor de unos 47mf-100mf en paralelo a R2, ademas una resistencia en paralelo del nodo que hay entre R1 y C6, para limitarte la intensidad de la señal de entrada porquei quiza esta sea demaciado intensa y por ese motivo se escucha el ruido debido al limite de ganancia
Gracias, así lo haré, aunque no creo que tenga a mano esos condensadores TAN GRANDES.
23/04/2011 #10
Excluido


Pelelalo dijo: Ver Mensaje
. . . Al calcular la Fc no tienes en cuenta la Rin del operacional? . . .
Como la impedancia de la entrada del operacional es elevada, no pierdo el tiempo haciendo ese calculo.
Pero la señal de entrada: circula por los componentes R1 y C6 que estan conectados en serie. Esa red tiene una constante de tiempo, que si influye en la señal de entrada.
23/04/2011 #11
Moderador general

Avatar de Cacho

Pelelalo dijo: Ver Mensaje
Cuando No hay entrada se escucha silencio como bien dices, pero he puesto la ganancia a x3 y mejora muchisimo el ruido con respecto a x100.
Debés tener demasiada señal a la entrada, así que con menos ganancia lográs que no sature el operacional
Pelelalo dijo: Ver Mensaje
¿A que te refieres con eso de "se te caerá la señal"???
Asumiendo que entregue 10mA el operacional y que el parlante sea de 8Ω, entonces tenés que cuando la señal alcance 0,08V la corriente será de 0,01A (la máxima). A partir de ahí no puede ya subir la tensión porque no hay corriente disponible como para que lo haga (Ohm lo dice).
Si nos ponemos precisos al hablar, no es que se caiga la señal, sino que no puede subir (o bajar) más.
Pelelalo dijo: Ver Mensaje
...si la resistencia de entrada de los operacionales es del orden del MegaOhmio, eso quiere decir que el valor del condensador de entrada apenas importa, puesto que la frecuencia de corte sera bajisima??? Y de ser así, no se colaría el ruido de baja frecuencia.???
Efectivamente y efectivamente.
El valor de los condensadores de entrada (así como está tu circuito) no es una cosa demasiado importante porque la impedancia de entrada será enorme. Hacé la prueba de cambiar el de 1uF que tenés por uno de 100nF y no creo que escuches diferencias. Aclaro que no tengo el datasheet fresco en la cabeza, pero apostaría a que así será.
Si querés recortar algunos bajos, hacé un filtro RC antes de eso (a fin de cuentas, una resistencia a tierra lo hace, sólo calculá su valor).
Pelelalo dijo: Ver Mensaje
...aunque no creo que tenga a mano esos condensadores TAN GRANDES.
Tranquilo, que debe hablar de micro y no mili . Suele usarse erróneamente la m en lugar de la µ (o la u) en estos casos.

@ Mandrake: ¿Qué cálculo hiciste para llegar a esas frecuencias?

Saudos
24/04/2011 #12


Si ese es el termino que suele darse, 47-100 microfaradios (mf) jejeje
24/04/2011 #13

Avatar de Pelelalo

PERFECTO. Con vuestra ayuda he comprendido bastante más algo que debieron haberme enseñado en una carrera que apodaron "Sonido e Imagen". Cosas de la vida.
24/04/2011 #14
Excluido


Pelelalo dijo: Ver Mensaje
PERFECTO. Con vuestra ayuda he comprendido bastante más algo que debieron haberme enseñado en una carrera que apodaron "Sonido e Imagen" . . .
En internet puedes encontrar tutoriales sobre aplicacion de calculos en amplificadores operacionales.
09/05/2011 #15

Avatar de johncaro12

Y el enigma de los 4 voltios?
Si cambio el valor del de entrada parece que ni funciona y a la salida del de 100uF mido hasta 4 voltios en ausencia de señal. Podrían indicarme el por qué de esos valores de Condensador.
Tengo una teoria que lo explica, a lo mejor lo mediste con un multimetro y en ausencia del speaker, con esto tendrias una red RC de 100uf y 1M (impedancia del multimetro asumo yo), esto imlica una constante bastante grande, ademas recordemos que a la salida del Opamp hay 4,5 V puesto que esta es la "tierra virtual", debido a que se esta partiendo la fuente.



Que estas metiendo a la entrada? una señal de microfono o una de linea? recuerda que la de mic va en el orden de los miliamps y la de linea puede estar por 1 voltio.
Lo adecuado con la ganancia de 200 es para microfono, porque si usas la de linea se te va a saturar causando distorsion.
Asumiendo que entregue 10mA el operacional y que el parlante sea de 8Ω, entonces tenés que cuando la señal alcance 0,08V la corriente será de 0,01A (la máxima). A partir de ahí no puede ya subir la tensión porque no hay corriente disponible como para que lo haga (Ohm lo dice).
Si nos ponemos precisos al hablar, no es que se caiga la señal, sino que no puede subir (o bajar) más.
mmmmm, te olvidas de un detalle, bueno, realmente este opamp da una corriente de salida de 40ma tipicamente, pero eso es a la salida del pin 1, no a la entrada del speaker, te falta sumar la corriente de la entrada de audio que tambien ayuda, aunque no lo creas.
09/05/2011 #16

Avatar de Pelelalo

Gracias Jhon por tu aporte. Como bien dices la señal se me satura con esa ganancia. Además conectarle ese speaker no ayuda (aunque sea un poco más de 40mA).
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Reparación de equipos de Audio

Reparación de amplificadores, mesas de mezclas, equipos de grabación y reproducción, procesadores, etc.

Cerrar
Foros de Electrónica » Reparación en General » Reparación de equipos de Audio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.