Haz una pregunta
  Foros de Electrónica » Reparación en General » Reparación de equipos de Audio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/01/2016 #1

Avatar de leonardolopezg

Problemas en amplificador con 741
Saludos colegas

Tengo montado un pequeño amplificador con un lm741,



Al principio el no amplificaba de manera clara, se escuchaba como si tuviera problemas de alimentacion, despues de cambiarle el tarfo continuó escuchandose igual, revisando las conexiones y después de aumentarle y disminuirle la ganancia sin resultados, le conecté la realimentacion directamente a la salida del operacional como se aprecia en la 2da imagen; fue entonces que se escucho mas claro aunquecon algo de ruido en la señal, al subirlo al maximo se llevo el operacional y otro mas que le puse para volver a probar...

La pregunta: ¿que estoy haciendo mal?

ya habia realizado otros dos anteriormete y ambos me dieron trabajo pero funcionaron, creia que con la practica iba a mejorar pero cada ves me salen peor....

El objetivo es un pequeño amplificador de uno 10W ya que no tengo acceso a los TDA´s
11/01/2016 #2
Moderador general

Avatar de DOSMETROS

Ummm , yo pondría :

- Dos transistores de salida algo mas grandes
- Dos díodos de protección en anti paralelo con colector-emisor de los de salida
- 10 uF en vez de 1 uF
- Dos resistencias de 1k entre base y emisor de los de salida
- Dos capacitores de 50 pF entre bases y colectores de los excitadores
11/01/2016 #3

Avatar de juanma2468

Creo que tu problema puede venir por el lado del transistor BD237 de la rama de abajo por ser NPN, este debería ser un PNP. Fijate la imagen que te adjunto de una estapa clase B. Además deberían ser 2 diodos de polarización ya que tenes 2 junturas PN
Imágenes Adjuntas
Tipo de Archivo: png Ampli clase B.png (4,9 KB (Kilobytes), 161 visitas)
11/01/2016 #4
Moderador general

Avatar de DOSMETROS

Es correcto , es un "cuasi complementario"

El que vos propones es "complementario"
11/01/2016 #5

Avatar de Dr. Zoidberg

En realidad tiene un par darlington arriba y un par sziklay abajo (configuracion cuasi-complementaria), así que debería poner dos diodos en la mitad superior y dejar el que ya tiene en la inferior. Hay algunos otros errores como los que marca Dosmetros y algunos más... no sé, yo le recomiendo que use este esquema de referencia...
11/01/2016 #6

Avatar de juanma2468

Tambien una resistencia de bajo valor en el emisor de los BD no estarian de más.
12/01/2016 #7

Avatar de leonardolopezg

Gracias por las resuestas, me dedicare a efectuar los cambios y sugerencias, exepto la de los transistores complementarios, estoy obligado por ausencia fisica de transistores pnp complementarios...
Comentaré los resultados obtenidos.

---------- Actualizado después de 4 minutos ----------

Dr. Zoidberg dijo: Ver Mensaje
(...) no sé, yo le recomiendo que use este esquema de referencia (...)
¿¿Por qué los filtros de desacople en la salida?? según tengo entendido cuando se alimenta con fuente doble (±vccc) no son necesarios
12/01/2016 #8

Avatar de Dr. Zoidberg

leonardolopezg dijo: Ver Mensaje
Gracias por las resuestas, me dedicare a efectuar los cambios y sugerencias, exepto la de los transistores complementarios, estoy obligado por ausencia fisica de transistores pnp complementarios...
Comentaré los resultados obtenidos.

---------- Actualizado después de 4 minutos ----------



¿¿Por qué los filtros de desacople en la salida?? según tengo entendido cuando se alimenta con fuente doble (±vccc) no son necesarios
Segui leyendo que la respuesta esta mas adelante.
12/01/2016 #9
Moderador general

Avatar de Fogonazo

Por aquí para ser mas precisos.
12/01/2016 #10

Avatar de juanma2468

Transcribo el fragmento donde hablan del capacitor de desacoplo
Dr. Zoidberg dijo:
...Este ampli tiene algunas cosas muy buenas, como el capacitor de acople de salida aún cuando la alimentación es de doble polaridad, por que ese cap me asegura que si vuela algo en el ampli la tensión de CC no se lleve los auriculares a mejor vida. Lo único que no me gusta mucho es que tiene una ganancia de 5.7 que me parece un poco "alta" pero como no sé que niveles voy a manejar e esa parte del preamplificador, mejor la dejo así y la bajo un poco si fuera necesario mas adelante...
12/01/2016 #11

Avatar de leonardolopezg

Ohh... ya vi gracias, tiene mas sentido ahora... con respecto a las sugerencias originales:

DOSMETROS dijo: Ver Mensaje
Ummm , yo pondría :

- Dos transistores de salida algo mas grandes
- Dos díodos de protección en anti paralelo con colector-emisor de los de salida
- 10 uF en vez de 1 uF
- Dos resistencias de 1k entre base y emisor de los de salida
- Dos capacitores de 50 pF entre bases y colectores de los excitadores
en el caso de dos transistores de salida mas grandes... ¿se pueden poner otro BD´s en paralelo?. Además me imagino que también habria que aumentar el tamaño (potencia) de los exitadores...
12/01/2016 #12

Avatar de diegomj1973

Sugeriría un capacitor de 4,7 uF para el de entrada (en lugar de uno de 1 uF), uno de 220 uF para el de realimentación (en lugar de uno de 10 uF), un diodo más en serie al 1N4148 superior, bajar las dos resistencias de 10 K a 2K2. Todo esto es si quien postea no puede cambiar la configuración de la etapa de salida ni los transistores.

Con una alimentación de + - 12 V no esperes mucho más de 7 W sobre 8 ohmios. Operar sobre menos de 8 ohmios => imposible con esos transistores de salida. Para lograr esa potencia máxima se debe inyectar unos 157 mV RMS a la entrada. No sería descabellado reducir la ganancia a algo como 19 veces (reduciendo la resistencia del lazo de realimentación de 47 K a unos 18 K): con ello se aumentaría el ancho de banda pasante y se mejoraría la relación de señal a ruido. La señal de realimentación la tomaría siempre de la salida al parlante. Unos condensadores de 100 pF entre base y colector de cada excitador van a ser obligatorios.

Sugerencia: de ser posible, sustituir el LM741 por un TL071, ya que la ganancia a lazo cerrado es muy grande y se van a ver muy comprometidos los sonidos agudos.

Saludos
12/01/2016 #13


leonardolopezg dijo: Ver Mensaje
Gracias por las resuestas, me dedicare a efectuar los cambios y sugerencias, exepto la de los transistores complementarios, estoy obligado por ausencia fisica de transistores pnp complementarios...
Comentaré los resultados obtenidos.

---------- Actualizado después de 4 minutos ----------



¿¿Por qué los filtros de desacople en la salida?? según tengo entendido cuando se alimenta con fuente doble (±vccc) no son necesarios
Hola a todos , caro Don leonardolopezg tenga en mente que capacitores de desacople en lo barramento de alimentación sienpre son mas que bienvenido y si nesesarios para que cualquer circuito electronico trabaje bien.
En tu caso la ausencia deses puede transformar lo amplificador en un bueno oscilador mas conocido como "motorboating"
Att,
Daniel Lopes.
12/01/2016 #14

Avatar de leonardolopezg

diegomj1973 dijo: Ver Mensaje
(...) Todo esto es si quien postea no puede cambiar la configuración de la etapa de salida ni los transistores.
La verdad?? no tengo muchas opciones para cambiar la etapa de salida...

diegomj1973 dijo: Ver Mensaje
Con una alimentación de + - 12 V no esperes mucho más de 7 W sobre 8 ohmios. Operar sobre menos de 8 ohmios => imposible con esos transistores de salida. Para lograr esa potencia máxima se debe inyectar unos 157 mV RMS a la entrada.
El parlante es de cerca de 6Ω y dice ser de 6W por lo que no me preocupa mucho que la salida que con algo cercano a lo 8W RMS

diegomj1973 dijo: Ver Mensaje
(...) La señal de realimentación la tomaría siempre de la salida al parlante.
Como dije antes, la realimentacion la tenia como esta en el plano original, y no se escuchaba bien, mas bien "no se entendia nada del audio", cuando cambie la realimentacion para la salida del operacional fue que se escucho, mas tarde probare los cambios y comentare los resultados....

diegomj1973 dijo: Ver Mensaje
(...)
Sugerencia: de ser posible, sustituir el LM741 por un TL071, ya que la ganancia a lazo cerrado es muy grande y se van a ver muy comprometidos los sonidos agudos.

Saludos
Me gustaría poder sustituirlo peor estoy rodeado a duras penas de algunos 741 en varios de sus modelos (UA741, lm741,) 8 pines, 14 pines...
12/01/2016 #15

Avatar de diegomj1973

Fijate algunas de las modificaciones que te sugiero (circuito de la izquierda) y analizá cómo queda el nuevo ancho de banda (en color verde), la ganancia y la THD.

Se pueden implementar varias mejoras más, todavía. Con esas modificaciones mostradas, tenés para entretenerte un buen rato. Después, queda mejorar el slew rate con un cambio de opamp y un agregado de resistencias en lugares específicos de los transistores de salida.







Es lógico que se haya escuchado bastante mal, haciendo un breve análisis del circuito .

Fijate, además, que implementando el cambio de punto de realimentación que has empleado, si bien mejora la respuesta en frecuencia y la distorsión, sigue siendo aún mediocre el desempeño general (entre lo que la impedancia de salida se va a las nubes y corrés, además, el riesgo de un alto offset en la salida).





Saludos

PD: M U Y I M P O R T A N T E !!!: CON LOS CAMBIOS PROPUESTOS, DOTAR DE MUY BUENOS DISIPADORES DE CALOR A LOS TRANSISTORES DE SALIDA.
Imágenes Adjuntas
Tipo de Archivo: jpg Sin título2.jpg (41,4 KB (Kilobytes), 131 visitas)
Tipo de Archivo: jpg Sin título4.jpg (41,9 KB (Kilobytes), 131 visitas)
Tipo de Archivo: jpg Sin título6.jpg (73,3 KB (Kilobytes), 130 visitas)
Tipo de Archivo: jpg Sin título8.jpg (134,3 KB (Kilobytes), 127 visitas)
Tipo de Archivo: jpg Sin título10.jpg (43,1 KB (Kilobytes), 127 visitas)
12/01/2016 #16

Avatar de leonardolopezg

Gracias diegomj1973 visto de la manera esa me convences mucho más... en las simulaciones que le realizé antes de montar el esquema solo comprobé el funcionamiento, uso el Proteus y no pude simularlo con los trasistores de salida, en fin solo vi que funcionara bien con esos valores...
Pasaré a probar todos los nuevos cambios...
12/01/2016 #17

Avatar de diegomj1973

Del esquema que te sugerí subo alguna data que te pueda interesar:







De todos modos, tené presente que la palabra final la tiene el circuito real tal como se vaya a comportar en la práctica. Esto que subo es solo una guía aproximada, pero que nos puede dar alguna idea o pista de cómo vaya a comportarse en las pruebas. Sobre las resistencias de 2K2 vas a tener que experimentar algún valor por encima ó por debajo (muy seguramente), midiendo siempre la corriente de reposo por el par de salida.

Con ese opamp en la entrada se queda algo corto de desempeño en alta frecuencia, si pretendés alta ganancia en lazo cerrado. Un truco sería reducir la ganancia al mínimo requerido (es decir, no dejar saldo de nada) para mejorar el desempeño en alta frecuencia.

Espero te sirva y puedas disfrutar tu amplificador.

Saludos
Imágenes Adjuntas
Tipo de Archivo: jpg Sin título2.jpg (138,7 KB (Kilobytes), 123 visitas)
Tipo de Archivo: jpg Sin título4.jpg (55,4 KB (Kilobytes), 125 visitas)
Tipo de Archivo: jpg Sin título6.jpg (55,3 KB (Kilobytes), 122 visitas)
12/01/2016 #18
Moderador general

Avatar de DOSMETROS

leonardolopezg dijo: Ver Mensaje
en el caso de dos transistores de salida mas grandes... ¿se pueden poner otro BD´s en paralelo?. Además me imagino que también habria que aumentar el tamaño (potencia) de los exitadores...
Poné dos BD's en paralelo en la salida , los excitadores estarán bien . . .
13/01/2016 #19

Avatar de diegomj1973

DOSMETROS dijo: Ver Mensaje
Poné dos BD's en paralelo en la salida , los excitadores estarán bien . . .
Si bien a esos BD237 no les sobra mucho de resto para esos 6 a 7 W sobre 8 ohmios, tengo mis dudas si sería estrictamente necesario agregar un par más en paralelo a los existentes (con sus debidas resistencias de ecualización los 4 transistores de potencia), ya que el fT no es de los más altos (3 MHz) y no hay muchas chances de cambiar adicionalmente ese lento LM741 en la entrada (GBW de 0,437 MHz).

De todos modos, los excitadores estarían sobrados para un par de transistores de potencia adicional más (aunque, como dije antes, dudo si serían estrictamente necesarios).

Personalmente, sugeriría no degradar aún más la respuesta en alta frecuencia, que ya viene bastante deteriorada por encima de los 8 KHz, aún con ganancias de lazo cerrado bastante bajas.

Saludos

PD: sugerencia de sustitución para mejorar la parte alta del espectro en forma radical: los excitadores por BC550C y BC560C (el fT pasa de 100 a 150 MHz), el opamp por TL081 (el GBW pasa de 0,437 a 4 MHz). Con esa sustitución bajamos la THD del 10 % a los 0,145 % en los 8 KHz y a 6,18 W sobre 8 ohmios (que no están tan mal). El gran impacto de cambio lo provoca el opamp, seguido en menor medida por el cambio de excitadores y, por último, si queremos ganar un plus más, los transistores de potencia (aunque con este último cambio hay que ser muy cautelosos por las posibles oscilaciones, en mayor medida si disponemos más de un par de salida).
13/01/2016 #20

Avatar de leonardolopezg

Gracias una vez más por responder...

Ya realice algunos de los cambios referidos por diegomj1973, solo me faltó poner los condensadores en paralelo a los diodos... resultados:

Por momentos se escuchaba bien , y de momento se silenciaba el audio, la tocar el operacional (el encapsulado es de metal) el amplificador hacia un ruido fuerte, o volvia a amplificar, o se escuchaba mas alto y con ruidos, pasaba lo mismo al tocar los disipadores... tambien pasaba sin yo tocarlo, se subia con el volumen con la aparicions de ruidos o sa bajaba el volumen al minimo

Aclaracion: la fuente de audio no es la del problema (eso es seguro)

tengo la impresion de que hay falsos contactos o tego muchas interferencias en el esquema... pero me queda la experanza de que en el mar de problemas por resolver, se escuchó como yo quería...

++++++++++++++++++++++++++++++++

Con respecto al las sugerencias de DOSMETROS hoy le colocare los condensadores de 47pf entre colector y base de los exitadores y lugo de las pruebas la resistencia de 1k, a otros montaje les he colocado tambien condensadores de pequeño valor de ±vcc a tierra para los ruidos e interferencias...

-----------------------------------------------------------
Las pruebas las realize dos veces, una con un pequeño parlante de 8 ohm@2w y las otras, con otro de 4 ohm@6w, para mi era de esperar que donde mas problemas dio fue con el de 4 ohm aunque estoy pensando en dejarlo con el de 4... se escucha mejor y es más grandecito...
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Reparación de equipos de Audio

Reparación de amplificadores, mesas de mezclas, equipos de grabación y reproducción, procesadores, etc.

Cerrar
Foros de Electrónica » Reparación en General » Reparación de equipos de Audio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.