Haz una pregunta
  Foros de Electrónica » Reparación en General » Reparación de equipos de Audio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

04/07/2016 #1


Ruido parásito al conectar amplificador clase D junto con un clase AB
Hola gente, básicamente el problema es el descripto.
Si desconecto el clase D, el ruido desaparece (aún con el coche encendido). Si lo conecto, en los altavoces conectados al clase AB aparece un ruido al encender el coche (supongo que viene del encendido del coche). Tengo conectadas todas las masas a un mismo punto.
No se que más hacer, las masas RCA están perfectas.

Gracias
05/07/2016 #2

Avatar de nasaserna

Hay varias causas, que bueno ver las conexiones y los equipos, la otra es saber que tipo de fuente tiene el tipo D, ahí puede radicar el problema, pues los elevadores de tensión generan algunos inconvenientes,
suerte
05/07/2016 #3


Es un kicker cx 300.1, no se qué fuente tendrá y no lo quiero desarmar porque aún está en garantía. Ya estoy pensando en cambiar el clase D por un AB de dos canales y puentearlo... El ruido es muuuy agudo, inaudible para personas mayores, pero yo lo oigo perfectamente. Hay otros parlantes que los tengo conectados directamente al stereo y en esos no se produce ruido. Solo se produce en los que estan conectados a la etapa AB
05/07/2016 #4

Avatar de shevchenko

Seguro que el ruido es del oscilador del clase D que se filtra en el clase A saliendo por sus parlantes, en la alimentación del ampli clase D Agrega un filtro tipo PI así el ruido no pasa por la alimentación,
También puede pasar por la ficha de entrada de audio.... incluso si están dentro de un mismo gabinete o cerca físicamente uno del otro...
05/07/2016 #5


Están muy cerca físicamente, pero no están en contacto. Podrías explicarme un poco más acerca del filtro? Cuáles deberían ser los valores de cada componente? Gracias por tu tiempo

PD: vale volver a resaltar que el ruido solo aparece cuando el coche está en contacto o encendido, pero es particular de esa etapa clase D que ocurre. Si la quito no tengo más ruido aún con el coche encendido o en contacto. Debe ser una combinación de ambas cosas y el efecto solo se produce cuando tanto la etapa clase D como el encendido se encuentran conectados, al faltar alguno de ellos el ruido no aparece.
06/07/2016 #6


Tu problema es el auto, no se que auto tenes, pero había muchos que eran propensos a generar ruidos, y dependiendo de estereo se escuchaba o no, incluso me ha pasado hace ya muchas decadas atras que dependiendo de como estaba carburado el ruido disminuia o aumentaba.

Una de las soluciones era colocar bujias con resistencias, los autos actuales ya usan ese tipo de bujias, y cables resistivos anti-parasitarios, si con eso el ruido seguía les colocaba una bobina hecha sobre una barra de ferrite de las antenas de AM o algo similar, junto con varios capacitores antes y despues de la bobina, y de distintos valores, no vale poner uno que sea la suma de todas las capacidades.
06/07/2016 #7


El ruido sólo se produce con la etapa clase D conectada, por lo que dudo que sea sólo el auto el problema. Es un Peugeot 307, con las bobinas que vienen en un bloque y sin cables de bujía. Las bujías no son resistivas me parece, de todos modos el ruido se produce ya con el auto en contacto. También suele meter ruido en la radio AM esa etapa clase D, al igual que los balastros de xenon que también meten ruido en la AM, más no en otros modos de escucha del stereo. Me inclino más a un problema de oscilación que aún no se como resolver
06/07/2016 #8

Avatar de pilm

Hola follow8. Yo colocaría filtros en las líneas de alimentación de los amplificadores. Varios capacitores de diferente valor en paralelo (priorizando de 0.1uF) y de ser posible una bobina en serie o al menos “beams” de ferrita rodeando los cables. Esto evitará que el clase D contamine con interferencias el sistema electrico y que el clase AB las recoja.
06/07/2016 #9


Gracias por tu respuesta pilm. Qué tipo de bobina y de cuantos mH debería ser? Alguna de una fuente atx de pc servirá? Y respecto a los capacitares, cuales serian los valores específicos? Electrolíticos o cerámicos? Muchas gracias
06/07/2016 #10

Avatar de pilm

Pues tendrías que probar de varios valores, todo depende de la banda de frecuencia del ruido involucrado; te recomiendo que inicies poniendo varios de 0.1uf hasta 10uF y vayas apreciando si obtienes mejoría, tendrían que ser cerámicos y de tántalo (los electrolíticos de aluminio no te recomiendo). Las bobinas si te podrían servir las de PC pero ojo con el calibre del conductor, pues dependiendo de la potencia de los amplificadores, necesitas unas cuantas decenas de amperios para alimentarlos, sobretodo el clase AB, el clase D no tanto pues es de alto rendimiento. Posiblemente tengas que rebobinar los inductores con conductor de calibre adecuado.
06/07/2016 #11


Entonces lo de la bobina en serie se complica un poco... Probaré primero con capacitores. Otro detalle a tener en cuenta es que si al stereo lo alimento externamente, no aparece ningún ruido. Por lo que claramente el ruido está en la alimentación y no en los RCA. Sería más correcto poner los filtros en la alimentación del stereo? Ya que ahí es donde parece que afecta la interferencia eléctrica
06/07/2016 #12

Avatar de nasaserna

Para, para dijiste que si alimentas el radio externamente no aparece el ruido???

ni siquiera en la potencia AB, si es asi mejor el filtro al estereo, mas barato menos grande la bobina
06/07/2016 #13

Avatar de pilm

Pues sí, en ese caso es mas fácil. El stereo no demanda muchos amperios y se simplifica lo de las bobinas. Pero el filtro en el clase D sigue siendo importante, como ya dije, al menos unos “beads” sobre los cables; tal vez los consigan en la chatarra, pues los electrodomésticos que involucran motores suelen traerlos en los cables de alimentación.
06/07/2016 #14


Servirán esos supresores de ruido que venden en los autoradio? Me refiero a los que van a 12v, no los de RCA

---------- Actualizado después de 2 minutos ----------

Y los beads de ferrita veré si consigo en algún cable de electrodomestico viejo...
06/07/2016 #15

Avatar de nasaserna

Viendo los precios, y lo ambiguo de sus datos
http://articulo.mercadolibre.com.mx/MLM-551626161-supresor-de-ruido-automotriz-de-20-amperes-_JM

es mucho mejor hacerlos uno mismo
06/07/2016 #16

Avatar de pilm

Si, no está por demás que pruebes con ese supresor que mencionas, suele estar constituido por un filtro paso bajo en torno a un capacitor y una bobina, lo malo es que está última posee un núcleo de hierro al silicio, lo que la hace ineficiente a transitorios de alta frecuencia que me imagino es lo que está produciendo el clase D.
06/07/2016 #17


Acá en Argentina valen unos 5 usd, pero uno no sabe qué tienen adentro. Si lo armo debería ser una bobina en serie (la idea es usar una de fuente de pc sin reformar ni modificar) y unos cuantos capacitores desde 0.1uf hasta 10uf que irían en paralelo. Si con esto no se soluciona, no me quedará otra que deshacerme de la etapa clase D
06/07/2016 #18

Avatar de pilm

El filtro que publica nasaserna estaría muy bien colocarlo entre el audio que va del stereo al clase AB, pero por el costo, primero intentar filtrar bien las fuentes creo sería lo mejor. Por cierto, los cables que transportan esta señal deberían ser lo mas cortos posible, y apantallados; me refiero, a aquellos que tienen dos cables internos para conducir la señal y la malla externa solo es la pantalla que se conecta a tierra (no de be conducir señal)
06/07/2016 #19


Actualmente estoy usando cables RCA no apantallados, estuve usando unos apantallados y el ruido seguía, al fin y al cabo los saqué porque tenían un falso contacto en una ficha y puse unos comunes de 3 metros. El filtro de RCA he leído que atenúa mucho la señal y le quita agudos, no es lo que busco...
06/07/2016 #20

Avatar de pilm

Yo no me desharía de la clase D. Como ya mencioné son amplificadores muy eficientes; comparando con similar potencia en clase AB consumen la mitad de corriente.
Yo, en lo particular suelo instalar bajos potenciados con una etapa clase D de diseño propio que puede configurarse entre 200 y 400 Wrms. Para los medios y altos uso el propio estéreo (si es de buenas prestaciones). La clave está en hacer un buen trabajo con los parlantes; si están instalados en las puertas se debe tapar todas las aberturas del panel y colocar material aislante, si van en cajas aparte, estas deben calcularse adecuadamente, acorde con los parámetros de los parlantes, para aprovecharlos al máximo. Así ismo se deben instalar los correspondientes crossover. De ser necesario elevar la potencia de medios y altos utilizo módulos clase D que siendo de buena calidad se consiguen a precios muy cómodos.
Como filtro suelo emplear un pequeño banco de capacitores; unos diez de 1000uF y unos cinco de 0.1uF. Los primeros me aseguran la suficiente corriente al momento que se presentan los bajos y los segundos eliminan la mayoría de transitorios.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Reparación de equipos de Audio

Reparación de amplificadores, mesas de mezclas, equipos de grabación y reproducción, procesadores, etc.

Cerrar
Foros de Electrónica » Reparación en General » Reparación de equipos de Audio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.