Haz una pregunta
  Foros de Electrónica » Reparación en General » Reparación de equipos de Audio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

24/07/2015 #1


Subgrave RCF sin Microcontrolador
Hola!

Recientemente he adquirido éste subgrave autoamplificado, RCF 4Pro 8001-AS, sabiendo que la electrónica no encendía, y que el altavoz estaba abierto.

Lo del altavoz ha sido muy fácil, sólo levantar la tapa que cubre la bobina se veía dónde estaba interrumpido, un punto de soldadura y pegamento, y listo!

El tema viene al abrir la electrónica. Salta a la vista un zócalo vacío, y enseguida me doy cuenta que allí iba un microprocesador. Tengo el esquema de esa parte, y el chip es el PIC16F870 de 28 pines.
Sin ese chip, el equipo está "muerto". Controla todo, desde el ventilador, tensiones, relés, temperaturas, etc...
Todas las tensiones están correctas, se alimenta con +-40v y +-90v, todas las tensiones secundarias, +-15v, +-12v y +5v están presentes, no hay nada fundido ni recalentado.

El anterior dueño no tiene ni idea de quién ni cuándo ha podido sacar el chip, y me consta que dice la verdad ya que el sub llevaba varios años tirado en un sótano, desde que petó el altavoz. De hecho, la placa trasera sólo tenía 4 de los 10 tornillos que la sujetan.

Conseguir el chip es fácil, pero, mis problema son: No tengo el programa que hay que cargarle al procesador. He mandado un par de mails al fabricante y al SAT, pero no tengo muchas esperanzas por ahí... y por otra parte, tampoco tengo programador ni la más mínima experiencia programando estos bichos... aunque si me tengo que poner, lo hago.

¿Alguna sugerencia?

Dejo fotos de la placa, el zócalo vacío, y el esquema de esa placa.

Gracias!
24/07/2015 #2


1.-Buscar el mismo equipo y sacarle el micro
2.- Buscar el mismo equipo y copiar el micro.
3.- ingenieria inversa y hacer el programa o mandar a hacerlo y gravar un nuevo micro.
25/07/2015 #3


Hola!
Gracias por contestar.
Ya he dado el primer paso, que es hacerme con un programador de PIC. Lo más difícil será conseguir el .hex, pero estoy en ello.
Iré posteando los avances.

Basándome en el circuito, he "forzado" el disparo de los relés, y he comprobado que el amplificador funciona perfectamente. Se me está ocurriendo un plan B, si no consigo el programa.

Saludos!
25/07/2015 #4


Excelentisimo!
Claro es una opcion viable el hacer puentes para hacer funcionar las partes, pero analiza bien que es lo que puede llegar a controlar el micro...
Exito!
28/07/2015 #5


Hola!

Gracias Herfeest! He encontrado un sub casi igual, el 8002-AS, la electrónica es la misma, cambia la caja del bafle, y el chip en cuestión es SMD. Está soldado en los pads vacíos que se ven en la foto. ¿Se pueden soldar hilos para leer el programa que tiene? Evidentemente no puedo desoldar el chip, es un sub que se está usando, pero en la placa parece que tiene unos pines para la programación.....

Saludos!
Imágenes Adjuntas
Tipo de Archivo: jpg detalle.jpg (143,9 KB (Kilobytes), 10 visitas)
28/07/2015 #6
Moderador general

Avatar de DOSMETROS

El 99,99 % de las veces están protegidos contra copia

Probaste de comprarselo al fabricante ?
28/07/2015 #7

Avatar de Daniel Meza

Esos "pads" que se aprecian en la foto me parece que son para comunicación del micro nada más.

Soy de la idea de que, ya que hallaste un equipo similar, observes el comportamiento del micro para tratar de copiar ("simular") su tarea con otro micro.
29/07/2015 #8


Hooola_que_tal !

Señor DOSMETROS, espero que no sea como dices Y entonces pasaremos al plan B, Lo que dice Daniel Meza, hacerme mi propio programa.
Tengo un par de amigos que programan a nivel app´s y programas y plugins de sonido, esto no debería ser difícil para ellos, pero como todos los buenos, no disponen de mucho tiempo libre

Y sí, la opción de buscar soporte por parte del fabricante está en desarrollo, del SAT ya me contestaron, que se lo lleve alli y el distribuidor de la marca me está intentando conseguir el .HEX de la casa madre, en Italia, aunque no promete nada y seguramente haya que esperar a Septiembre, después de las vacaciones de verano.

Añado fotos de la reparación del altavoz de 18". Se había roto el hilo de la bobina justo al lado de la soldadura superior. Creo que ha sido por que en esa parte, no había pegamento que fijase el hilo al papel. Bueno, soldar, cubrir con pegamento y poner y sellar la tapa. Listo!

Seguiré dando las novedades, Gracias y Saludos!
Imágenes Adjuntas
Tipo de Archivo: jpg 20150726_211910.jpg (68,3 KB (Kilobytes), 11 visitas)
Tipo de Archivo: jpg 20150727_225932.jpg (106,2 KB (Kilobytes), 10 visitas)
Tipo de Archivo: jpg 20150727_231114.jpg (124,0 KB (Kilobytes), 11 visitas)
Tipo de Archivo: jpg 20150727_231128.jpg (110,3 KB (Kilobytes), 10 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Reparación de equipos de Audio

Reparación de amplificadores, mesas de mezclas, equipos de grabación y reproducción, procesadores, etc.

Cerrar
Foros de Electrónica » Reparación en General » Reparación de equipos de Audio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.