Haz una pregunta
  Foros de Electrónica » Reparación en General » Reparación de equipos de Audio
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

17/07/2012 #1


Teclado Yamaha PSR-2000 algunos botones no funcionan
Un saludo a todos los compañeros del foro. Hace ya varios años tengo una Yamaha PSR-2000, funcionaba perfectamente, un dia la encendi y me di cuenta que algunos botones no funcionaban (Start, algunos ritmos, algunos instrumentos, etc), los demas funcionan perfectamente.

Tengo un pequeño conocimiento en electronica y estaño, asi que la desarme para mirar si eran los switch pulsadores, le cambie los que parecian estar dañados por unos nuevos y el problema continuo..

Si alguien puede ayudarme, darme un consejo o una observacion le agradezco mucho, pues este teclado lo utilizo como herramienta de trabajo y me hacen falta esos botones.
Muchas gracias.
25/09/2012 #2


Estimado amigo:

Partiendo de la base que no conozco ese modelo en concreto te comento lo siguiente:

La lectura de los botones, por parte del MCU encargado, se hace de forma matricial, es decir, todos los pulsadores van interconectados a una matriz de modo que cuando pulsas uno realmente estás uniendo una salida del procesador (o lo que tenga) con una entrada del mismo, él registra esa orden y la valida como que has pulsado tal función y traslada la orden oportuna para que se ejecute. Lo más probable es que todos esos pulsadores que no funcionan tengan un punto común que es el que está fallando, trata de establecerlo y revisa los puentes o conexiones entre caras de la pcb, el fallo suele ocurrir en esos puntos.
25/09/2012 #3

Avatar de nasaserna

al desarmar la psr puedes ver que la pieza larguísima de silicona que tiene los contactos en dos bandas. en la parte trasera debe tener unas perforaciones producidas por el uso normal, puedes cambiar la goma en un servicio tecnico de yamaha, o si tienes tiempo y cuidado puedes probar lo siguiente:
Simplemente cortas la goma que recibe las señales del teclado en uno de los dos extramos de ella apróximadamente 1mm y lo corres colocandolo en el otro extremo de la goma de contactos, casi siempre da resultado, además la tir de contactos es un poco dificil de encontrar al menos en mi pais

Corrijo mi respuesta no leí bien tu pregunta, la solucion que te acabo de dar es para el caso en que algunas de las teclas dejan de funcionar.
25/09/2012 #4


Bien amigos, muchas gracias por sus respuestas.
Nasaserna, tienes la razon, tu respuesta es para las teclas, muchas gracias de todas formas y esperemos que encontremos la solucion a mi problema.

Cqtsdss, muchas gracias por tu respuesta. Yo probe la continuidad partiendo desde los pulsadores que estaban "fallando" y como tu dices, todos se van conectando en serie, pero siempre encontraba continuidad. Se me olvido mencionar que donde tenia el teclado era una habitacion en la cual tuvimos problemas de humedad, no se si esto tenga algo que ver pero he pensado que se daño algun integrado por esa causa, porque los buses de comunicacion y el resto de componentes parecen estar bien.

No se que mas pueda hacer. Muchas gracias por su ayuda compañeros.
25/09/2012 #5

Avatar de nasaserna

los suiches que cambiaste eran, exactamente iguales a los originales, a mi me paso, que un dia cambie los suiches de una psr700 y los coloqué al reves, obviamente no funcionaron,

perdon psr7000, tengo que dormir mejor
25/09/2012 #6


Si, los suitches eran iguales, las mismas medidas, la misma altura pero en los suitches que estaban "malos" hay continuidad cuando se pulsan, eso es lo que me pone a pensar que tal vez fue un integrado.

Se me olvido mencionar otra cosa, los parlantes no suenan, abro el teclado, reviso la conexion de los parlantes y perfecta, mido continuidad en dichos cables y perfecta, enciendo el teclado desarmado y suena! me fijo que no quede un cable pisado al cerrarlo, lo cierro y lo pruebo y no suenan! algo raro.
25/09/2012 #7

Avatar de Melghost

A ver si vas a tener una pista cortada en la placa... o una soldadura fría. En algunos aparatos ocurre a veces que si fuerzas mecánicamente un poco la placa funciona, y si la dejas en reposo no funciona, o viceversa. Lo ideal sería conseguir que falle cuando está abierto, y después ir tocando los componentes uno a uno.

Los pulsadores que fallan... ¿empezaron a fallar al mismo tiempo? ¿Fallan siempre, o alguna vez vuelven a funcionar?
25/09/2012 #8


Un saludo Melghosst. Aparentemente todo esta bien, pues no se ven pistas cortadas y en los cables hay continuidad. Soldaduras frias tampoco he visto, tengo que revisarlo otra ves bien.
El teclado estuvo mas o menos 3 meses sin uso y puesto contra un muro que tenia problemas de humedad (no se si tenga algo que ver)

Sobre los pulsadores, dejaron de funcionar asi no mas, un dia la prendi y ya no funcionaban y no han vuelto a funcionar.

Muchas gracias.
25/09/2012 #9

Avatar de nasaserna

Busca en la placa señales de humedad, algunas pistas se corroen por debajo del antisolder(barniza verde) y a veces se nota porque quedan un poco infladas, verifica las soldaduras, que tienen el característico polvillo blanco de la corrosion.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Reparación de equipos de Audio

Reparación de amplificadores, mesas de mezclas, equipos de grabación y reproducción, procesadores, etc.

Cerrar
Foros de Electrónica » Reparación en General » Reparación de equipos de Audio

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.