Haz una pregunta
  Foros de Electrónica » Sistemas de Audio » Audio: Discusión General
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

05/05/2009 #21

Avatar de Dr. Zoidberg

juanma dijo:
En este punto me desoriente un poco, donde me estoy equivocando, no logro verlo.
Comparo con el ClassA de SiliconChip, y Vce del transistor del VAS es casi Vcc, es decir, esta poco/nada polarizado. Cuando arme este amplificador, medi Vce≈8.5V (Vzener 9V1 . Vcc +/-22V) y sin embargo anduvo.
Esta es la medicion (respecto de tierra) de Vce de los transistores de VAS cuando el amplificador satura un poco. Estoy tratando de ver si es correcta:
Cuales son las condiciones de la prueba que hiciste? Con entrada en corto a masa y el multiplicador Vbe ya ajustado?
Fué una prueba estática o dinámica?

Saludos!
05/05/2009 #22

Avatar de juanma

Buenas, lo tipico.
1ero con la entrada a masa, verificado tensiones "standard"
Utilizo resistencias de 100Ω en serie a modo de evitar cualquier corto sobre la fuente y que se queme algo del amplificador.
El multiplicador Vbe sin problemas. La corriente en reposo => Vre = 0.010V => ≈10mA no estoy seguro de que las Re sean de 0.22Ω, medidas con el tester comun marca 1Ω. Igualmente lo deje en un valor bajo por precaucion.
Espere un tiempo a ver si todo seguia marchando bien y si, todo ok.

2do, lo probe con un parlante de pruebas (<3U$S), al seguir funcionando correctamente, probe con uno de mas calidad a ver que tal el sonido. Poco y nada de ruido escuche.

Asi que en ambas pruebas dio satisfactorio. NO a mucho volumen si y no lo he podido verficar aun con un osciloscopio.
En un tiempo que tenga mido las tensiones y las subo.
05/05/2009 #23
Moderador

Avatar de hazard_1998

juanma dijo:
Guarda, creo que simulaste la version que estaba mal (voy a dejar solamente todo lo que funciona, asi evito que simulen algo que no anda).
En la 1.3.1 que arme, no use el seguidor de emisor, y Cmiller quedo entre la base de Tr del VAS y el colector del cascode. En el esquema de mas arriba que arme esta colocado.

Lo del cascode, todo un tema. Comento un poco la historia.
Para armar este amplificador, tome como referencia otros, como comente.
El esquema de Randy no funciona, porque el current mirror no garantiza la polarizacion en clase A del transistor del VAS. Sin saber esto, lo arme en el protoboar y NO funciono, como era de esperar.
Por lo que me comentaron en el foro de DIYAudio, la solucion es no usar current mirror y usar resistencias tales que tengan una caida de tension >0.6V.

fijate bien, yo tengo aca el ultimo esquema que subiste, el 1.3.1-1
los transistores Q2 y Q4 son seguidores de emisor, y efectivamente, los C miller estan entre su base y el colector del cascodo.
05/05/2009 #24

Avatar de juanma

hazard_1998 dijo:
fijate bien, yo tengo aca el ultimo esquema que subiste, el 1.3.1-1
los transistores Q2 y Q4 son seguidores de emisor, y efectivamente, los C miller estan entre su base y el colector del cascodo.
Buenas hazard, el circuito que arme en protoboar es este, el 1.3.1 es la version que anda en el simulador, pero no la que arme. La que arme no tiene seguidor de emisor:
Esta mal colocado Cmiller?
06/05/2009 #25

Avatar de Dr. Zoidberg

juanma dijo:
Buenas, lo tipico.
1ero con la entrada a masa, verificado tensiones "standard"
Utilizo resistencias de 100Ω en serie a modo de evitar cualquier corto sobre la fuente y que se queme algo del amplificador.
El multiplicador Vbe sin problemas. La corriente en reposo => Vre = 0.010V => ≈10mA no estoy seguro de que las Re sean de 0.22Ω, medidas con el tester comun marca 1Ω. Igualmente lo deje en un valor bajo por precaucion.
Espere un tiempo a ver si todo seguia marchando bien y si, todo ok.

2do, lo probe con un parlante de pruebas (<3U$S), al seguir funcionando correctamente, probe con uno de mas calidad a ver que tal el sonido. Poco y nada de ruido escuche.

Asi que en ambas pruebas dio satisfactorio. NO a mucho volumen si y no lo he podido verficar aun con un osciloscopio.
En un tiempo que tenga mido las tensiones y las subo.
Tené cuidado con una cosa....

Si vos estas haciendo mediciones con el sistema en lazo cerrado, no esperes ver el mismo comportamiento que con cada etapa individual del amplificador operando en lazo abierto (sin realimentación global).
El tema es simple: si vos ponés la entrada a masa, la NFB va a ajustar la operacion del amplificador para que la salida se vaya a masa, así que los estados internos de cada etapa (VAS y compañía) pueden parecer incorrectos...aún cuando no lo sean y la NFB logre lo que está buscando.

Te comento esto por que por ahí dijiste que parecía que el VAS estaba al corte ya que tenía la Vce parecida a la Vcc, pero sin embargo el amplificador andaba bien (pero no cazé de cual amplificador hablabas), y esto puede ser a causa de lo que dije antes. Pueden haber otros motivos, pero las mediciones en lazo cerrado siempre son complicadas de leer...

Acá encontré algo sobre la lecturas de tensión en amplificador. Es para encontrar fallas, pero el sirve igual:
http://sound.westhost.com/troubleshooting.htm#volts

Saludos!
24/06/2009 #26

Avatar de juanma

Buenas, he tenido un tiempo como para hacer unas pruebas, lleva mucho tiempo la facu y una vida social decente 8-)
Hice pruebas a oido, y suena mucho mejor que el SiliconChip que arme. Mucho mas detalle en los agudos.

El ultimo prototipo del cual obtuve las medidas, es con la etapa de entrada en modo cascode con espejo de corriente.
Es una tecnica muy interesante el cascode. Hay un excelente paper en la pagina de Fist Watt, de Nelson Pass.
Los componentes para implementarlo son nada, de los mas comunes, con grandes beneficios. Decidi utilizarlo (es mas, estoy considerando la etapa de salida en cascode cuando disponga de mas tiempo).

La maxima excursion de salida esta "limitada" por el cascode del VAS, como no lo probe a maxima excursion, no fue necesario tener en cuenta ese detalle para estas primeras mediciones.
A la hora de armarlo y ajustarlo definitivamente, es necesario tenerlo en cuenta.

Dejo las mediciones, sobre una carga de 10Ω. No pude probar con una entrada mayor, ya que el generador no funcionaba correctamente para esa amplitud.

Señal senoidal 20kHz

Espectro de la señal de entrada a 20kHz

Espectro de salida 20k

Señal cuadrada 20kHz

Señal senoidal 50kHz

Señal cuadrada 50kHz

Espectros de entrada/salida 100kHz



Esquema del circuito, cambie a Spice como simulador.


No disponia de mas tiempo, pero la idea era compararlo con el de SiliconChip de 20W.
Agradezco a arields1, por el cambio de opiniones e ideas en este tiempo, y a todos lo que hayan opinado.
Es una excelente manera de ampliar el panorama sobre las tantas opciones que hay en el diseño de un ampificador.

Cualquier opinion/sugerencia, es bienvenida
Saludos

PD: no subo fotos del protoboar porque es un verdadero caos
25/06/2009 #27

Avatar de Dr. Zoidberg

Veo algo raro en esas fotos...
La FFT de la señal de entrada tiene una parva de componentes espectrales y pinta como si fuera ruido del generador. Sin embargo, la salida está "limpia" y solo aparece el "pelo" de la señal de prueba. A menos que estes haciendo algun preprocesamiento de la señal de salida antes de la FFT, ese amplificador parece un excelente filtro con ganancia

A que se debe?

Saludos!
25/06/2009 #28

Avatar de juanma

Eso lo note ya, tambien se ven en las fotos de las señanes de prueba. La entrada no se ve tan limpia como la salida.
Las señales tienen a la izquierda un numero, el cual es el canal.

Las puntas del osciloscopio pueden ser, la que media la entrada no tenia tierra, usaba la tierra del canal 2 (salida).
Sin contar que las puntas no so nuevas, y tienen un uso intensivo, por asi decirlo
Tengo las fotos en 4mpx, ahi si ve claro que la entrada "esta" con ruido, pero la salida no. Descartando que sea un filtro lo que arme, queda que el channel2 no haya tenido tierra.

Adjunto un zoom, ahi se ve mejor.

En la FFT no busque que tipo de ventaneo es mejor o mas efectivo para este tipo de mediciones. Un ventaneo rectangular no era tan claro como Hanning

Saludos
Imágenes Adjuntas
Tipo de Archivo: jpg zoom_170.jpg (56,2 KB (Kilobytes), 13 visitas)
25/06/2009 #29

Avatar de Dr. Zoidberg

OK. Si podés hacer las pruebas de nuevo, pero en mejores condiciones, dale otra vez. Tengo en mente que veas si se aprecian las componentes espectrales derivadas de la distorsión, que deberían ser muy pequeñas si la THD del amplificador es baja.

Saludos!
30/07/2009 #30

Avatar de juanma

DIY Progress Report!

Con todo esto del gran receso de la gripe A, pude terminar con una placa del amplificador.
Ocupa 7x10cm, hecha a lapiz y papel. Creo que con un buen programa para diseño, puede entrar en 5x10cm.
En resumen, como comentario del sonido, por demas excelente agudos.

Queda por incursionar en single-ended, pero mas adelante.






Saludos, y para nada doy por terminado el proyecto
Juanma
30/07/2009 #31
Moderador

Avatar de hazard_1998

juanma dijo:
DIY Progress Report!

Con todo esto del gran receso de la gripe A, pude terminar con una placa del amplificador.
Ocupa 7x10cm, hecha a lapiz y papel. Creo que con un buen programa para diseño, puede entrar en 5x10cm.
En resumen, como comentario del sonido, por demas excelente agudos.

Queda por incursionar en single-ended, pero mas adelante.






Saludos, y para nada doy por terminado el proyecto
Juanma
muy interesante el diseño, y muy prolijo el circuito impreso, me hace acordar a mis primeros diseños de impresos.... o armados en placas experimentales de paso 5mm..... lo que si noto es que no se corresponde en algunos puntos con el esquema que esta en esta pagina...por ej, las resistencias de 0.22 en el esquema aparecen contra salida a parlantelo cual seria correcto, pero en el impreso estan contra las barras de DC... otra consulta, cual es el sentido (y como lo haz determinado) el capacitor miller dividido en los driver cascodo?colocando esa R contra la barra, no se anula el efecto miller?
30/07/2009 #32

Avatar de juanma

Es verdad, no es actualizado, tanto la foto como el esquema, error mio.

La etapa de ganancia de voltaje esta limitada en cuanto a excursion por el cascode, por lo que la etapa de salida tiene ganancia, lo que permite (en simulacion) una excursion maxima de 18.5Vpp, mientras que sin el arreglo, la maxima excursion de salida esta limitada aproximadamente por la tension Zener del Cascode (9V1).

En la foto falta la la inductancia con la R en paralelo, que no utilice en la simulacion.

Sobre la compensacion, tome los valores del libro de Randy o Self, no recuerdo exactamente cual.
Tengo un pdf que entra en el tema del calculo, pero por demas complicado, asi que utilice algo ya hecho.
Douglas se explaya sobre el tema, explica como varia la red con la frecuencia, y coloca un grafico del comportamiento a lazo abierto, el polo en vez de estar en 100Hz, se desplaza a 10kHz con -40dB/dec, y luego tiende a -20dB/dec del polo original en 100Hz.
Calculo que esto tambien se podria ver en MATLAB con sisotool, pero no lo he probado.

Pero por lo que conclui (puede estar mal), podes tener un mayor ancho de banda si tu ganancia a lazo abierto no es grande y no realimentas en gran medida, igualmente Douglas menciona de una reduccion en la distorsion con esta tecnica.
Ahora, no tengo determinada la ganancia a lazo abierto del amplificador.
Al ser simetrico, la Rc de la etapa VAS, que en parte determina la ganancia a lazo abierto, es justamente el complemento, pero no se si puedo decir si es tan alta como la impedancia de una fuente de corriente o mayor...
Ambas etapas de entrada tienen una ganancia grande ya que usan cargas activas (espejos de corriente).

Con un metodo para estimar la ganancia a lazo abierto, seguramente van a estar mas claros varios aspectos del amplificador (del cual varios simetricos por la web).

En estos dias, me enganche bastante con el tema del zero feedback, o un factor bajo. Mas que nada leyendo sobre el Zen de Nelson Pass, el US2 de Pablo, DoZ de Elliot y varios esquemas mas, junto con papers de Pass.
Es todo un tema y por demas controvertido, mas en algo tan subjetivo y personal como el audio, pero el prox proyecto seguramente es algo con poca realimentacion (tambien queda ver el tema de los armonicos generados: single-ended o push-pull), asi lo comparo con este amplificador.
Este amplificador tiene una ganancia de 21veces o 26dB, por lo que con una gran ganancia a lazo abierto, la realimentacion es considerable.
Pero es cuestion de armar y ver (escuchar) los diferentes sonidos.

Temas como compensacion en frecuencia, realimentacion, etc, son temas que termine de ver hace relativamente poco en la facultad (Sistemas de Control), con lo cual estoy en la relectura obligada de algunos capitulos de Douglas y Randy y varios sitios webs, y llegar a "actualizar" este amplificador, cosa que me he cansado de ver. NINGUN es version 1, todos los amplificador DIYs sufren actualizaciones, a medida que uno adquiere mas conocimiento y practica.

A nivel escucha, mas que aprobado, pero queda totalmente abierto a mejoras, que es lo que espero seguir haciendo.

Saludos!

PD: circuito impreso? nada de eso, todo con el clasico marcador Eddding 8-) y buen pulso.
Imágenes Adjuntas
Tipo de Archivo: gif esquema_actualizado_177.gif (20,3 KB (Kilobytes), 78 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Audio: Discusión General

Cerrar
Foros de Electrónica » Sistemas de Audio » Audio: Discusión General

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.