Haz una pregunta
  Foros de Electrónica » Compartiendo con la comunidad » Sala de Charla
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

06/07/2012 #21

Avatar de el-rey-julien

y si usas el nano para editar?
06/07/2012 #22

Avatar de Nepper

para editar que? ya lo he utilizado para editar el grub y no a funcionado...
06/07/2012 #23

Avatar de el-rey-julien

y como es que para editar yo siempre uso el nano y ningún problema?
eso si tienes que abrirlo como rot ,sino no te guarda los cambios
06/07/2012 #24
Moderador

Avatar de Nilfred

OK, te anda el metacity, pero el con-pis se te clava mal, si no tenes compiz entonces no tenes barra de unity, ergo no podes lanzar nada. Un triste fondo de escritorio.
Me olvidé decirte que el lanzador que instalaste, tenes que ejecutarlo, pero bueno, veamos que se ejecute al inicio:
Código PHP:
# Vemos donde está cada cosa que tenes instalada
ls /usr/share/applications/
# Vemos donde está cada cosa que se autoejecuta:
ls ~/.config/autostart
# La única línea que vale es esta:
cp -/usr/share/applications/avant-window-navigator.desktop ~/.config/autostart 
Era mas fácil ejecutarlo y configurar que se ejecute al inicio, dirán, pero la verdad no se si se banca el argumento --display :0.0

Ahh, la línea que te anduvo, cambiala por esta:
Código PHP:
metacity --composite --replace --display :0.0 
Bueno, ahora al reiniciar ya deberías tener una barra configurable, desde donde lanzar las aplicaciones.
Por lo menos tenes un entorno gráfico desde donde solucionar el tema de compiz.

Si no se soluciona, fijate como hacer para arrancar con otro "DE", por ejemplo "Unity-2D" que no usa compiz, Cinnamon, Mate y otros...
06/07/2012 #25
Moderador

Avatar de Nilfred

Nepper dijo: Ver Mensaje
Código:
metacity --replace --display :0.0 & 
# Eso tendría que mostrarte algo en Ctrl+Alt+f7
Sos una masa! Tal cual! me muestra la cosa de la contraseña!!
puse la contraseña y se me volvió a morir... vuelvo a la consola 1...

me di cuenta que me aparece el escritorio, cambio las areas de trabajo pero no me aparece nada mas que el mouse

bueno... el gconf me tira error...

pero el maus me anda...
Si tenes el mouse, estas en modo gráfico, Alt-Ctrl-T te abre una consola en modo gráfico.
Si estas en TTY1 no podes abrir ningún programa gráfico, salvo que le digas donde abrirse: gconf-editor --display :0.0
Igual tira error...
Lástima que no puedo abrir el gnome-terminal desde TTY1: gnome-terminal --display=:0.0
No se que pretende que le ponga
06/07/2012 #26

Avatar de Nepper

Nilfred dijo: Ver Mensaje
Si tenes el mouse, estas en modo gráfico, Alt-Ctrl-T te abre una consola en modo gráfico.
Si estas en TTY1 no podes abrir ningún programa gráfico, salvo que le digas donde abrirse: gconf-editor --display :0.0
Igual tira error...
Lástima que no puedo abrir el gnome-terminal desde TTY1: gnome-terminal --display=:0.0
No se que pretende que le ponga

HHHAAAA!!!! no mis disculpas... me perdí en tu tutorial porque no había presionado crtl+alt+T, con tu último post me di cuenta de ello. Comencé a intercambiar entre el compiz y el metacity y me di cuenta de las diferencias, si el metacity anda pero el compiz no, cuando lo pasé a compiz se me fueron las barras de "titulo" de las ventanas...

HAAAA!!! QUE MASA!!!
ya con el metacity, le mandé al avant-window-navigator... en la consola gráfica lo "reinstalo" pero me dice que ya está (porque lo instalé con la consola F1). Entonces ¿como lo ejecuto??? pues... supongo... poniendo el nombre del programa... avant-window-navigator
Es la barrita de abajo y me marca todo lo que abrí!!! sarpado...

entonces, ahora tengo que empezar a llenar el escritorio con boludeces? (el reloj, alguno que otro software, etc)

despues veo como hacer que se me haga todo en el inicio... gracias por todo, me dieron muy buen soporte y ni siquiera lo pedí... gracias gente!!!

---------- Actualizado después de 8 minutos ----------

No!! muy bueno... estaré horas configurando esto... se agradece!!!
06/07/2012 #27

Avatar de el-rey-julien

bien ¡¡¡¡ muy bien por nilfred ,no sabia que el sabia algo del tema ¡¡¡ le preste atencion y no intervine para luego poder decir
¡¡viva chaco no hay corriente¡¡ pero devo reconocer y le doy mis respetos a un user linux y se nota de años ¡¡¡
mis respetos nilfred ,viva chaco y corrientes ¡¡ y el gnu
07/07/2012 #28
Moderador

Avatar de Nilfred

Gracias SM.

Pensé que no andaba Alt-Ctrl-T, por eso seguí con las instrucciones desde TTY1.
Ahora que tenes AWN, agregale el menú "Aún otra Miniaplicación de Menú" y el flor de reloz "Reloj Digital". Tildar "Iniciar AWN automáticamente", etc.
Si definitivamente no va a andar compiz vas a necesitar "Área de notificación".

Ahora para arreglar compiz ejecutá: ccsm

Antes de meter mano buscá el "Crash handler" en la categoría "Utilidades"
Asegurate que esté habilitado y diga "metacity --composite --replace" tal como configuramos desde TTY.
Ese es tu salvavidas en caso que hagas un click de mas...
En posts anteriores ya te explique como resetearlo si haces demasiados clicks de mas y deseas comenzar desde 0 otra vez.

En la categoría "Escritorio" está "Ubuntu Unity Plugin". Trata de mantener ese habilitado.
compiz --replace para ver si anda tu configuración.
07/07/2012 #29

Avatar de el-rey-julien

ese compiz no lo puede hacer funcionar nunca ,pero porque tengo maquina vieja,,,,,,,,con escasos recursos ,
aun cuando funciona mi super pc de 1,8ghz ¡¡ no tenia acelerador grafico,como siempre su majestad amarrete
no piensa comprar una pc de ultima generacion,
por dos motivos
1= se aprenden mas con una pc vieja
2=la lemur quiere un lcd y si compro una pc nueva me va a inflar las tarlipes a mas no poder
ergo= no gasto un peso ¡¡
07/07/2012 #30
Moderador

Avatar de Nilfred

Nepper dijo: Ver Mensaje
cuando lo pasé a compiz se me fueron las barras de "titulo" de las ventanas...
Eso ya es un avance, solo te faltan las decoraciones de ventana, configurable...
Asegurate que compiz se está ejecutando:
Código PHP:
ps x grep [d]ecorator
# /bin/sh -c /usr/bin/compiz-decorator
# /usr/bin/gtk-window-decorator 
Ahora metele mano a ccsm hasta que con el último click se deje de ejecutar
Anda tomando nota de donde NO tenes que hacer click

¿Instalaste el driver de video propietario? ¿nVidia dijiste que tenias?
Preferencias - Controladores adicionales
07/07/2012 #31

Avatar de Nepper

Jua jua!!
cuando reinicié se me quedaba con la pantalla violeta!!
pero bueno.. volví a reiniciar y me mandó al grub de una... de caradura nada mas le saqué el parametro acpi_oci=linux al nomodeset.... a ver que pasaba...
inicié y negro tambien... pero ahora el mouse se me puso como cursor mucho mas rápido de lo que lo hacía antes. o sea, antes me tardaba como 5 min en ponerme la selección de usuario (me daba cuenta por el maus, pero siempre se ve todo negro)

bueno, se me inicio la seción pero con compiz (funcionando mal), paso a la consola F1, para mi sorpresa se me pone negra la pantalla cuando paso a la consola... ¬_¬, bueno, le mandé el usuario, contraseña y metacity a ciegas y anduvo XD. cuando volví todo tenía lo que tenía que tener pero el fondo me parpadeó como un led con un 555 a alta frecuencia...
ya me puse a descargar las actualizaciones.

No puedo encontrar el panel de configuración del compiz... ¿se tenía que instala a parte no?
tampoco puedo encontrar el crashhandler así que le mando mano...

hago lo que decís:
Código:
ps x | grep [d]ecorator
JUA JUA!!! activé el compiz y se me salió todo de la pantalla XD... al minuto volvió a aparecer todo pero sin barras XD
HUUU!!! volví a F1 y apreté Arriba para repetir el comando metacty y no me lo agarró... (porque no veo nada), agarré y inicie el F2, lo mismo, usuario y contraseña y comando y no me anduvo!! bueno... F3, usuario, contraseña, y mando el comando de memoria.... Anduvo! metacity otra vez.. aguanto a que se acutualize el ubuntu... puse el gestor de actualizaciones...
veo si le puedo actualizar la placa...
07/07/2012 #32
Moderador

Avatar de Nilfred

Nepper dijo: Ver Mensaje
1- cuando volví todo tenía lo que tenía que tener pero el fondo me parpadeó como un led con un 555 a alta frecuencia...

2- activé el compiz y se me salió todo de la pantalla XD... al minuto volvió a aparecer todo pero sin barras XD
1- ¿Frecuencia de actualización de pantalla demasiado alta? ¿Tamaño de pantalla no estandardizado?

2- Lo que pasa exactamente es esta secuencia:
run Compiz -> Crash -> Crash handler -> run Metacity
No hace falta reiniciar, a menos que cambies algo en el grub: Cerrá sesión y volvé a abrir.

---------- Actualizado después de 9 minutos ----------

Parecería ser que el crash-handler no está funcionando. Fijate la salida del siguiente comando:
Código PHP:
gconftool --all-entries /apps/compiz-1/plugins/crashhandler/screen0/options
# directory = /tmp
# start_wm = true
# wm_cmd = metacity --composite --replace
# enabled = true 
Si no es así, repetimos:
Código PHP:
gconftool --set /apps/compiz-1/plugins/crashhandler/screen0/options/wm_cmd --type string "metacity --composite --replace"
gconftool --set /apps/compiz-1/plugins/crashhandler/screen0/options/start_wm --type boolean true
gconftool 
--set /apps/compiz-1/plugins/crashhandler/screen0/options/enabled --type boolean true 
Tambien puede que el compiz esté usando archivo de texto para configurarse en vez de gconf
07/07/2012 #33

Avatar de Nepper

claro, ya te entiendo... si puse y me salió
Código:
gconftool --all-entries /apps/compiz-1/plugins/crashhandler/screen0/options 
# start_wm = true 
# wm_cmd = metacity --composite --replace 
# enabled = true
tal cual...
lo que hise ahora, fue dejarla todo el día actualizando, reinicié y me arrancó, lento pero me arrancó de una en el escritorio... con compiz, se veía todo mal (sin marco de ventanas y el AWM medio plano) pero arrancaba y ya se veía... con la consola F1 lo pasé a metacity y arranco lo mas bien...

Me instale el gestor gráfico del compiz, voy a ver si encuentro algo para arreglarlo...

---------- Actualizado después de 36 minutos ----------

no, el compiz no me anda, recién intercambié entre ambos y no va...
08/07/2012 #34


nepper, tengo entendido que estás instalando el linux en una portátil.

Te sugiero revises con google algo así: "instalar (distro de linux) en (marca de portátil).

Algunas veces hay mucho detalles relacionados que estorban.
08/07/2012 #35

Avatar de Nepper

mcrven dijo: Ver Mensaje
nepper, tengo entendido que estás instalando el linux en una portátil.

Te sugiero revises con google algo así: "instalar (distro de linux) en (marca de portátil).

Algunas veces hay mucho detalles relacionados que estorban.
aunque no me creas, me dio mucho mas resultado poner "pantalla negra despues de instalar" que "problemas acer aspire con ubuntu 12"
yo pienso que el ubuntu funciona "genericamente" y te agarra todos los drivers de maravilla (aunque yo vea lo contrario), digo ¿como es que el metacity funciona y el compiz no? no es problema de drivers, si no no se vería ni el mouse.
Además, tenía instalado ubuntu 10 y andaba fenomenal, formatíe para limpiar la PC y cambiar al 12... ¿por que debería haber problemas si me andaba perfecto?
hoy no tuve tiempo, pero despues mando el metacity al inicio y listo, me arreglo ahí...
09/07/2012 #36

Avatar de Nepper

Nilfred dijo: Ver Mensaje
Gracias SM.

Pensé que no andaba Alt-Ctrl-T, por eso seguí con las instrucciones desde TTY1.
Ahora que tenes AWN, agregale el menú "Aún otra Miniaplicación de Menú" y el flor de reloz "Reloj Digital". Tildar "Iniciar AWN automáticamente", etc.
Si definitivamente no va a andar compiz vas a necesitar "Área de notificación".

Ahora para arreglar compiz ejecutá: ccsm

Antes de meter mano buscá el "Crash handler" en la categoría "Utilidades"
Asegurate que esté habilitado y diga "metacity --composite --replace" tal como configuramos desde TTY.
Ese es tu salvavidas en caso que hagas un click de mas...
En posts anteriores ya te explique como resetearlo si haces demasiados clicks de mas y deseas comenzar desde 0 otra vez.

En la categoría "Escritorio" está "Ubuntu Unity Plugin". Trata de mantener ese habilitado.
compiz --replace para ver si anda tu configuración.
te ruego que me disculpes, ahora me doy cuenta de lo que mencionaste aca... El CCSM me lo tuve que instalar aparte (por suerte lo aprendí del ubuntu 9).
El Crashhandler no me aparece, el unity plugin no estaba habilitado, ahora lo habilite. todavía estoy con metacity, voy a pasar a compiz...

no... me sigue sin andar el compiz, se me van todos los recuadros de las ventanas....

---------- Actualizado después de 2 minutos ----------

me tiró el siguiente error cuando pasé al compiz
Código:
Usuario@Maquina:~$ compiz --replace &
[1] 6147
Usuario@Maquina:~$ Backend     : ini
Integration : true
Profile     : default
Adding plugins
Initializing core options...done
Initializing composite options...done
Initializing opengl options...done
compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing scale options...done

(compiz:6147): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key (dirname, NULL)' failed
WARN  2012-07-09 11:22:44 unity.favorites FavoriteStoreGSettings.cpp:139 Unable to load GDesktopAppInfo for 'ubiquity-gtkui.desktop'
Initializing unityshell options...done
compiz (core) - Warn: failed to receive ConfigureNotify event on 0x3c00590

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x3c0059e

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x4200003

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x4200004

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x4200006

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x4200007

compiz (core) - Warn: failed to receive ConfigureNotify event on 0x4200008

compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000d0!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000d4!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000d8!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000d8!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000d8!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000db!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000db!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000db!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000df!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000df!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000df!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000e2!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000e2!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000e2!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000e5!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
WARN  2012-07-09 11:22:53 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/firefox.desktop' is using a deprecated format for its actions that will be dropped soon.
WARN  2012-07-09 11:22:53 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/libreoffice-writer.desktop' is using a deprecated format for its actions that will be dropped soon.
WARN  2012-07-09 11:22:53 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/libreoffice-calc.desktop' is using a deprecated format for its actions that will be dropped soon.
WARN  2012-07-09 11:22:53 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/libreoffice-impress.desktop' is using a deprecated format for its actions that will be dropped soon.
compiz (core) - Warn: failed to receive ConfigureNotify event on 0x4200008

compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000e5!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.
compiz (core) - Warn: unhandled ConfigureNotify on 0x1c000e5!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.

[1]+  Violación de segmento  (`core' generado) compiz --replace
09/07/2012 #37
Moderador

Avatar de Nilfred

Nepper dijo: Ver Mensaje
Backend : ini
[1]+ Violación de segmento (`core' generado) compiz --replace
Tenes el compiz configurado para leer la configuración desde un archivo .ini; por eso no arrancaba el metacity solo.
ccsm -> Preferencias -> Backend -> Gconf
ccsm -> Preferencias -> Perfil -> unity
ccsm -> Categoría -> Utilidades -> Crash handler -> ...
ccsm -> Categoría -> General -> Copy to texture -> Deshabilitar

A todo esto ¿Que placa de video tenes? ¿Seguro que soporta compiz?
09/07/2012 #38

Avatar de Nepper

Nilfred dijo: Ver Mensaje
Tenes el compiz configurado para leer la configuración desde un archivo .ini; por eso no arrancaba el metacity solo.
ccsm -> Preferencias -> Backend -> Gconf
Hem... si lo cambie mientras tocaba todo
ccsm -> Preferencias -> Perfil -> unity
Ese ni idea si lo toque
ccsm -> Categoría -> Utilidades -> Crash handler -> ...
si... no me aparece...
ccsm -> Categoría -> General -> Copy to texture -> Deshabilitar
Está deshabilitado

A todo esto ¿Que placa de video tenes? ¿Seguro que soporta compiz?
bueno, eso es lo raro, porque yo ya tenía el ubuntu 9 y despues lo actualicé al 10, por eso me parece raro que no ande, porque ya usaba ubuntu y el compiz...
bueno... pasé al compiz y sigue... estoy viendo actualizar la placa, se comenta que hay problema con los drivers en general...
09/07/2012 #39
Moderador

Avatar de Chico3001

Hablando de Ubuntu 12.04... a cada rato me sale un crash del colord... ni idea que es eso y se ve que los encargados de reparlo desaparecieron de la faz de la tierra.. asi que no hay para cuando...

Sabran de algun manejador equivalente que pueda instalar? o sera mejor de plano cambiarme a mint 13?
09/07/2012 #40

Avatar de el-rey-julien

cambiate a debian ,asta donde lo use no me dio problemas http://www.debian.org/index.es.html,
de momento estoy usando lenny ,,,pero el squeeze,una maza funciona muy bien
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Sala de Charla

Comparte charlas y momentos. No todo es Electrónica en la vida ;)

Cerrar
Foros de Electrónica » Compartiendo con la comunidad » Sala de Charla

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.