Haz una pregunta
  Foros de Electrónica » Compartiendo con la comunidad » Sala de Charla
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

20/08/2016 #141


Le doy las mas cordiales gracias a su Majestad
La orientacion me ha servido, aunque no al pie de la letra, he tenido que cambiar un par de lineas, pero esto de copiar y pegar es una maravilla
Ahora no tengo que estar atento a la pantalla al arrancar el ordenador esperando que salga el menu de inicio, esto me deja margen para limpiar el escritorio y asi tengo contenta a la Maria
De nuevo muy agradecido
01/09/2016 #142

Avatar de el-rey-julien

me pase a arch linux
al instalar opera con el comando
pacman -S opera
se instala la versión nueva,para instalar la versión vieja la 12,16 se usa este comando
yaourt -S opera-legacy
luego de descargar/compilar crea una carpeta llamada .opera-legacy
para recuperar los marcadores y paginas guardas que tenia el viejo opera de debian
hay que borrar esa carpeta oculta .opera-legacy
y renombrar la carpeta .opera a .opera-legacy
con eso volví a tener el viejo opera en archlinux
bastante fácil
ahora me queda compilar un kernel al estilo arch ,
espero no sea muy diferente que en debian
01/09/2016 #143

Avatar de Nepper

Para los que tienen dudas qué Distribución elegir.

https://upload.wikimedia.org/wikiped...n_Timeline.svg

Ahora tendrán MAS dudas...
01/09/2016 #144

Avatar de el-rey-julien

yo comense con mandrake,esta en la linea de red hat
falta algunas en la lista,no encontre huarya, por ejemplo,que deberia estar en la rama debian
tampoco encontre a galpon-ninimo

---------- Actualizado después de 6 minutos ----------

haa ya lo encontre,si figura galpom minino
esta canaima,pero no esta huarya y canaima esta en la rama equivocada
deberia estar en la rama debian/ubuntu
06/09/2016 #145


Perdonad de nuevo la intromisión de un pobre ignorante, al cual la fortuna le lleva por despeñaperros (lugares muy dificultosos)
Hace unos días os pedí orientación, en el post #136 de este tema, de como resolver el problema del Grub en Ubuntu
Gracias al desinterés de su Majestad pude resolver este percance
Sin embargo, la curiosidad mata al hombre, dado el consejo de Su Majestad instale Debian, y la verdad en que el ventilador de la CPU no me molesta pues con Ubuntu parecía un reactor y con Debian se comporta como Yo, tranquilo pero sin pausa
Al grano, con Ubuntu consigo instalar el MPLAB, que ya viene en los "repositorios", perdonad pero soy demasiado nuevo en estos lugares, sin embargo con Debian no consigo encontrar en Synaptyc el programa, lo descargo de microchip, genera un archivo en ".sh", pero luego se queda mas colgado que Yo
He leído que puede ser por la arquitectura, que el programa sea en 32bit y el SO es de 64bit
En los paquetes de Sinaptyc encontré la librería "libc6-i386", supongo que para los programas de 32bit puedan "correr" en 64bit
Estoy buscando Ya hace algún tiempo información del suceso, pero mi experiencia en el mundo de la informática es tan débil que ya no me acuerdo ni del MSDOS
Su Majestad dado su consejo y tras haberme cargado, en tantos intentos, la estructura de Debian así como de Ubuntu( el que no toca una cosa No la rompe, eso me enseño hace muchos años un profesor de robotica) instale Debian Mate pero me perdía muchísimo y estoy con Debian "normal"
Os pido, con tanta verborrea ¿verdad?, una orientación de en donde Me he perdido para poder instalar MPLAB
De antemano muchas gracias

Estuve con el buscador, en relación al tema y me salio este enlace Instalar MPLAB en Linux, pero no me resolvió el problema
06/09/2016 #146

Avatar de Nepper

haa!! se podía instalar en debian?... changos!! no la tenía esa....

aguanta que me lo pongo a instalar y te digo que problemas encontré...

Pero por el momento te puedo decir que los programas para instalar en debian suelen terminar en ".deb".
Eso del SH no se que es, y me parece que está mal.
06/09/2016 #147


Nepper dijo: Ver Mensaje
haa!! se podía instalar en debian?... changos!! no la tenía esa....

aguanta que me lo pongo a instalar y te digo que problemas encontré...

Pero por el momento te puedo decir que los programas para instalar en debian suelen terminar en ".deb".
Eso del SH no se que es, y me parece que está mal.
*.sh es el sufijo de archivos ejecutables desde el shell de la consola. Ej.: hplip_clean.sh; install.sh y otros.

Desde la consola se activa con >sh install.sh

El archivo debe ser declarado como ejecutable previamente.
06/09/2016 #148


Efectivamente mcrven
Le doy permiso de ejecutable, clic dos veces, se abre con gedit, sale una barra y debajo mucho texto
Quedandose mas colgado que Yo
Voy a la consola y con sudo me dice que no esta el comando
Con apt tambien
06/09/2016 #149

Avatar de Nepper

Para empezar, te conviene usar uname -a para ver que arquitectura tenes
Código:
uname -a
http://jugandoconsl.blogspot.com.ar/...-linux-es.html

Ya me lo descargué, y descomprimí el .tar

si, estaban en lo correcto, ahora viene la parte del .sh

http://microchip.wikidot.com/install:mplabx

Código:
root@movil:/home/nepper/Descargas# tar -xvf MPLABX-v3.40-linux-installer.tar
MPLABX-v3.40-linux-installer.sh
root@movil:/home/nepper/Descargas# chmod u+x MPLABX-v3.40-linux-installer.sh
root@movil:/home/nepper/Descargas# ./MPLABX-v3.40-linux-installer.sh
32 Bit, start installer
Verifying archive integrity... All good.
Uncompressing MPLAB X v3.40 Installer....
y se me abrió una ventanita..
Y la verdad que se me está instalando bastante bien...

Fijate que la pagina de microchip dice:

If you have problems running the graphical installer, you can run the installer in text mode instead by specifying "text" as the mode parameter value (where 2.XX is the installer version):
sudo ./MPLABX-vX.XX-linux-installer.sh --mode text

en mi caso, la primera anduvo joya...
Sep... sin problemas...

no recomiendo que uses el synaptic para debian, es como dice el rey, tenes que usar el apt o el aptitude. o el apt-get
lamentablemente, es engorroso.

trata de pasarnos el log de lo que pasa en la consola.

---------- Actualizado después de 6 minutos ----------

fijate de usar el comando cd para llevar la "ruta" a donde está la descarga. Esto es lo que hice antes de empezar la instalación:
Código:
nepper@movil:~$ su
Contraseña: 
root@movil:/home/nepper# uname -a
Linux movil 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt20-1+deb8u4 (2016-02-29) i686 GNU/Linux
root@movil:/home/nepper# cd /home/nepper/Descargas/
root@movil:/home/nepper/Descargas#
06/09/2016 #150


Muchas gracias por el interés
Le estoy dando muchas vueltas a San gogle
Ya mire la arquitectura, y es de 64 bit
He intentado instalar las librerias para el apaño en 32 bit
Pero solo encuentro libc6-i386
No se si falta alguna mas
El comando sudo no lo reconoce y el apt ni idea
Después de trabajar mirare con todo detalle lo que me has comentado
Procurare subir una imagen de la pantalla, pero con lo inepto que soy no se....
Gracias

He efectuado los pasos que me has mencionado
Aquí el primero
captura uname.png

Después el comando para instalar
Captura de pantalla 2.png

Me dice que faltan librerías, voy a al dirección de microchip y no consigo encontrarlas
Imágenes Adjuntas
Tipo de Archivo: png captura uname.png (20,0 KB (Kilobytes), 8 visitas)
Tipo de Archivo: png Captura de pantalla 2.png (55,7 KB (Kilobytes), 7 visitas)
07/09/2016 #151


De nuevo muchísimas gracias Nepper y al resto de compañeros del foro
Ya he solucionado el dichoso engorro en el que por ignorante me había metido
Me he descargado Debian con arquitectura de 32bit, e seguido tus pasos, que muy certeramente, me habías sugerido y mi sorpresa es que tengo otra obligación más, que es la de programar artefactos con Mplab
Muchas Gracias
07/09/2016 #152

Avatar de Ardogan

juan47 dijo: Ver Mensaje
...
Me dice que faltan librerías, voy a al dirección de microchip y no consigo encontrarlas
Ahí en la última imagen hay un enlace a
http://microchip.wikidot.com/install:mplabx-lin64

Ahí te dice los nombres de los paquetes:
ia32libs -> este ya no corre más, ahora en su lugar se usa lib32ncurses5 (me pasó al instalar otros programas)
Y luego todo el resto... y si no tenés instalado el paquete de soporte multiarch, también (esto permite correr programas de 32 bits en arquitecturas de 64 bits):

Entonces, paso a paso, abrís ventanita de terminal y tecleas (va todo con sudo, te va a pedir el password de root para el primer comando, quizás para el resto no):

Código:
sudo apt-get install multiarch-support
Por las dudas hacemos:
Código:
sudo apt-get update
Seguimos:
Código:
sudo apt-get install lib32ncurses5 libc6:i386 libx11-6:i386 libxext6:i386 libstdc++6:i386 libexpat1:i386
Y con eso creo que ya tendrías instaladas las dependencias, luego seguí los pasos de instalación del mplab ide y a ver que pasa.

Si tenés un error, copialo (el texto no la imagen), buscalo en internet a ver si la solución es una nimiedad, y sino responde poniendo lo que dice la consola y lo vemos.
07/09/2016 #153


Gracias Ardogan
Como he comentado en el post #151 he cargado debian en 32bit
Las librerías las he buscado todas en sinaptyc y solamente encontré "lib32zz1" , pero al validarlas me decía que el resto de archivos que hacían falta no se podian descargar, no recuerdo el porque, al principio las apuntaba en un papel(consejo de el-rey-julien) pero al final las copie y pegue en word dando un resultado de tres folios
De todos modos, esto me recuerda cuando empecé a trastear con windos 95 que lo desarmaba y volvia a cargar hasta tres veces al dia, mañana cargare denuevo debian 64 y seguire los consejos que me has dado
Apartir de hay comentare lo sucedido
Gracias
07/09/2016 #154

Avatar de Ardogan

juan47 dijo: Ver Mensaje
Gracias Ardogan
Como he comentado en el post #151 he cargado debian en 32bit
Las librerías las he buscado todas en sinaptyc y solamente encontré "lib32zz1" , pero al validarlas me decía que el resto de archivos que hacían falta no se podian descargar, no recuerdo el porque, al principio las apuntaba en un papel(consejo de el-rey-julien) pero al final las copie y pegue en word dando un resultado de tres folios
De todos modos, esto me recuerda cuando empecé a trastear con windos 95 que lo desarmaba y volvia a cargar hasta tres veces al dia, mañana cargare denuevo debian 64 y seguire los consejos que me has dado
Apartir de hay comentare lo sucedido
Gracias
Ah!!!, no había leído eso. Naaa dejá, si funciona ya está, no vayas a hacer cambios solamente para ver si funciona. Pero si por algún otro motivo probás de vuelta no dejes de comentar .
Suerte!!!
07/09/2016 #155

Avatar de el-rey-julien

haa llegue tarde ,pero lo si funciona,como dijeron peirmero hay que instalar el soporte de 32 bit y ya
el resto es facil,yo e instalado sin problemas el mplab sin problemas
aqui una guia
https://cristopherav.wordpress.com/2...debian-wheezy/
Si tu PC es de 64 bits puede darte problemas el instalar para iniciar, eso lo solucionas instalando las librerias de compatibilidad para 32 bits

sudo apt-get install libc6:i386 libx11-6:i386 libxext6:i386 libstdc++6:i386 libexpat1:i386
antes de siquiera intentar instalar las librerías
hay que poner esto en consola de root
dpkg --add-architecture i386
apt-get update


yo sigo usando en arch

Código:
tsu@arch:~$ uname -a
Linux arch 4.7.2-1-ARCH #1 SMP PREEMPT Sat Aug 20 23:02:56 CEST 2016 x86_64 GNU/Linux
tsu@arch:~$
08/09/2016 #156


Muchas gracias por vuestros aportes
He vuelto a instalar Debian para 64bit, pero no he conseguido instalar MPLABX
Primero como buen consejo de el-rey-julien hice lo siguiente
el-reu-julien dijo: Ver Mensaje
dpkg --add-architecture i386
apt-get update
[/code]
todo funciono muy bien
Como segundo realice el buen consejo de Ardogan
Ardogan dijo: Ver Mensaje

Código:

sudo apt-get install multiarch-support

Por las dudas hacemos:
Código:

sudo apt-get update

Seguimos:
Código:

sudo apt-get install lib32ncurses5 libc6:i386 libx11-6:i386 libxext6:i386 libstdc++6:i386 libexpat1:i386
[/code]
Todo sobre ruedas, por cierto que multiach dice el sistema que lo tenia operativo
Y por ultimo los buenos consejos de Nepper
Nepper dijo: Ver Mensaje

Código:

root@movil:/home/nepper/Descargas# tar -xvf MPLABX-v3.40-linux-installer.tar
MPLABX-v3.40-linux-installer.sh
root@movil:/home/nepper/Descargas# chmod u+x MPLABX-v3.40-linux-installer.sh
root@movil:/home/nepper/Descargas# ./MPLABX-v3.40-linux-installer.sh
32 Bit, start installer
Verifying archive integrity... All good.
Uncompressing MPLAB X v3.40 Installer....

[/code]
Pero no me instala MPLAB, me dice que faltan las siguientes librerias
root@SONIA:/home/sonia/Microchip# chmod u+x MPLABX-v3.40-linux-installer.sh
root@SONIA:/home/sonia/Microchip# ./MPLABX-v3.40-linux-installer.sh
64 Bit, check libraries
Check for 32 Bit libraries
These 32 bit libraries were not found and are needed for MPLAB X to run:
libstdc++.so
libexpat.so
libX11.so
libXext.so

For more information visit http://microchip.wikidot.com/install:mplabx-lin64

Y Yo ni corto ni perezoso como buen Chapu cojo y hago lo siguiente

root@SONIA:~# apt-get install libstdc.so libexpat.so libX11.so libXext.so
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete libstdc.so
E: No se pudo encontrar ningún paquete con la expresión regular «libstdc.so»
E: No se ha podido localizar el paquete libexpat.so
E: No se pudo encontrar ningún paquete con la expresión regular «libexpat.so»
E: No se ha podido localizar el paquete libX11.so
E: No se pudo encontrar ningún paquete con la expresión regular «libX11.so»
E: No se ha podido localizar el paquete libXext.so
E: No se pudo encontrar ningún paquete con la expresión regular «libXext.so»

En definitiva que no consigo las librerías para este evento
Os pido disculpas y espero tengais la paciencia suficiente para dar luz a un ignorante como Yo
08/09/2016 #157

Avatar de el-rey-julien

con el dpkg --add-architecture i386
apt-get update
el sistema queda listo y ya es multiarch
solo te falto esto
apt-get install libc6:i386 libx11-6:i386 libxext6:i386 libstdc++6:i386 libexpat1:i386
08/09/2016 #158


Efectivamente Su Majestad con ello se ha resuelto el problema y ya tengo instalado el MPLAB en 64bit
Pero Yo diria que efectué este proceso
Ardogan dijo: Ver Mensaje
Código:

sudo apt-get install multiarch-support

Por las dudas hacemos:
Código:

sudo apt-get update

Seguimos:
Código:

sudo apt-get install lib32ncurses5 libc6:i386 libx11-6:i386 libxext6:i386 libstdc++6:i386 libexpat1:i386

[/code]
Pero seguramente que en el fragor de la batalla me cegaron las lentes que llevo y me perdí en el ansiado problema

Muchisimas gracias
08/09/2016 #159

Avatar de el-rey-julien

si yo lo tenia instalado,pero no se como dos o tres años por lo menos,si no es mas
ni bien salio para linux yo lo instale , luego no lo use mas
solo uso últimamente el pickdev para grabar los pic,y para algunos retoques finales

---------- Actualizado después de 24 minutos ----------

se me dio por mirar y,si quisiera instalarlo en mi linux arch ,se puede
https://aur.archlinux.org/packages/m.../?comments=all
no tiene dependencias raras ni nada,se lo ve facil,
lo voy a instalar ,para probar nomas

---------- Actualizado después de 3 minutos ----------

lance una búsqueda y apareció
su@arch:~$ yaourt -Ss microchip-mplabx-bin
aur/microchip-mplabx-bin 3.35-1 (42) (0,97)
IDE for Microchip PIC and dsPIC development
tsu@arch:~$
a instalarlo ¡¡¡
tsu@arch:~$ yaourt -Ss microchip-mplabx-bin
aur/microchip-mplabx-bin 3.35-1 (42) (0,97)
IDE for Microchip PIC and dsPIC development
tsu@arch:~$ yaourt -S microchip-mplabx-bin

==> Descargando PKGBUILD para microchip-mplabx-bin desde AUR...
x .SRCINFO
x LICENSE
x PKGBUILD
x microchip-mplabx-bin.install

microchip-mplabx-bin 3.35-1 (2016-06-23 15:51)
(Paquete sin soporte: ¡podría ser peligroso!)
==> ¿Quiere editar PKGBUILD? [S/n] ("A" para anular)
==> ------------------------------------------------
==>
==> dependencias de microchip-mplabx-bin:
- gtk2 (ya instalado)
- alsa-lib (ya instalado)
- libxslt (ya instalado)
- libxtst (ya instalado)
- desktop-file-utils (ya instalado) [makedepend]
- java-runtime>=7 (compilando desde AUR)
- java-openjfx (paquete encontrado)
- fakechroot (paquete encontrado) [makedepend]
- lib32-fakeroot (paquete encontrado) [makedepend]


==> ¿Quiere editar microchip-mplabx-bin.install? [S/n] ("A" para anular)
==> --------------------------------------------------------------------
==> n

==> Continuar compilando microchip-mplabx-bin? [S/n]
==> ------------------------------------------------
==> s
lo rojo son las dependencias eso de los 32 bit ,porque mi sistema es de 64 bit

---------- Actualizado después de 10 minutos ----------

14:46 comense a instalarlo
se tarda en descargar,el paquete microchip.tar pesa 490mb ¡¡¡

---------- Actualizado después de 8 minutos ----------

mientras espero a que se descarge encontre el piklab
tambien se puede instalar

Código:
su@arch:~$ yaourt -Ss piklab
aur/piklab 0.16.2-3 (12) (0,09)
    IDE for applications based on Microchip PIC and dsPIC microcontrollers 
    similar to the MPLAB environment
tsu@arch:~$
08/09/2016 #160

Avatar de el-rey-julien

juan47 dijo: Ver Mensaje
Efectivamente Su Majestad con ello se ha resuelto el problema y ya tengo instalado el MPLAB en 64bit
Pero Yo diria que efectué este proceso

Pero seguramente que en el fragor de la batalla me cegaron las lentes que llevo y me perdí en el ansiado problema

Muchisimas gracias
proba el picklab ,yo mucho no lo use,pero lo poco que lo use me gusto,
apt-get install picklab
http://usuariodebian.blogspot.com.ar...microchip.html

cuando termine de instalar el mplab me instalo en piklab ,ese es nativo de linux

---------- Actualizado después de 17 minutos ----------

tardo unos 40 minutos en instalarce el mplab ,mas tarda en descargar el mplab que otra cosa,ya lo probe y funciona y ya desisntale también

en la captura estaba cargando el mplab

¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Sala de Charla

Comparte charlas y momentos. No todo es Electrónica en la vida ;)

Cerrar
Foros de Electrónica » Compartiendo con la comunidad » Sala de Charla

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.