Haz una pregunta
  Foros de Electrónica » Reparación en General » Reparación de Electrodomésticos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/09/2012 #1


Problema con manometro digital
Buenas a todos, tengo un manometro digital para medir la rampa de alta presion en vehiculos diesel, y de lo mas bien que andaba, ahora se me desaparecio los segmentos horizontales de todos ellos, es decir se muestran los valores numericos pero sin las lineas inferiores de los 7 segmentos.
Tengo buen conocimiento en electronica pero nunca pase por ese problema, si hay alguien que le paso algo asi y me pueda orientar por donde esta la cosa, espero no sea algo relacionado con la progarmacion del pic, pero bueno gracias

COMPONENTES
Q: x4 C33725
IC: x1 7805
PIC: x1 PIC16F876A-1/SP

LES DEJO ALGUNAS PICS
19/09/2012 #2


te fallan los cuatros segmentos (D) de los cuatro displays,los has comprabado con el polimetro que no se han fundido?seria mucha casualidad pero no algo imposible,has revisado tambien las soldaduras de los cuatro segmentos(D)-resistencias(creo ver que son de 220ohm)-pin x del pic?. Te digo esto porque seguramente el pic tiene 7 salidas (si contamos el punto son 8)que controlan los 7 segmentos de cada displays y estos estan conectados en paralelo ,asi que una salida del pic controla todos los segmentos(a),otra todos los (B),otra todos los(C),etc.. aunque a lo mejor esto tu ya lo sabes.
Nunca he tratado con pic's pero no creo que se le funda una sola salida(en este caso la que controla(D),pero podria ser cualquiera),aunque cosas mas raras he visto. suerte y saludos!
19/09/2012 #3
Moderador general

Avatar de DOSMETROS

Revisá soldaduras frias , o impreso cortado o las 8 resistencias de la derecha (una por cada segmento más el punto)

Saludos !
19/09/2012 #4

Avatar de DJ DRACO

Yo te aviso que los microcontroladores NO tienen mucha capacidad de corriente en sus terminales...SIEMPRE es aconsejable agregar un ULN o algún arreglo de transistor para amplificar la capacidad de corriente


Si no anda ningún segmento D de ningún display, seguramente se quemó esa salida del PIC


Porque no creo que de repente se hayan quemado 4 segmentos iguales a la vez....no lo creo

Mirando bien los resistores que van entre el PIC y los display son de 220 Ohms...

5V que maneja el PIC sobre 220 Ohms da casi 23mA

23mA es casi lo máximo que maneja un PIC en sus I/O...si a eso lo multiplicas por 4 (en el peor de los casos digamos) supera ampliamente la capacidad máxima del PIC de drenar corriente


Saludos.
19/09/2012 #5
Moderador general

Avatar de DOSMETROS

DJ DRACO dijo: Ver Mensaje
23mA es casi lo máximo que maneja un PIC en sus I/O...si a eso lo multiplicas por 4 (en el peor de los casos digamos) supera ampliamente la capacidad máxima del PIC de drenar corriente
Seguramente esté multiplexado DJ
19/09/2012 #6

Avatar de Gudino Roberto duberlin

DJ DRACO dijo: Ver Mensaje
Yo te aviso que los microcontroladores NO tienen mucha capacidad de corriente en sus terminales...SIEMPRE es aconsejable agregar un ULN o algún arreglo de transistor para amplificar la capacidad de corriente


Si no anda ningún segmento D de ningún display, seguramente se quemó esa salida del PIC


Porque no creo que de repente se hayan quemado 4 segmentos iguales a la vez....no lo creo

Mirando bien los resistores que van entre el PIC y los display son de 220 Ohms...

5V que maneja el PIC sobre 220 Ohms da casi 23mA

23mA es casi lo máximo que maneja un PIC en sus I/O...si a eso lo multiplicas por 4 (en el peor de los casos digamos) supera ampliamente la capacidad máxima del PIC de drenar corriente


Saludos.
Amigo Draco, dejame corregirte en algo, como veras, los 4 display son accionados en modo multiplex, vale decir, nunca existen 2 segmentos iguales encendidos en el mismo periodo, por lo tanto la corriente instantanea drenada en cada puerto de salida, sera constante exista 1 segmento encendido, o los 4.
19/09/2012 #7

Avatar de DJ DRACO

es verdad amigo dos metros está multiplexado...

olviden mi cálculo


pero tengan en mente 2 cosas

1) mantener drenando la corriente casi máxima durante mucho tiempo va calentando el sistema
2) si bien cada pin puede drenar 25mA por separado, el puerto entero creo que tiene un límite de 80 o algo así...hay que ver el data....por ende puede ser que en conjunto con nùmero que usan muchos segmentos...algo se haya quemado...

puede ser
19/09/2012 #8

Avatar de Gudino Roberto duberlin

Amigo materere, deberas ubicar el pin del puerto del PIC que acciona el grupo comun de seg. D, y seguir todo su circuito, en busca de alguna interrupcion o resistencia abierta.
21/09/2012 #9


estoy de vuelta, les cuanto que encontre el problema, resulta que tiene los dip de contacto en ambos lados cuya soldadura, a pesar de no ser vieja, se desoldo por tener pistas muy finas, se ve que las bibraciones y eso le hizo cortar, muchas gracias, les debo una a todos!!! SON UNOS GRANDES
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Reparación de Electrodomésticos

Reparación de Lavadoras, secadoras, microondas, aire acondicionado, calentadores, hornos, ventiladores, etc.

Cerrar
Foros de Electrónica » Reparación en General » Reparación de Electrodomésticos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.