Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?
21/05/2016 #1


Arduino, alimentacion y control
Buenas,
Hice un proyectito con Arduino Uno que por alguna razon cuando lo alimento con una fuente independiente deja de funcionar y si lo conecto y alimento por usb funciona ok.
Entonces tengo 2 preguntas:

1) Puedo tener conectada la placa con usb a la pc para ver el log y a la vez alimentar por una fuente independiente?.

2) Hay algunas funciones en las librerias de arduino que me permita ver el estado de la placa?.

Salu2.
21/05/2016 #2

Avatar de Dan2013

Seria bueno que enseñes como es el proyecto para asi sacar una conclusion.

1) Puedo tener conectada la placa con usb a la pc para ver el log y a la vez alimentar por una fuente independiente?.
Claro que si, la fuente externa es para suplir mas corriente al proyecto, aunque esto no cambia el consumo de los pines de arduino.

2) Hay algunas funciones en las librerias de arduino que me permita ver el estado de la placa?.
No hay libreria para eso, ya que si lo que necesitas es saber si esta encendido o apagado, basta con ojear la placa para ver, o integrar un led que siempre este encendido si vas a meter la placa en una caja.

Saludos.
21/05/2016 #3


Hola,
El proyecto es el clasico ejemplo de servidor web con la ethernet shield.
El problema es que deja de responder pero estuve revisando la fuente que aunque dice 9v cuando la mido tira 13v y el valor recomendado es hasta 12v y por ahi puede venir el problema.

Gracias por la respuesta. Salu2.
21/05/2016 #4

Avatar de Dan2013

miguelcolon dijo: Ver Mensaje
Hola,
El proyecto es el clasico ejemplo de servidor web con la ethernet shield.
El problema es que deja de responder pero estuve revisando la fuente que aunque dice 9v cuando la mido tira 13v y el valor recomendado es hasta 12v y por ahi puede venir el problema.

Gracias por la respuesta. Salu2.
Es recomendable que siempre revises el voltaje de la fuente antes de conectarla a arduino, ya que si sobrepasas el voltaje quemaras el regulador interno de la placa.

Saludos
21/05/2016 #5


Le puse otra fuente de alimentación externa y sigue haciendo lo mismo.

Lo raro es que si estuviera dañado el regulador interno, no funcionaría de una la placa, pero si funciona un rato y después deja de responder.

Yo supongo que el problema es la placa arduino, pues la placa de red sigue respondiendo al ping.

Lastima que no pueda loguear variables internas de la placa para ver si alguna se va de rango o
similar.

Saludos.
23/05/2016 #6

Avatar de Scooter

Alimenta directamente a 5V, yo nunca empleo la pata Vin
24/05/2016 #7

Avatar de foso

fijate que el módulo de ethernet que venden para arduino por ML no trae transformador de aislación como debería, entre el driver y el jack RJ45. Solo vos sabes como lo estas conectando porque aca no posteaste ningun circuito. Asique revisá bien que no haya alguna fuga de corriente por falta de aislación.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.