Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/12/2011 #1


Arduino + XBee
Hola de nuevo!

Ahora ando trasteando con el modulo Xbee, compre la placa base de arduino para este. Quite el micro del arduino, puse la placa del XBee, puse los jumpers en posicion para grabarlo desde USB, abrí el IDE de arduino e introduje el comando "+++" y me devolvió un "OK" entonces ingrese el comando: "ATID3332,DH0,DL1,MY0,BD4,WR,CN" y salieron con sus respectivos "OK". Ahora mi pregunta es: Cuando quise de nueva cuenta ingresar el comando "+++" el modulo ya no responde. ¿Hice algo mal? o ya le doy las gracias al modulo trate de usar los comandos que vienen en esta pagina: http://www.arduino.cc/en/Guide/ArduinoXbeeShield pero de igual manera no esponde.

Ayuda!

Gracias por su atención.
14/12/2011 #2


Ja! parece que ya lo solucione, resulta que si habia logrado programar los Xbee desde la consola de arduino, el detalle es que no reaccionaba por que el Baud no era el correcto, baje el programilla X-CTU y desde ahi trate de ver que Baud era con el que se habia programado, resulta que yo estaba utilizando 9600 cuando el Xbee estaba en 19200. Despues de acertar en el Baud loq ue hice fue darle Reset por los defaults de fabrica y de nueva cuenta el serial se puso a 9600 Baud. Eso era todo. Saludos!

---------- Actualizado después de 42 minutos ----------

Y para los novatos que estan tan verdes como yo en el ambito de modulos Xbee, aqui les dejo un manual que me despejo de muchas dudas: http://www.olimex.cl/pdf/Wireless/Zi...ia_Usuario.pdf

saludos!
01/03/2012 #3


Buenas a todos,

Estoy empezando un PFC y necesito que alguien me asesore.

Quiero hacer una comunicación Zigbee punto-multipunto. La idea es tener como controlador (punto) un arduino, con un Shield Xbee y un Max Stream de Zigbee. La duda que tengo es qué poner en la parte del multipunto, lo que necesito es que se lean entradas digitales de un sensor, que se manden señales digitales a un actuador, es una aplicación de domótica.

Mi duda ahora es por donde tirar:

- Modulo zigbee programado (20€) + PIC (2€).

- Chip zigbee (4€) + PIC (2€): Para esta solución, ¿existe algún PIC preprogramado con el stack de zigbee probablemente?


¿Que pros y contras veis a estas dos soluciones? ¿Cuál veis mejor?

Muchas gracias por adelantado,
Un saludo, Alexgut.
01/03/2012 #4

Avatar de Basalto

Yo lo unico que te recomendaría es MRF24J40MA + PIC. Un saludo
01/03/2012 #5


Esa solución que me das es super cara, ya sólo el MRF24J40MA cuesta alrededor de 50 €. ¿Por qué me recomiendas esa solución? ¿Qué ventajas tiene sobre las que he propuesto yo?
01/03/2012 #6

Avatar de Basalto

alexgut dijo: Ver Mensaje
Esa solución que me das es super cara, ya sólo el MRF24J40MA cuesta alrededor de 50 €. ¿Por qué me recomiendas esa solución? ¿Qué ventajas tiene sobre las que he propuesto yo?
Hola, ¿Donde lo viste por 50 euros? Eso vale 7 euros cada antena. Ventajas el precio, el tamaño del diseño y no me gusta utilizar modulos si los pueder hacer tu. Un saludo
01/03/2012 #7


Ok, perdón, tienes razón en el precio, muchas gracias por la info.

Aunque la segunda solución que doy sería bastante parecida a la tuya, es una antena con el PIC que se comunica tanto con sensores, como con actuadores.
01/03/2012 #8

Avatar de Basalto

alexgut dijo: Ver Mensaje
Ok, perdón, tienes razón en el precio, muchas gracias por la info.

Aunque la segunda solución que doy sería bastante parecida a la tuya, es una antena con el PIC que se comunica tanto con sensores, como con actuadores.
Hola, si sería lo mismo. En la página de microchip tienes codigos de ejemplo para ZigBee, MIWI o MIWI P2P. Un saludo
01/03/2012 #9


Muchas gracias, te agradezco mucho la info!!!
05/03/2012 #10


Me podrías mandar el link donde están los ejemplos? Please. He estado buscando y encuentro algunos ejemplos de código, pero no estoy seguro que sean para el MRF24J40MA.

Muchas gracias!!!
05/03/2012 #11

Avatar de Basalto

Hola, es aquí http://www.microchip.com/stellent/id...cName=en547784, descargas Application Libraries y en la instalación instalas las librerías y ejemplos que quieras.
08/03/2012 #12


Alguien puede ayudarme a simular el atmega2560 en Proteus?
09/03/2012 #13

Avatar de Basalto

Yeey dijo: Ver Mensaje
Alguien puede ayudarme a simular el atmega2560 en Proteus?
Alguien puede decirme que tiene de relacción eso con ZigBee????
20/03/2012 #14


Buenas a todos,

Estoy empezando un proyecto con Arduino y Xbee, ahora estoy haciendo las primeras pruebas de concepto.

En una parte tengo el arduino, con su shield xbee y el xbee stream. El la otra parte, en la que quiero encender un LED, tengo sólo el xbee max stream, sin pic ni nada. He visto que se pueden usar las entradas y salidas del tranductor. Pero..... ¿Le mando desde mi arduino los comando AT que el xbee solo va a reconocer? ¿El xbee max stream tiene algún micro dentro que tenga que programar?



Serial.print('ATD34');
Serial.print('ATWR');

¿Así podría configurar el Xbee max stream que no tiene micro? Evidentemente sería parte del programa que voy a cargar en Arduino. Es decir, desde mi Arduino si mando esas instrucciones configuraría el DIO3 del Xbee max stream como salida digital??

Si así tengo configurado el PIN de Xbee, cómo lo activo?

Serial.print('digitalWrite(13,HIGH)'); así???

Un saludo y gracias por adelantado.
20/03/2012 #15


Please!!! help........

¿Puede ser con ATIC1?? para activa el pin 1??? pero me activa el del xbee en la parte del arduino o manda el comando al otro xbee??? porque yo tengo conectado un led en el xbee que no tiene micro y no se me enciende.
20/03/2012 #16


void setup(){
Serial.begin(9600);
}
void loop(){
Serial.print('ATD1 5');
Serial.print('ATWR');
delay(5000);
Serial.print('ATD1 4');
Serial.print('ATWR');
delay(5000);
}

este es el programa que estoy cargando al arduino. Lo que yo entiendo es que el PIN 19 del Xbee max stream de la otra parte, es decir, de la que no tiene arduino, se debdería de encender y apagar cada 5 segundo. Pero en mi caso no lo hace.

El programa está bien??? puede que sea cualquier otro problema de configuración???

---------- Actualizado después de 10 minutos ----------

En el hyperterminal me devuelve 824422354, alguien sabe cómo puedo interpretar ese dato?
20/03/2012 #17

Avatar de Moyano Jonathan

http://hangar.org/webnou/wp-content/...eros-pasos.pdf
Una guía muy simple de arduino y Xbee.
21/03/2012 #18


Ya leí ese manual hace unos días, lo que pasa que no puedo hacer esa prueba porque yo no tengo dos shield xbee. Por tanto, puedo cargar ese programa, así como la configuración de los xbee, pero a la hora de ver como transmite la cuenta, no puedo conectar el xbee con el ordenador.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.