Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/05/2013 #1

Avatar de Scooter

Una de comandos ESC y Arduinos
Estaba formateando la salida de texto por el puerto serie de un programa de arduino con comandos AT y falla mas que una escopeta de feria. En muchísimas ocasiones aparece el comando en si en la pantalla en lugar de su efecto.
Tendré que ir haciendo pruebas para ver donde está el fallo:Era por si alguien lo había intentado y podía aportar ideas al respecto, no veo muy claro por qué a veces ejecuta el comando AT del VT100 y en otras aparece sin mas el contenido del comando en pantalla.

Para evitar tener que hacer un programa receptor en android, windows o lo que sea estaba intentando usar un simple "terminal tonto" y formatear texto y preguntas desde el propio arduino...
07/05/2013 #2

Avatar de albertoxx

Por lo que vi en el datasheet del bluetooth solo tiene 4 comandos AT (AT,BAUD,NAME,PIN) que si funciona como un modem solo se podran ejecutar cuando no exista una conexion, luego que se realizo la conexion en este caso via bluetooh todo lo que envies desde el arduino aparecera en la terminal de android y todo lo que le envies desde el programa en android lo recibiras en el arduino
07/05/2013 #3

Avatar de Scooter

Una cosa son los comandos de configurar el bluetooth, que efectivamente son los justos, y otra los de configurar el terminal (creo). De hecho funcionan y funcionan mas que fallan, pero si estoy actualizando un dato y falla una de cada diez, al cabo de un tiempo tengo la pantalla entera hecha una calamidad.
Podría borrarla y repintarla entera cada vez, pero así gastaría mas tiempo y estaba intentando emplear lo justo.
Seguramente suba el baudrate para bajar también el tiempo; la librería de serie de arduino se queda "tointa" hasta que se termina de enviar. Probaré a ver que saco en claro.
07/05/2013 #4

Avatar de albertoxx

A bueno entonces son los comandos ESC del VT los que te estan dando problemas talvez llegue algun caracter basura en medio de la secuencia o que no llegue el caracter #27, para verificar si esta llegando todo talvez seria conveniente enviar numeros consecutivos 1 2 3 4...digamos hasta el 1000 o algo asi para verificar que estan llegando en secuencia y no que lleguen asi 1 23 4 o 1 2 4, tambien puede ser el emulador que no todos son tan buenos.
07/05/2013 #5

Avatar de Scooter

Es verdad, está mal el título. Son comandos esc
Pues aparte de los esc a veces transmite mal, tanto por usb como por bt
07/05/2013 #6

Avatar de albertoxx

Si deplano es por eso que cuando envias <esc>[ talvez no llegue el <esc> y solo el [ por eso te lo muestra en pantalla o si llega el <esc> pero luego llega otra cosa, lo que si no vi si tenia opcion para configurar la paridad y control de flujo que eso ayuda a mejorar la calidad de la transmision ya que el protocolo serial no tiene tanta seguridad
08/05/2013 #7

Avatar de Scooter

No se si el módulo bluetooth lo permite porque la documentación que tengo de él es ambigua; se ve que hay módulos casi idénticos con distintas "calidades" de firmware etc y algunos tienen muchas opciones y otros menos. Este por ser el mas barato seguramente tendrá pocas.
El que no tiene control de flujo por hardware es el arduino, no se si el Xon Xoff lo soporta, lo miraré a ver.
De cualquier modo he usado muchas veces comunicación serie "a tope" sin ningún control de flujo ni paridad y el índice de errores es mucho mas bajo que en los arduino, es casi nulo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.