Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

04/07/2016 #1


Dos transformadores un MEGA y la masa.
Hola.

Quiero controlar una electroválvula con un arduino mega.
La electroválvula se alimenta con 12V con un transformador de 12V. el arduino tiene su propia fuente de 9V.
Voy a controlar la electroválvula mediante un MOSFET. Conectaré las patas S y D del MOSFET al transformador de 12V y la G a un pin digital del arduino. No sé si debo poner un optoacoplador a esta pata, pero esta es otra cuestión.
La cuestión es ¿debo conectar las masas de los dos transformadores entre si?¿Y como lo hago, conectando un cable entra las dos y ya está, o hay que poner algo entre ellas?.
Adjunto un esquema.
Y francamente no se que más información aportar para que no tengan que adivinar lo que pretendo y se entienda la pregunta.

Ah! Y se me olvidaba, en el esquema donde pone 5V es en realidad 9V (me equivoqué).

Gracias!!!!
04/07/2016 #2

Avatar de ruben90

Y porque no obtienes los 9V del primer transformador con un regulador comercial LM7809?.
Como estas utilizando un MOSFET tipo N, la electro-válvula debe ir conectada en el Drain y el Source lo conectas a GND. Por ultimo, los 5V que proporciona el Arduino no son suficientes para "saturar" al transistor ya que lo normal son 10V (o más).

¿debo conectar las masas de los dos transformadores entre si?
No necesariamente, pero si las conectas entre si, no pasa nada.
04/07/2016 #3


ruben90 dijo: Ver Mensaje
Y porque no obtienes los 9V del primer transformador con un regulador comercial LM7809?.
Por que no tengo ni idea de electrónica y pensaba que como el arduino tiene un regulador no se podía poner otro.
Pero vamos, me has alegrado el día. GRACIAS!!!!!!

---------- Actualizado después de 3 minutos ----------

ruben90 dijo: Ver Mensaje
Por ultimo, los 5V que proporciona el Arduino no son suficientes para "saturar" al transistor ya que lo normal son 10V (o más).
Vaya. Pues la información la he sacado de una página donde pone este mosfet conectado a un PIC. He supuesto que la salida del arduino sería como la un PIC. Veo que no.
Gracias una vez más, voy buscar un solución.

la pagina en cuestión:
http://www.inventable.eu/como-conect...rocontrolador/
04/07/2016 #4

Avatar de ruben90

A ok, es que ahí especifican el IRL530 que es un MOSFET con bajo voltaje de umbral y que con 5V se "satura", y el IRF530, el cual tiene un voltaje umbral de entre 2V-4V, y necesitas 10V en el gate para "saturarlo", pero si consigues el IRL530 los 5V del arduino bastan.
04/07/2016 #5

Avatar de Gudino Roberto duberlin

Hola, primero que nada deben estar conectados los GND de ambos sistemas, sino no cierra el circuito de señal de acción del MOSFET, además cómo sugirió el compañero, si dicho MOSFET es canal N, pues el surtidor debe estar conectado a GND, y el drenador a la electrovál. Debes proteger a arduino del MOSFET en caso de problemas, para eso, añade un diodo zener en la salida de arduino hacia el GATE, con un valor 1V. por encima de la tensión de salida de dicho arduino, la resistencia de gate no puede ser mayor a 50Ohms.
04/07/2016 #6

Avatar de Scooter

Sin unir las masas no va a ir nada, ni ese ni ningún otro circuito
04/07/2016 #7

Avatar de ruben90

A ok, es que ahí especifican el IRL530 que es un MOSFET con bajo voltaje de umbral y que con 5V se "satura", y el IRF530, el cual tiene un voltaje umbral de entre 2V-4V, y necesitas 10V en el gate para "saturarlo", pero si consigues el IRL530 los 5V del arduino bastan.

Por que no tengo ni idea de electrónica y pensaba que como el arduino tiene un regulador no se podía poner otro.
Nunca eh utilizado el Arduino MEGA, pero sus versiones (1280, 2560, etc) utilizan el regulador AMS1117-5 que tiene un VIN(max.) de 18V. Si tu transformador es de 12VAC, después del puente de diodos y el capacitor de filtrado, tendrás un VIN =12VAC (√2) - 1.2V ≈ 15.8VDC (en el mejor de los casos).

Ahora, tu electro-válvula trabaja a 12VDC (desconozco cuanta corriente consume), lo que te da un exceso de 15.8V - 12V = 3.8V (podrías descomponer la válvula, al menos que verifiques su Vmax de operación). Supongamos que consume 1A (desconozco cuanta corriente suministra tu transformador), entonces el diagrama seria algo así:


Utilice el TIP120 porque soporta mas corriente que los LM78XX. El diodo zener debe ser de 13V. Si consigues el IRL530, la salida del Arduino va directo a Gate.

Saludos

PD. Todos los capacitores deben ser a 25V o mas.
Imágenes Adjuntas
Tipo de Archivo: jpg circuito.jpg (40,6 KB (Kilobytes), 22 visitas)
04/07/2016 #8


ruben90 dijo: Ver Mensaje

Ahora, tu electro-válvula trabaja a 12VDC (desconozco cuanta corriente consume), lo que te da un exceso de 15.8V - 12V = 3.8V (podrías descomponer la válvula, al menos que verifiques su Vmax de operación). Supongamos que consume 1A (desconozco cuanta corriente suministra tu transformador), entonces el diagrama seria algo así:
http://i64.tinypic.com/2w23pxx.jpg

Utilice el TIP120 porque soporta mas corriente que los LM78XX. El diodo zener debe ser de 13V. Si consigues el IRL530, la salida del Arduino va directo a Gate.

Saludos

PD. Todos los capacitores deben ser a 25V o mas.
La EV consume 450 mA y no pone su Vmax en la hoja de datos. El transformador está pendiente de comprar, así que puedo poner lo que quiera. Con 1A supongo que dará para alimentar la Ev y el MEGA.
Muchas gracias por tu esquema, pero hay una cosa que no acabo de entender: el porqué del BC547 ¿no se puede poner la salida directamente del arduino al IRL530 o es que con este transistor puedo poner un IRF530 (por tus comentarios imagino que será más fácil de conseguir)?
Gracias de nuevo.
04/07/2016 #9

Avatar de ruben90

Ya te explique en el post 4,
ruben90 dijo: Ver Mensaje
A ok, es que ahí especifican el IRL530 que es un MOSFET con bajo voltaje de umbral y que con 5V se "satura", y el IRF530, el cual tiene un voltaje umbral de entre 2V-4V, y necesitas 10V en el gate para "saturarlo", pero si consigues el IRL530 los 5V del arduino bastan.
El bc547 actua como un transistor inversor, si tiene 0V en la base, su señal de salida sera en este caso ≈15.8V (suficiente para saturar al IRF530, de caso contrario, con 5V en la base la señal de salida sera 0V, lo que mantiene "apagado" al transistor. Si "excitas" al transistor IRF530 con 5V, posiblemente se caliente mas de lo debido.

Si no quieres colocar el transistor bc547 y no encuentras el IRL530, puedes conseguir el IRFZ44N. Suerte con tu proyecto
05/07/2016 #10


Pues después de dar unas cuantas vueltas, no encuentro un transformador de 12V 1A . En su lugar he encontrado uno de 12V-9V 1A.
Partiendo del esquema de ruben90, al que le agradezco en el alma la ayuda prestada, he hecho este esquema. A ver si con esto se eliminan los problemas de la masa y además funcionaría el mosfet.
No he encontrado tampoco un IRL530 y si un IRF350, así que espero que funcione tal y como lo he puesto.
Imágenes Adjuntas
Tipo de Archivo: png esquema_mosfet_03.png (115,7 KB (Kilobytes), 15 visitas)
05/07/2016 #11

Avatar de ruben90

Y dicho transformador cuantos cables tiene en el secundario? 3 cables? 4 cables? O 5 cables?
Sobre todo esto, no es mejor que compre un eliminador de voltaje o fuente conmutada? Venden unas de 12V/2A a unos cuantos dolares, y son pequeñas. Se ahorraria muchos problemas y usaria el diagrama que puso arriba (sin el transformador y los capacitores de filtrado).
05/07/2016 #12


Pues parece que tiene 3, pero estoy trabajando con una foto del catálogo de internet.

O sea, 3 del secundario y dos de entrada

Pues parece que tiene 3, pero estoy trabajando con una foto del catálogo de internet.

O sea, 3 del secundario y dos de entrada

---------- Actualizado después de 8 minutos ----------

Ya veo a donde vas. A ver si así esta mejor.

---------- Actualizado después de 3 minutos ----------

ruben90 dijo: Ver Mensaje
Y dicho transformador cuantos cables tiene en el secundario? 3 cables? 4 cables? O 5 cables?
Sobre todo esto, no es mejor que compre un eliminador de voltaje o fuente conmutada? Venden unas de 12V/2A a unos cuantos dolares, y son pequeñas. Se ahorraria muchos problemas y usaria el diagrama que puso arriba (sin el transformador y los capacitores de filtrado).
Pues es una idea. Y posiblemente sea la mejor solución, pero por otra parte me gustaría aprender. No creo que me ahorre mucho dinero, pero me quedaré más satisfecho.
Imágenes Adjuntas
Tipo de Archivo: png esquema_mosfet_03.png (115,2 KB (Kilobytes), 18 visitas)
05/07/2016 #13

Avatar de ruben90

Catálogo? Que imagen?
Lo interpretas mal, los transformadores mas comunes se dividen en: sin tap central o con tap central.

Los sin tap central solo tienen 2 hilos y los que tienen tap central tienen numeros impares de hilos (3, 5, etc). El tap central es un punto de derivación neutro (o sea tiene 0V), y se toma como tierra física del circuito (bla bla bla, no te quiero marear). El cable genealmente es negro y esta en medio de los cables,

El transformador de arriba es de 12V-0-12V. Si mides entre unos de los azules y el negro, obtendras 12VAC, pero si mides entre azul y azul, obtendras 24VAC.

Si quieres aprender electronica de manera autónoma descarga un simulador de circuitos, asi verás su funcionamiento virtual y te ahorraras dinero al no tener que comprar material antes de tiempo.
05/07/2016 #14


Este. La imagen no se corresponde con el producto.
http://www.ondaradio.es/producto/159...-1a-43445.aspx
05/07/2016 #15

Avatar de ruben90

Ok, en este tipo de transformador toman las derivaciones de diferentes puntos del bobinado (si quieres saber más investiga sobre transformadores reductores y su diseño), pero aún te sirve.
No entiendo porque quieres usar los 3 hilos, es material de más. Ya te di la opción de usar los 0-12VAC. Si usas el 0-9VAC obtendrás un voltaje de 11.5VDC (ya no necesitas regulador), eh irá conectado como el diagrama que subiste (solo el Puente de diodos y el capacitar de filtrado). Obvio usar el voltaje justo trae inconvenientes (caídas de tensión por la activación de la electro-válvula, etc.). Cualquier duda, para eso está el foro.
06/07/2016 #16


Gracias ruben09. Voy a hacerlo según tu esquema y dejo de jugar al electrónico, que no se me da nada bien.
18/07/2016 #17


Hola de nuevo.

Ya recibí los materiales para hacer mi proyecto y la primera sorpresa es que el transformador que debería dar 9V y 12V me da 10 y 13,5.
Así que aún y todo, esperando que la cosa funcionase, he comenzado a montar el asunto en una placa perforada.
La cosa es que después de montar parte de lo que puso ruben90 en el esquema, me encuentro con que la tensión que llega al TIP122 es de 15V. Yo suponía que el TIP122 regularía la tensión y lo dejaría en 12V, pero no, a la salida del TIP122 me encuentro con 15,19V.
Es decir al TIP122 llegan por Base 16,08, por Collector 15V y por Emitter me dan 15,19V.
Como los diodos se supone que dan una caída de tensión, le he puesto dos 1N4007 en serie en el Emitter y se me queda en 14,47V.
Así que ahora tengo un poco de miedo de conectarlo al arduino ¿aguantará?¿generará demasiado calor?.
Y una cosa que no acabo de de entender es que hace el diodo zener ahí.
Y una cosa más que me pasa, es que cuando desconecto la electricidad, la fuente me sigue dando voltios y se van cayendo poco a poco. ¿Que puedo poner para que se descargue si está "en vacío"? .

---------- Actualizado después de 29 minutos ----------

Y otra cosa: no se si metí la pata con el zener, he comprado unos que se llaman 1N5350, que era lo que encontré.
18/07/2016 #18

Avatar de Scooter

Es normal que la tensión aguante unos segundos, es lo que tarda en descargarse el condensador.
20/07/2016 #19


Pues ya solucioné lo del TIP122, había confundido colector y base.
Ahora lo que no entiendo es en el esquema de ruben90 lo del IRF530: Si pongo source a GND y Gate al Voltaje del arduino el circuito está siempre cerrado. siempre tengo 12V en Drain. ¿Esto es así o hay algo que no entiendo?
20/07/2016 #20


Bueno, pues creía haberlo entendido. Es decir, según entiendo el IRF350 deja pasar corriente entre source y drain mientras que no aplique la adecuada corriente en Gate.
Así que si la salida del arduino está en LOW tengo paso de corriente y si "subo" la salida del arduino, ésta se debe interrumpir... pues lo he hecho así y la resistencia de 10K del circuito se ha quemado.
Vamos, ha echado humo y se ha puesto negra, así que deduzco que se ha quemado...
Lo he repasado todo una y otra vez y creo que está todo como en el esquema. ¿Que puede estar ocurriendo?
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.