Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

01/07/2015 #1


Problema arduino y lm324
Hola buenas en primer lugar me presento, soy nuevo en el foro, estoy estudiando ingenieria de telecomunicaciones a punto de empezar la rama de electronica. En segundo lugar me gustaría pediros ayuda con un proyecto que estamos haciendo mi padre y yo, para dicho proyecto necesitamos una fuente variable de 0 a 12 voltios para ello queríamos amplificar la señal pwm del arduino mediante el circuito integrado lm324, el problema que tras simularlo y comprobar que funciona al pasarlo a la placa hemos visto que no amplifica la señal. Tenemos conectado el vcc de chip al positivo de una pila de 12 voltios, el gnd del chip al negativo de la pila, la patilla inversora a dos resistencias de 1k en serie y seguido a la salida pwm del arduino, salida con realimentación negativa con una resistencia de 4k7 y la patilla no inversora a la tierra del arduino. Si pudieses resolverlos la duda nos haríais un gran favor. Gracias de antemano.
01/07/2015 #2

Avatar de Daniel Meza

Saludos, ¿y la salida del LM324 a que va conectada?, otra cosa, el PWM al tratarse de una señal "digital" será conveniente amplificarla por medio de un transistor de potencia y no un operacional.

Comparte tu circuito para tener más claridad.
01/07/2015 #3
Moderador general

Avatar de DOSMETROS

Debes subir diagramas y archivos para poder recibir ayuda adecuadamente , algunos deberás zipearlos.

¿Cómo subo imágenes y archivos?

Bienvenido !
01/07/2015 #4


Subire una foto del montaje y el esquema en cuanto pueda, en cuanto a lo del pwm lo habia dicho por simplificar la explicación pero en verdad pensabamos usar un DAC de adafruit para poder tener mayor precisión de la que proporciona la señal pwm del arduino que ademas no llega a ser analógica. De todas formas hasta que suba las fotos te puedo decir que la salida del lm324 esta conectada a una resistencia de 4700 y seguidamente a la entrada inversora.


P.D. En mis dos primeros cursos no hemos hecho muchos montajes así que estoy un poco verde en ese tema.
01/07/2015 #5

Avatar de Daniel Meza

Bien, ¿la finalidad del ARDUINO será manejar la fuente variable?
01/07/2015 #6

Avatar de Gudino Roberto duberlin

Hola, cómo bien comentan los compañeros, un esquema será óptimo para opinar. Pero según tu comentario, dices que el terminal no inv. del op-amp está conectado a GND, pues entonces si arduino no trabaja con alimentación simétrica, entonces esa configuración no funcionará.
01/07/2015 #7


Aquí os dejo el montaje y el esquema de la simulación donde se pueden ver las conexiones y como el resultado da lo que debería (11 voltios y pico). En el montaje la parte de arriba derecha esta el pin 1 del lm324. Si no veis bien el montaje decidmelo e intentaré explicarlo.
Imágenes Adjuntas
Tipo de Archivo: jpg Simulacion arduino.jpg (43,0 KB (Kilobytes), 35 visitas)
Tipo de Archivo: jpg Arduino y placa.jpg (75,2 KB (Kilobytes), 22 visitas)
01/07/2015 #8

Avatar de pandacba

Primero que nada, porque un montaje inversor?? En la simulación no inyectaron la señao pwm--
01/07/2015 #9

Avatar de Scooter

De momento le falta la resistencia en la entrada no inversora: en la realidad los circuitos son reales, nunca son ideales. R =R1//R2 osea =2k // 4k7
¿Las masas de la fuente de 12V y la de 5V están unidas? En la simulación no lo están
Tampoco entiendo que pinta un operacional de ganancia dos y pico en un pwm, el pwm consiste en corte saturación, no en trabajar en zona lineal.
01/07/2015 #10


Las masas de la de 5 voltios y la de 12 voltios no estan conectadas porque al conectarlas en la simulación salian 0.7 voltios de salida y en cuanto a lo de pwm nuestra intención era la de usar el operacional para amplificar la salida de un DAC puesto que necesitamos mas precision de la que proporciona el pwm.
02/07/2015 #11


Si tal y como me comentais el operacional no es la mejor opción, entonces debería usar un mosfet amplificador?. La cosa como ya os comentaba sería conectar el arduino a un conversor digital analógico y la salida del mismo al amplificador para poder obtener una señal de -12 a 12 voltios para poder controlar un galvanómetro. El caso es que ya no se que montaje debería hacer para amplificar dicha señal. Si pudieses darme consejo nos ayudariais enormemente.
02/07/2015 #12

Avatar de pandacba

Primero qeu nada tenes que tener idea de como funciona un amplififcador de señal, ya sea transistorizado o un operacional y como opera este,
De acuerdo a lo que mencionan para que una señal de 5V tenga a la salida una amplitud que va desde -12V a +12V se puede utiilizar un operacional que pueda manerjar el rango de frecuencia y que por lo menos se alilmente a ±15Vdc, y que el amplificador amplifique lo necesario para ir de 5v a lo mencionado, la masa de la salida del pwm debe ir a la masa del amplificador si no no funiocnara, para lo que ustedes necesitan la ganancia debe estar en el orden de los 4.8
02/07/2015 #13


Como he comentado en mis dos ultimos posts la salida de pwm no pensamos usarla ya que necesitamos mayor precision de la que nos proporciona este, pensábamos usar un conversor digital analógico como el de adafruit y la salida de este es la que queremos amplificar puesto que el galvanómetro del que disponemos con 5 voltios no es capaz de moverse.
04/07/2015 #14

Avatar de Dan2013

guillermodarder dijo: Ver Mensaje
Como he comentado en mis dos ultimos posts la salida de pwm no pensamos usarla ya que necesitamos mayor precision de la que nos proporciona este, pensábamos usar un conversor digital analógico como el de adafruit y la salida de este es la que queremos amplificar puesto que el galvanómetro del que disponemos con 5 voltios no es capaz de moverse.
Lo que debes de tener en cuenta es que si se usa una fuente externa además de la ofrecida por arduino, debes de conectar todos los negativos o tierra del circuito en total.

Esto significa el negativo de la fuente y el negativo de arduino.
04/07/2015 #15

Avatar de pandacba

Que tanta precisión necesitan? segundo si le pone a la salida de tu pwm un galvanometro obvio que no se movera ya que este mide voltajes dc(si es un voltímetro) y en la salida no tenes voltaje dc si no pulsos con la frecuencia del pwm, lo que hay que hacer es un integrador para que puedan ver el voltaje en el galvanómetro
04/07/2015 #16


Hola a todos , desafortunadamente lo circuito proposto tiene graves erros : premero lo AmpOp estas sendo alimentado con 1/2 fuente (no hay una fuente negativa) , asi la entrada positiva no puede sener conectada directamente a la tierra porque asi ese CI no es polarizado correctamente y por consequenia no anda de modo algun.
Segundo : ese circuito es inversor , asi invertemos totalmente la relación "on -off" (duty cicle) de lo PWM .
Mi sugerencia es ingresar con lo sinal proveniente del arduino en la entrada positiva del Amp Op y en la entrada negativa hacer lo dibisor resistivo que definen lo gaño de la salida , ha si no pudemos olviar que en ese amplificador lo gaño es 1+ R2/R1 donde R2 es lo resistor de realimentación entre salida y entrada negativa y R1 es lo resistor entre entrada negativa y tierra o masa.
!Fuerte abrazo y buena suerte en los desahollos !
Att.
Daniel Lopes.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.