Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/02/2015 #21

Avatar de Nuyel

Le puedes poner una resistencia o un preset para ajustar el rango, luego ya el potenciómetro ajustaría en el rango que necesitas, la a otra es conectar el por a analogReference en lugar de VDD, Claro que es posible que requiera un buffer.
27/02/2015 #22

Avatar de Dan2013

Nuyel dijo: Ver Mensaje
Le puedes poner una resistencia o un preset para ajustar el rango, luego ya el potenciómetro ajustaría en el rango que necesitas, la a otra es conectar el por a analogReference en lugar de VDD, Claro que es posible que requiera un buffer.
Explicame lo del buffer para entenderlo, lo que pasa es que soy nuevo en la programacion de arduino. Quiero llegar despues a la programacion de PIC!!!
27/02/2015 #23

Avatar de Nuyel

No, me refería a un buffer análogo (un amplificador operacional en modo seguidor), este lo colocas a la señal de referencia para el Arduino, y de ahí tomas el voltaje para el potenciómetro de ajuste Tmax.
Igual si tienes la posibilidad, mejor aprende a programar ATmega como el que usa el Arduino en lugar del PIC
28/02/2015 #24


no puedo entrar al video me pide clave para desencriptar, voy a armar en estos min el circuito que yo haría espero me puedas mandar un diagrama del tuyo

saludos
28/02/2015 #25

Avatar de Nuyel

El link no se enlazó bien, la clave es lo que está después del segundo '!', sería:
r4d64i0f_jcwIWtku_kgqiHAizqhTF5FxCIHOb6 dA1M
Con eso lo descargué.
28/02/2015 #26

Avatar de Dan2013

He modificado el circuito cambiando el potenciómetro por un selector de 3 posiciones con el que cambio el valor de "Tmax", pero ahora genera un error de calculo cuando "Tactual" es mayor que "Tmax".

Aquí un vídeo del circuito operando:
https://mega.co.nz/#!pMx3yYgb!1bYuvZ...ZZublwBOQ6s9pw

Aquí el nuevo código:
Código PHP:
#include <LiquidCrystal.h>

LiquidCrystal milcd(2,3,4,5,6,7);

byte grado[8] = {
    
B00010,
    
B00101,
    
B00010,
    
B00000,
    
B00000,
    
B00000,
    
B00000,
    
B00000,
};

float temp;
int tmax 20;

void setup() {
    
analogReference(INTERNAL);  // Referencia de 1.1v para mayor precision de lectura
    
milcd.begin(16,2);
    
milcd.createChar(0,grado);
    
pinMode(8INPUT);  //Boton 1
    
pinMode(9INPUT);  //Boton 2
    
pinMode(10OUTPUT);   //LED
}

void loop() {
    
temp float((analogRead(A0) * 1.0758) / 10.23);   //Escalando a grados celcius
    
    
milcd.setCursor(0,0);
    
milcd.write("Tactual: ");
    
    
milcd.print(temp);
    
milcd.setCursor(14,0);
    
milcd.print((char)0);
    
milcd.write("C");
    
    if(
digitalRead(8) == HIGH) {
        
tmax++;
    }
    if(
digitalRead(9) == HIGH) {
        
tmax--;
        if(
tmax 0) {
            
tmax 0;
        }
    }
    
    if(
temp >= tmax) {
    
digitalWrite(10HIGH);
    }
    else {
    
digitalWrite(10LOW);
    }
    
    
milcd.setCursor(0,1);
    
milcd.write("Tmax: ");
    
milcd.print(tmax);
    
milcd.print((char)0);
    
milcd.write("C");
    
    
delay(300);
    
milcd.clear();

También el circuito tiene un voltaje de referencia de 1.1v para mayor precisión de lectura, pero pasa lo que les dije anteriormente.
28/02/2015 #27


dan2013 mira esto es un fragmento que tome de mi tesis que hice hace casi ya 10 años te va a servir mucho,


Acondicionadores y Procesadores de señal
No se puede hablar de los sensores, como componentes electrónicos básicos, sin ver como se pueden adaptar a un sistema de adquisición y control. Estos adaptadores, como acondicionadores de señal, son los amplificadores operacionales en sus diferentes estructuras de montaje, pasando por filtros o por procesadores analógicos, convirtiendo estas señales de analógico a digital para posteriormente ser procesados los datos con un Microcontrolador u otro dispositivo que sea capas de hacer dichos procesamientos y actuando por medio de las salidas lógicas del procesador o por medio de un convertidor digital a analógico.

3.3.1 Sensor de Temperatura
Probablemente sea la temperatura el parámetro físico más común que se mide en una aplicación electrónica, incluso en muchos casos en que el parámetro de interés no es la temperatura, ésta se ha de medir para incluir indirectamente su efecto en la medida deseada.
La diversidad de sus aplicaciones ha condicionado igualmente una gran proliferación de dispositivos sensores y transductores, desde la sencilla unión bimetálica de los termostatos, hasta los dispositivos semiconductores más complejos.

Tipos de Sensores de Temperatura
1. Termopares: Los termopares utilizan la tensión generada en la unión de dos metales en contacto térmico, debido a sus distintos comportamientos eléctricos.
2. Resistivos: Lo constituyen las RTD (Resistance Temperature Detector) basadas en la dependencia de la resistividad de un conductor con la temperatura, están caracterizadas por un coeficiente de resistividad positivo PTC (Positive Termal Coefficient). También lo son las NTC (Negative Termal Coefficient), que se llaman termistores y están caracterizadas por un coeficiente de temperatura negativo.
3. Semiconductores: Se basan en la variación de la conducción de una unión p-n polarizada directamente.

te recomendaria que ocupras un LM6081

Realmente te hace falta un circuito como el siguiente:
Imágenes Adjuntas
Tipo de Archivo: png acoplamientolm35.png (5,9 KB (Kilobytes), 68 visitas)
28/02/2015 #28

Avatar de Dan2013

Entiendo tu punto, pero parece ser que el problema esta en el software en ves del hardware, ya que he hecho mediciones del circuito en marcha y no hay fluctuaciones de voltaje. Es mas he puesto en el circuito un filtro R-C en paralelo entre la salida y negativo.

Como he dicho es mejor que veas el video y el codigo, pero gracias de todos modos.
28/02/2015 #29


No es tu código. Necesitas estabilizar tu circuito. ¿Ya lo mediste con el multímetro?
28/02/2015 #30

Avatar de Dan2013

jonathanriv dijo: Ver Mensaje
no es tu codigo necesitas estabilizar tu circuito, ya lo mediste con el multimetro
Como he explicado he medido el voltaje de entrada y de salida del sensor, pero no hay cambios en el voltaje de entrada. Un ejemplo es el ultimo video que subi.

Ademas se puede notar que cuando bajo el valor de "Tmax a un punto mas bajo que "Tactual", este cambia de valor como por 2 grados mas mo menos.

---------- Actualizado después de 3 minutos ----------

A y una cosa, como pueden observar pongo el dedo en el sensor para calentarlo hasta el punto donde este Tmax, pero como ven enseguida sube entre 1 o 2 grados en Tactual
28/02/2015 #31

Avatar de Nuyel

Es que no parece tener sentido lógico alguno asumir error en el código, la comparación no realiza ningún efecto alguno, solo encender un LED con un IF que no cambia para nada el resto del código o los datos. Me parecía que en el Proteus 8 se podría simular esos componentes, sería cosa de probar, la simulación no es la realidad así que los problemas de conexionado y oscilaciones no deberían ocurrir, para poder ayudarte ahora si que necesitaría el circuito físico, pero mi Arduino UNO R3 está a 279km de donde me encuentro y no tengo un LM35 (aparte de que el costo por uno cuando tengo otras maneras de medir temperaturas no me convence, ahora solo tengo un chip que si bien lo podría programar en el mismo lenguaje es ARM Cortex-M4F lo que tiraría resultados demasiado eficientes comparados al AVR de 8 bits.
02/03/2015 #32

Avatar de Dan2013

Tendre que revisar mas exhaustivamente el voltaje del circuito para ver lo que pasa, porque estoy viendo que es verdad no puede ser un problema de codigo.

Ahora entiendo que pasa aqui. Fui a buscar el multimetri de un amigo que es un fluke y pude observar un cambio de 7.4 mV cuando Tactual es mayor que Tmax.

Parece ser que el causante del problema es el LED. Pero como soluciono este problema sin tener que eliminar el LED.

Ya he puesto un filtro RC y un bypass y nada.


jonathanriv dijo: Ver Mensaje



:
Sobre el circuito que me planteaste, se ve borroso y no entiendo nada. Quisiera que me lo expliques mejor.
02/03/2015 #33


es un amplificador operacional como no inversor la resistencia de retro es de 4.16K
02/03/2015 #34


Listo. Ahí está, ya no sufras.

Cambié los pines del lcd por cuestiones prácticas y el led lo puse en el pin 6, no en el ocho como tú decías.
Todo esto es porque ya tengo la placa para el arduino diseñada así.

El amplificador operacional es un LMC6081, la resistencia de retroalimentación es de 4.16K y en la entrada inversora una de 1K conectada a tierra.
Ya revisando, si te agrada el diseño lo que tendrías que hacer es sacar un promedio de las últimas 10 lecturas.

Código:
#include <LiquidCrystal.h>

LiquidCrystal milcd(12,11,5,4,3,2);

byte grado[8] = {    //Creamos el simbolo de grado
    B00010,
    B00101,
    B00010,
    B00000,
    B00000,
    B00000,
    B00000,
    B00000,
};

long milivolts;
int temp;
int tmax;
String Var1; //
String Var2; //
float mitemp;


void setup() {
    milcd.begin(16,2);
    milcd.createChar(0,grado);   //El signo grado
    pinMode(6, OUTPUT);          // Led indicador de tmax
}

void loop() {
    milcd.setCursor(0,0);
    milcd.write("Tactual :");
    
    
    temp=analogRead(A0);
    mitemp=temp*0.11;
//    milivolts = (analogRead(A0) * 5000L) / 1023;     //Convertimos la escala a milivoltios
//    temp = milivolts / 10;        //Ajustamos la escala a grados celcius
    tmax = analogRead(A1) / 16;       //Leemos el valor del potenciometro tmax
    
    if(tmax >= mitemp) {
         digitalWrite(6, HIGH);
    }
    else{
         digitalWrite(6, LOW);
    }
    
   
    //Var1=String(temp, DEC);  // para convertirlo a string
    milcd.print(mitemp);
    milcd.setCursor(14,0);
    milcd.print((char)0);
    milcd.write("C");
    
    milcd.setCursor(0,1);
    milcd.write("Tmax : ");
    //Var2=String(tmax, DEC);
    milcd.print(tmax);
    
    //milcd.clear();
    delay(500);
    
}
Aquí está el diagrama en proteus.
Imágenes Adjuntas
Tipo de Archivo: jpg 2015-03-02_15-26-55_415.jpg (86,9 KB (Kilobytes), 18 visitas)
Tipo de Archivo: jpg 2015-03-02_15-26-42_778.jpg (97,5 KB (Kilobytes), 15 visitas)
Archivos Adjuntos
Tipo de Archivo: rar LM35.rar (10,7 KB (Kilobytes), 5 visitas)
02/03/2015 #35

Avatar de Dan2013

Quisiera que me expliques eso de el lcd, no entiendo por que cambiaste los pines del lcd. Y sobre el operacional, en mi pais no se encuentra, tengo un LM324, un LM386, un LM741 y un LM339. Cual eligirias y explicame sobre como usaste el operacional porque la imagen del circuito esta borroso.
02/03/2015 #36


Saludos , espero ya funcione
02/03/2015 #37

Avatar de J2C

Dan2013

No has colocado ningún dibujo/imagen de tu esquema de conexionado, por lo cual se hace muy difícil ayudarte. Se termina tirando tiros al aire mientras pasa la bandada de pájaros !!!.


Un tirito más:
Puede ser que al encender el led y debido al consumo del mismo la tensión de alimentación del LM35 varíe provocando tu error de lectura.



Saludos, JuanKa.-
02/03/2015 #38

Avatar de Dan2013

Gracias por toda la ayuda, pero pude solucionar el problema con un diodo zener com Vz de 3.3V como voltaje de referencia hacia Aref y estabilize la lectura al maximo.

Sobre el ultimo arreglo del codigo que me ofrecio jonathanriv es muy incomodo porque no entiendo para que un opam como amplificador inversor y ademas de que soy nuevo en arduino (comenzé hace 2 semanas y he aprendido mucho).

De igual modo quisiera que jonathanriv me conteste esa pregunta, o si no gracias de todas formas.
02/03/2015 #39


de nuevo el amplificador operacional es configurado como no inversor, lo puse para estabilizar la señal, la verdad solo recuerdo la mitad de las operaciones por eso no las puse completas pero así como esta es para medir de 0 a 100°C , realmente el led no tiene influencia en la salida del sensor, creo que deberías de saber que las conversiones son promedios aproximados así que considero que el diodo lejos de ayudarte puede perjudicarte porque no tendrás medidas aproximadas, o ya probaste comparando tu sensor con un medidor de temperatura y que las medidas sean aproximadas??? en conclusión como sabes si el conjunto de el sensor con el diodo están bien calibrados???

---------- Actualizado después de 7 minutos ----------

espero que este este mas claro
03/03/2015 #40

Avatar de Dan2013

No lo tengo entendido, porque segun lo que tengo entendido tu configuracion hace una amplificacion en vez de una reduccion. En todo caso lo que pude ver es que el problema es que se alteraba el voltaje de referencia de las entradas analogicas cada ve que encendia el led, y por lo tanto habia una alteracion en la lectura.

Mi solucion fue crear una referencia muy estable que mande al pin aref de arduino y pude resolver el problema en su totalidad. Aqui esta el circuito que usé:


Saludos
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.