Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?
06/07/2014 #1

Avatar de Renoxxx

Problema RX y TX creo?
Hola foro les cuanto mi problema,

Tengo un microcontrolador con arduino al cual le fabrique una placa y lo coloco en esta, la placa es sencilla tiene una entrada programada para detectar un switch que esta con un resistencia pullup y tiene una salida la cual va a dar a un optoacolpador que activa un triac para poder controlar un foco de 120 watts, le deje 4 pines 5Volts TX RX GND.

Cuando conecto el sistema el foco comienza a parpadear cada medio segundo como loco, cuando cierro el switch el foco se queda en un estado ya sea encendido o apagado pero cuando abro el switch el foco nuevamente comienza a parpadear, revise el pullup y los pines del micro y todo bien, pero les cuento lo que pasa, cuando toco el pin RX con mi dedo, el foco deja de parpadear y ya lo puedo controlar con el switch pero la verdad no entiendo que es lo que pasa, alguien me podria aconsejar por favor?

Les adjunto una imagen del esquematico

saludos
06/07/2014 #2


Pon el codigo que estas usando, es posible que sea una mala programacion. lo que tambien podes probar es poner pullup en los pines tx rx.

saludos.
06/07/2014 #3

Avatar de Renoxxx

Fernando123 dijo: Ver Mensaje
Pon el codigo que estas usando, es posible que sea una mala programacion. lo que tambien podes probar es poner pullup en los pines tx rx.

saludos.
Gracias fernando pero al ponerle un pull up al RX y TX de que manera me ayudaria esto?
07/07/2014 #4


es que tal ves las tienes configuradas como entradas, y esto te puede causar que parpadee ya que no están aterrizadas o a vcc, les genera ruido es como si estuvieras presionando el botón muy rápido.
07/07/2014 #5

Avatar de Renoxxx

luis30 dijo: Ver Mensaje
es que tal ves las tienes configuradas como entradas, y esto te puede causar que parpadee ya que no están aterrizadas o a vcc, les genera ruido es como si estuvieras presionando el botón muy rápido.
gracias Luis, voy a colocar las resistencias en pullup en el RX y TX del arduino y les comento, por cierto estoy utilizando un TRIAC BT139 para controlar un foco incandecente de 60 Watts, creen que este esta bien, en la hoja de datos dice que se puede usar para control de luces.

Saludos
15/07/2014 #6

Avatar de Scooter

Las resistencias R4 y R1 me parecen disparatadamente grandes sobre todo R4. Yo siempre he usado ambas de unos 180 Ohm para 230V
25/07/2014 #7

Avatar de Renoxxx

Gracias, tienes razon ya las cambie
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.