Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

Hace 3 Semanas #1


Timer0 y salidas D12 y D13
Buenos días. ¿Alguien sabe cuál es la relación entre timer0 y las salidas D12 y D13?
Cuando configuro el timer0 con la librería timehelpers en modo CYC (creo) las salidas D12 y D23 no me responden, con los otros timers no me pasa ( timer1 y timer2).

Según leí en la hoja de datos, cuando se configura el puerto SPI como esclavo, estos pines se vuelven entradas indiferentemente de lo configurado, yo no tengo configurado el SPI.
Si alguien me puede echar un cable, muchas gracias.
Hace 3 Semanas #2

Avatar de Scooter

Pon el código que has usado o algo.
No acabo de entender lo que preguntas

Hay que ver que hace cada uno de los timers en el sistema, no todos se pueden usar alegremente.
Hace 3 Semanas #3

Avatar de Meta

Hola:
Código:
  1. #include "TimerOne.h"
  2. void setup()
  3. {
  4. pinMode(10, OUTPUT);
  5. Timer1.initialize(500000); // initialize timer1, and set a 1/2 second period
  6. Timer1.pwm(9, 512); // setup pwm on pin 9, 50% duty cycle
  7. Timer1.attachInterrupt(callback); // attaches callback() as a timer overflow interrupt
  8. }
  9. void callback()
  10. {
  11. digitalWrite(10, digitalRead(10) ^ 1);
  12. }
  13. void loop()
  14. {
  15. // your program here...
  16. }
http://playground.arduino.cc/Code/Timer1


Saludos.
Hace 3 Semanas #4


Abajo he puesto un código similar que presenta el mismo problema.
Utilizo los 3 timers en el programa original pero este es el único que me genera este problema.
Las salidas 12 y 13 dejan de responder, no sé si la librería vincula de alguna manera el timer0 a estas salidas.
Gracias de antemano.


Código:
#include <TimerHelpers.h>

#define LED1 12
#define LED2 13
#define TIMER0 6

void setup() {
   pinMode (TIMER0, OUTPUT);
   pinMode (LED1, OUTPUT);
   pinMode (LED2, OUTPUT);


   TIMSK1 = 0;  // no interrupts 
 
   Timer0::setMode (2, Timer0::PRESCALE_64, Timer0::TOGGLE_A_ON_COMPARE);
   OCR0A = 128;

}

void loop() {

    digitalWrite(13,LOW);
    digitalWrite(12,HIGH);
    delay(500);
    digitalWrite(13,HIGH);
    digitalWrite(12,LOW);
    delay(500);
}
Hace 3 Semanas #5


Bueno, parece que el problema viene de la relación entre timer0 y delay(), también afecta a millis() y micros().
Las salidas funcionan bien, pero en el programa necesito retardos y si toco alguna función de estas me afectaría al timer0, el cual necesito que no se toque.
¿Alguna idea?
Hace 3 Semanas #6

Avatar de Nuyel

Es exactamente por eso que yo detesto Arduino, los procesos corriendo detrás no me gustan y siempre he pensado que en algún momento me serían conflictivos, especialmente esos delay()

No estoy seguro de como se estructura la API del Arduino, pero en "wiring.c" están las funciones millis(), micros() y delay(), respecto a eso, delay() está definido como una comparativa en bucle con micros() y esta está definida por el registro en timer0, así que si tocas ese timer olvídate de usar delay(), ah, y millis() está definida por una cuenta con interrupciones del timer0

En resumen, no toques el Timer0 o inventa tu propio delay().
Hace 3 Semanas #7


Bueno he tenido que meter un delay propio, que genera un retardo basado en delaymicros() que no utiliza el timer0. Asi que quedo solucionado.
Gracias
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Arduino y Raspberry Pi

Cerrar
Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos » Arduino y Raspberry Pi

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.