Ajuste de simulación de Proteus

#1
Buen día a todos, hace como una semana vine preguntando acerca del montaje de un circuito ADC para prácticas academicas. Afortunadamente pude encontrar como conectar el DAC para que funcionara. Mi problema ahora viene con la simulación. Se me pide que entregue una simulación del circuito que arme. En el archivo que adjunto en esta entrada se encuentra el circuito que armé en proto.

Originalmente en vez del TL081 que se ve, coloqué un LM741 que en la realidad me funciono bien, pero en las simulaciones me daba un error de simulación (algo de TimeStep demasiado pequeño o algo). Este circuito, armado en proto en la realidad funciona, pudiendo convertir valores analogos a digitales.

Pero en esta simulación ocurre algo ilógico, ya que a la salida del amplificador de transresistencia obtengo 12V (El DAC entrega una corriente de salida), lo cual no tiene sentido ya que a pesar de que conecto +-12V según el esquema de la imagen adjunta, las salidas de los contadores están en '0' lo que haría que el DAC entregase 0 V a su salida, pero en la simulación no ocurre así. Ademas, en el comparador tengo 1V en la entrada no inversora pero le están entrando 12V en la inversora del DAC, lo que debe dar una salida Baja y detendría el proceso de conversión, sin embargo, la salida sigue en alto y el conteo sigue por más la condición del comparador se sigue cumpliendo.

Ya no se si es mi proteus es una basura (uso el 8.6) o algo que no coloque bien. Si intento cambiarlo por un TL082 al transresistencia, la simulación no inicia. Me gustaría intentar simular este circuito en Multisim pero este no dispone siquiera del DAQ0800.

¿Como podría hacer andar este circuito? El funcionamiento normal es que cuando los contadores están en '00000000' el DAC entregue 0 V y mientras su valor de salida sea menor al voltaje que quiero convertir el DAC aumenta el voltaje de salida a cierto intervalo, una vez que el voltaje del DAC supera al voltaje que quiero convertir, el comparador cambia de estado y la conversión se detiene siguiendo la tabla de verdad de la compuerta NAND colocada. Pero como mencione antes, ni la conversión se detiene ni la lógica del DAC esta funcionando.

[Solucionado]: Como mencione anteriormente el proteus es un lio para simular, bien hará los PCBs pero no es bueno para simular. Aparentemente nombrar las entradas de voltaje con el mismo nombre, es decir repetir el mismo nombre provoca alguna clase de error. Lo cambie y esta operativo. No se como cerrar o borrar una entrada así que si alguien pudiera hacerlo se lo agradecería
 

Adjuntos

Última edición:

Temas similares


Arriba