Ayuda con modem WMOD2 Wavecom y comandos AT

#1
Hola

Para mi proyecto de final de carrera tengo que usar el modem GSM de Wavecom WMOD2, tengo que comunicarlo con un PIC y tal, supongo que esto no es nuevo.

El problema viene cuando conecto el modem al ordenador, le meto mi tarjeta, y el led esta continuamente encendido, significa que no encuentra red, en los comandos me devuelve siempre que le digo AT+CREG? lo siguiente:

AT+CREG: 0,2

Esto viene a decir lo mismo que el led, no se si alguien puede saber que hacer porque estoy desesperado, lo tengo alimentado con 12V así que eso no creo que sea. Le he metido una tarjeta de Carrefour y la mía del móvil que es de movistar (la de carrefour estaba dentro del modem cuando me lo han dado los de la universidad). Estoy desesperado ya totalmente con el modem, no se que hacer para que me conecte ni encuentro nada que me lo solucione :(..

Muchas gracias de antemano

EDITO: Solucionado este tema, cambie de tarjeta SIM y a la 3ª fue la vencida, muy raro todo porque la tarjeta de mi movil funciona en mi móvil.

Tengo otra duda, puesto que para que el modem te conteste tienes que pulsar enter despues de cada comando, ¿en el PIC para cada final de comando tendrá que añadirle también el caracter correspondiente a "enter"? Gracias de nuevo
 
Última edición:
#3
que comandos estas utilizando para comuniar el pic con el modem ?
El pic actúa de interfaz entre un datalogger y el modem GSM, así que entre los comandos que usaré seguro ( luego utilizaré mas seguramente ) serán el de la tarjeta sim (AT+CPIN), el de saber si esta conectado a la red (AT+CREG creo), el de los SMS que no recuerdo cual era, y supongo que usaré mas comandos pero en principio aún no lo tengo decidido hasta que no sepa que quiero controlar exactamente del datalogger.
 
#4
No es complicado enviar comandos, yo lo hago de la siguiente manera:

Código:
  fprintf(SIM300,"AT\n\r");           // Comando de verificación.
  delay_ms(500);
  fprintf(SIM300,"ATE0\n\r");         // Eco OFF.
  delay_ms(250);
  fprintf(SIM300,"AT+CMGF=1\n\r");    // Configuramos modo texto
Donde dice SIM300, le indico el puerto USART del PIC donde está conectado el módulo GSM. Tener en cuenta que programo en CCS.

Saludos !
 

Temas similares

Arriba