"boton turbo"

#1
Que tal!

Estoy tratando de hacer un circuito que su funcion sea "activar/desactivar" (como si fuera un switch on/off) pero a alta velocidad.

Les explico mas detalladamente:

tengo un circuito que tiene un micro switch, este micro switch al ser presionado activa un solenoide pequeño, yo presiono ese micro switch muchas veces, entonces me gustaria hacer un circuito que haga eso por mi jeje.

Tengo unas ideas pero no me fncionaron muy bien, les agradeceria si me orientaran un poco.

una idea mia era hacer un clasico pulsador con un 555 y la salida mandarla a un rele y este conectarlo al micro switch pero no ya que consumira demasiada energia y como se activaria varias veces se "flamerian los platinos" (aparte no tengo mucho espacio y solo tengo una pila 9v para su alimentacion)

cambie el rele por un transistor pero no se mucho sobre transistores, en fin, conecte la salida del 555 a la base del transistor y el emisor y el colector al microswitch. no funciono muy bien, de hecho muy mal.

alguien podria ayudarme??? seguro que hay una forma mucho mas simple de hacer lo que necesito solo que estoy algo perdido.

GRACIAS.
 
#4
faltaria...

una resistencia en serie con el pote, para que la resistencia, cuando este esté al minimo no sea 0.

usar, y no se si esto es critico, un extremo del pote junto con el cursor.

un condensador de .01uf en la pata #5 a masa, para evitar interferencias.
 
#5
dagger21: en tu esquema no nos mostrás como está conectado ese microswitch. Mostrás los terminales del transistor sueltos (no llego a ver si es PNP o NPN tampoco).
Además dijiste:
cambie el rele por un transistor pero no se mucho sobre transistores, en fin, conecte la salida del 555 a la base del transistor y el emisor y el colector al microswitch. no funciono muy bien, de hecho muy mal.
Si esto es así, deberías haber conectado el emisor a una de las tensiones de alimentación (la que corresponda) y el colector al microswitch .... A propósito: si querés que el trabajo lo haga el 555 y el transistor, ¿no deberias quitar el microcontacto y enviar la señal al solenoide directamente?

Saludos

EDIT: si podés, danos un esquema (un gráfico) más detallado de lo que querés hacer.
 
Última edición:
#6
Gracias por sus prontas respuestas.

creo que no me di a entender muy bien, les adjunto una foto real del switch. (como se ve en la imagen tiene 2 patitas, lo que quiero es un circuito que active/desactive ese switch pero a alta velocidad)

por cierto el transistor que use fue el 2N2222 y el colector lo conecte a una patita del switch, y el emisor a la otra patita (esto lo hago para no desoldar el switch hasta no estar seguro de tener un circuito que sirva)

GRACIAS.
 
#7
2N2222 :son NPN.
La foto no llegó: tal vez fuera muy pesada y el sistema no te permitió subirla.
Luego decis que conectaste el transistor "en paralelo" (termino mio) al switch.O sea.Cierro el switch, y el solenoide se apaga (o se prende). Si cierro el transitor deberia pasar lo mismo...hago un esquema, para saber si hablamos de lo mismo.
 

Adjuntos

#8
creo que si pesaba mucho, le bajare el tamaño.

pero si exactamente lo conecte como lo muestras, lo conecte en paralelo, solo que antes de el solenoide hay integrados, capacitores, etc.

Tendras alguna idea de como activarlo/desactivarlo como lo mencionaba? a alta velocidad, de hecho si se simplifica y se reduce de tamaño el circuito mucho mejor.

gracias!
 
#9
¿podés medir la tensión sobre el solenoide? es para saber si conmuta adecuadamente. También fijate si calienta algo. Y revisá el 555: alexus detectó un par de cosas interesantes.. (yo no me manejo con el 555, asi que no quiero meterme con eso)
Saludos

(agrega por las dudas una resistenica de 1 o 2K entre el 555 y el 2N2222)
 
Última edición:
#10
Si, de hecho lo que comento alexus ya lo e aplicado, la resistencia entre el 555 y el 2N2222 tambien la puse. la tension del solenoide no se cuanto es, pero se alimenta con una bateria de 9v por lo tanto supongo que no debe de ser mucho.

No habra alguna forma de sustituir el 555 por algo mas sencillo? alguna otra idea? lo digo porque solo lo puedo alimentar con una bateria y el espacio es muy reducido.

gracias.
 
#11
El 555 se banca 200mA .Tal vez puedas alimentar el solenoide directamente con la salida del 555

igual, medi la tensión sobre el solenoide, eso da algo de info
 
Última edición:
#12
ok, te muestro una imagen del circuito:


no se como medir la tension del solenoide, pero creo que el switch no esta conectado directamente con el solenoide, es decir, presionando el switch se manda un pulso a un integrado y este activa el solenoide.

Por cierto me quedo la duda de si estoy conectando bien o mal el transistor, porque segun yo al 555 ya no le puedo hacer nada mas, y teoricamente deberia de funcionar no?
 

Adjuntos

Última edición:
#14
Hola alexus, gracias por tus respuestas, sobre la salida del 555 y el transistor que estoy usando, teoricamente deberia de funcionar no?

es decir la salida del 555 forzosamente lo tengo que mandar a base del transistor no? y emisor y colector en paralelo con el switch.

el transistor haria la funcion del switch de "abrir y cerrar" no?
 
#15
dagger21: la placa que fotografiaste lo cambia todo. Estoy pensando si el transistor quedó mal polarizado. Podés hacer esta prueba: invertí el emisor y el colector del 2n2222. o sea: donde conectaste el emisor, conectá el colector. Y viceversa.

PD: ¿tenes un tester?
 
#17
Estoy pensando: es probable que la placa proporcione una tensión específica para alimentar el switch (por ejemplo, 5V) , y a la salida del mismo, haya conectada una resistencia referenciada al negativo. Luego, tenés la salida al solenoide, también conectada al negativo (es lo mas probable). Y por supuesto, la placa alimentada por la bateria de 9V.
Sería bueno si pudieras corroborar todo esto, y especificar las tensiones que medis en el switch, para aclarar un poco las cosas (La idea es saber si el esquema que adjunto es correcto o no).

(Por supuesto, cualquier nuevo esquema que puedas aportar es bienvenido).
 

Adjuntos

Última edición:
#18
No me habia puesto a pensar en eso y creo que tienes razon!

acabo de checar la placa y me di cuenta de algo que no se como no me di cuenta!
el switch de la placa montado en su respectivo lugar es N.A y a la hora de presionarlo pues obviamente es N.C

Aparte cuando el switch esta N.A hay 5v. lo acabo de medir con el multimetro y creo que si tenias razon.

creo que ya se complicaria mucho mas con esto no?

porque como estaba conectando el transistor en paralelo con el switch quiere decir que siempre estuve alimentando con 5v. el emisor y el colector no?

gracias!
 
#20
proto si tengo, ahora mismo lo armare desde cero,

creo que ya tengo una idea. como mencione si hay 5v. en el switch, y como lo conecte en paralelo con el transistor tal ves por eso no funcionaba y es probable que el transistor se haya dañado, lo que tengo en mente es colocar 2 diodos entre el transistor y el switch. creen que ahora si funcione???
 

Temas similares