circuito que invierte toda señal

#1
hola que tal, me he tirado ya varios dias en tratar de hacer funcionar el circuito de la figura1, ese circuito tiene 2 casos:

caso1: si entra una señal positiva de 2V al circuito como la de la figura 2, no le debe realizar cambios y a la salida debe mostara la misma señal de 2V.

caso 2: si entra una señal negativa de -2V como la de la figura 2, la debe volver positiva a +2V.

hasta este momento solo funciona el caso 1, pero el caso 2 no me ha logrado funcionar!!!!!, es decir no puedo volver positiva una señal que es negativa a la entrada!!!!!!

alguien tiene idea como puedo hacer esto? o ver el circuito realizado con un opam lm358 que tengo, de verdad no se si tenga algun erro o este realizando algo mal!!


saludos y espero alguna persona me pueda aportar algo para seguir avanzando y resolver mi problema!!
 

Adjuntos

#3
hola que tal graciasp or responder!! tu circuito serviria de manera independiente, pero yo quiero meter ambos casos de las señales mostradas en la figura por un mismo circuito!!

saluodds..
 

Fogonazo

Exorcista & Moderador eventual
#4
Hace un tiempo alguien pregunto exacto lo mismo.
Usa el buscador
En ese post había un circuito que hacia lo que necesitas.
 
#6
hola fogonazo, gracias por responder!!

tu siempre dispuesto a yudar,!! lo simulare y armare!,, y os comentare mas tarde para las retroslimentaciones gracias muchachos!!
 
#8
hola que tal queridos amigos ilustres!!

aun no me ha funcionado el circuito que deseo que invierta la señal como las imagenes que adjunto, debido a que ya traaja con la parte positiva, pero la negativa aun no la realiza como lo puedo hacer?, he seguido sus consejops pero hasta ahorita no tengo buenos resultados!! saludos.
 

Fogonazo

Exorcista & Moderador eventual
#9
...aun no me ha funcionado el circuito que deseo que invierta la señal como las imagenes que adjunto, debido a que ya traaja con la parte positiva, pero la negativa aun no la realiza como lo puedo hacer?, he seguido sus consejops pero hasta ahorita no tengo buenos resultados!! saludos.
¿ Imágenes ?

disculpa como hiciste ese circuito? que programa usaste? se parece al cade simu, aunque no cumple las mismas funciones.......
Multisim 10.1

Edit:
El mismo perro de antes,pero le quitamos las pulgas y le pusimos collar.
 

Adjuntos

Última edición:
#10
gracias por el interes, yo he simulado el circuito varias vces en orcad y me da el mismo resultado que ha ti en myultisim, el problema es que cuando armo el circuito en proto no funciona, las imagenmes a las cuales me refiero son las dos imagenes adjuntas al inicio de este foro (figura1 y figura2).

aun no he logrado que funcione!!! alguien me dijo que no debo utilizar fuente negativa, solo con +vcc y gnd, ya lo intente y tampoco funciono.

saludos.
 
Arriba