COMO CONECTAR salidas de UN PIC CON UN INTEGRADO INVERSOR..

#1
hola.. abro este tema para pedir su ayuda en como conectar las salidas de un pic a un inversor... he usado el 74ls04 y el cd40106.. con los dos he tenido el mismo problema. pasa lo siguiente el circuito que te montado es de un reloj digital.. fue diseñado para usar display 7 segmentos catodo comun... como solo disponia de anodo comun se me ocurrio conectar unos inversores en la salida del pic para usar los display anodo comun... resulta que al conectar los inversores al pic... las salidas del pic no cambian de estado.. no se visualiza nada en los display.. retire los inversores y se me ocurrio usar led normales para probar el funcionamiento del pic.. juntando los catodos de los led y conectado cada anodo a las salidas del pic.. y observe que el pic funciona bien.. el problema se presenta al conectar los inversores al pic.. quisiera que me ayuradan en la forma correcta de hacerlo.. ya coloque resistencias pull-up en las entradas de los inversores y aun persiste el problema.. adjunto la simulacion del circuito y la imagen del diagrama gracias por su ayuda...
 

Adjuntos

#2
Parecera tonto pero alimentantes el IC Inversor? nunca se sabe porque puede pasar.........
Bueno otra cosa que no me "gusta" es el inversor para el anodo comun de los display, el Fan-out o abanico de salida del inversor no podria dar toda la corriente para el display, revisa tambien eso, chauuuuuuuuu
 
Última edición:
#3
Tengo un comentario que no resuelve tu pregunta, pero por qué quieres utilizar inversores si puedes utilizar los displays de los que dispones simplemente utilizando una lógica inversa para el PIC, pensando que cada led encienda con un '0' en vez de un '1'.

Sobre tu problema la verdad no sabría que decirte, yo he conectado circuitos TTL directo al PIC sin ningún tipo de interfaz y nunca he tenido problema.
 
#5
si alimente los inversores... se me ocurrio usar los inversores no soy muy bueno en eso de la progrmacion... ya los inversores los tenia asi que tuve que hacer otro gasto.. si alguno edita el programa y lo modifica para que use 0 en vez de 1 no tendria problema y se lo agradeceria
 
Arriba