Errores al compilar en MPLAB

#21
hola tio gracias por tu respuesta pero aun no he podido con el problema ya vigile el registro tris en la ventana de registros especiales y el aparentemente me configura dicho registro entonces abro el wach para vigilar el estado del puerto y no sucede nada cuando le envio al puerto el valor 01h, solo veo un cambio cuando le envio un 0ffh pero en el puerto aparece el valor 10h. y el programa esta bien te digo que solo cambio el tipo de micro a 16f84 y me funciona correctamente, (por cierto el micro que uso es el 16f873a. espero atentamente sus respuestas.
 
#22
bueno intento ensamblar el hex, pero resulta que me sale que tiene un erro y que no se puede continuar, ya intente cambiarlo, pero en fin, para hacerlo yo me voy a (inicio=todos los programas=Microchip=MPLAB IDE v8.00=MPASMWIN) me sale ese error una vez me salio pero volvio a cambiar el formato y nucan mas lo volvi a ver pero ahora resulta que nuevamente sale, tenia 6.5 mplab o cambie pensando que tal vez era la version, y me pasa a la 8.0 mplab, pero siguio igual no se que esta pasando.

cualquier comentario gracias
 

Adjuntos

#26
mrkcc dijo:
bueno intento ensamblar el hex, pero resulta que me sale que tiene un erro y que no se puede continuar, ya intente cambiarlo, pero en fin, para hacerlo yo me voy a (inicio=todos los programas=Microchip=MPLAB IDE v8.00=MPASMWIN) me sale ese error una vez me salio pero volvio a cambiar el formato y nucan mas lo volvi a ver pero ahora resulta que nuevamente sale, tenia 6.5 mplab o cambie pensando que tal vez era la version, y me pasa a la 8.0 mplab, pero siguio igual no se que esta pasando.

cualquier comentario gracias
Hola me parece y si no me equivoco es lo siguiente... se ve claramente en la imagen que subiste que la ruta en donde tienes el archivo tiene demasiados caracteres(mas de 62 te dice el programa) es al menos lo que informaciónrma el error.
Crea una carpeta en la raíz del C: (Ej: C:\Trabajos\) guarda tu trabajo allí(el ".asm", etc) e intenta compilar desde allí con el MPASMWIN.

Saludos.

Ric.
 
#28
Guarda tus archivos en uan carpeta mas cercana al directorio raiz. Te está indicando que escedes los caracteres máximos. Seguramente lo guardas en "mis documentos" y el camino hasta llegar ahi es muy largo. create una carpeta en el directorio raiz y verás como se soluciona el problema

A mandar
 
#29
También es largo en el escritorio, ya nos contará si le ha funcionado. Si no te funciona , prueba lo de arriba qu puse para descargar.

 
#30
totalmente coincido con ricbevi y El nombre ese es tu problema para la vercion 8,xx ya de la 7,xx en adelante tenian esa modalidad de tener que hacer tus proyectos cerca de compilador
 
#34
si se pudo tenia razon de que la direccion era muy grande lo puse en c:microchip-1 y ahi se compilo en hex, asi pasa siempre en windoes, gracias por su ayuda, ya que me sirvio de mucho, y por los programas
 
#35
Acabo de instalar el MPLab v8.10, también me he bajado el Niple v5.2.

Utilizo el Niple para hacer el código asm, (este me parece muy buen programa para generar código porque es todo muy visual, gráfico...) y bien, me genera el siguiente código (Archivo adjunto).

Paso el código al MPLab, le doy para que programe y me da errores, en concreto el siguiente (Archivo adjunto).

Me podría decir alguien donde esta el fallo?
 

Adjuntos

#36
El problema es que la ruta del archivo excede un largo de 62 caracteres.
Te lo dice en el mensaje de error.
Poné todo el proyecto en una carpeta colgada directamtente del raiz, y listo !
Error[173] C:\DOCUMENTS AND SETTINGS\ADMINISTRADOR\ESCRITORIO\UNTITLED.ASM 58 :
Source file path exceeds 62 characters (C:\DOCUMENTS AND SETTINGS\ADMINISTRADOR\ESCRITORIO\UNTITLED.ASM)
 
#37
Pues si, tenias razón!
Muchas gracias

Pero ahora me pasa otra cosa, estoy empezando con el libro "microcontrolador PIC16F84"
de "Ra-Ma", escribo el primer ejercicio que pone, y me da otros errores que tampoco se solventar, los he puesto sobre el directorio raíz y tampoco.

Estos son mis primeros pasas con PIC y no se me da muy bien el ingles, es mas todo lo contrario
 

Adjuntos

#38
Bueno; cuando te aparezca un error en la salida de compilación, primero trata de traducir lo
que dice ahí lo mejor que puedas.
Luego haz "doble click" sobre la palabra ERROR y el "debugger" llevará el cursor a la instrucción donde se ha producido ese error.
Y allí, mi amigo, ... estás solo, ... tan solo como has venido a este mundo!

En este caso puede ser que has olvicdado poner el caracter # delante de INCLUDE <P16F84A.INC>. Además sobra el punto final (.)

Debería decir:

#INCLUDE <P16F84A.INC> ; Comentarios que quieras poner

El proceso de debug es tanto o más largo que el de programar.
Bienvenido al mundo de los "sacabichos".
Por qué te crees que les han puesto PIC, porque los bichos "PIC-an"! :LOL:
 
#39
De acuerdo muchas gracias, creo que ya lo estoy entendiendo, de todas formas ya he hecho mus pinitos en c++, pero cuando me pasaba esto se lo decía al profesor y me solucionaba.
 
#40
Disculpame, no es que no te quiera ayudar. Es que como los WARNINGS no son problemas graves, no les presté atención.

Lo que pasa acá es que las palabras LIST e INCLUDE son instrucciones para el compilador
que deben ir a partir de la columna 2.
Los numeros 4 y 5 indican la linea donde está el error.

Warning[205] C:\PARA BORRAR\UNTITLED2.ASM 4 : Found directive in column 1. (LIST)
Warning[205] C:\PARA BORRAR\UNTITLED2.ASM 5 : Found directive in column 1. (INCLUDE)

Debes dejar al menos una columna libre a la izquierda, o usar el tabulador así:

Código:
 LIST          P=PIC16F84A
 #INCLUDE	   <P16F84A.INC>
Si te pones hábil con el inglés, el debugger te lleva solo !
Tan solo no estás después de todo.
Por el debugger y por el foro.

Saludos

Editado: Acabo de notar el nombre del directorio: Je Je !!!
 
Arriba