Fuente para LEDs de alto brillo

#1
Hola. Estoy trabajando sobre un driver para LED de alto brillo y tengo algunos problemas con la corriente de salida. El circuito es el que pongo como adjunto. Las características del circuito son las siguientes:
Tension de entrada: 12 VDC (batería de gel)
número de Leds: 10 (HB white leds)
Corriente de salida: 350 mA
Tensión de salida: 34 V (3,4 V por led @ 350 mA)

El problema es que no consigo los 350 mA a la salida.

El circuito se basa en el integrado NCP3066 de On Semiconductors, un integrado configurable que trabaja como fuente switching (boost en este caso) con salida de corriente constante, configurable. La corriente de salida se sensa mediante la resistencias R4,R5 y R6 (en paralelo). La tensión que se desarrolla sobre esas resistencias se compara en la pata COMP: si es mayor a Vref=0.235V, el integrado cierra el PWM (disminuye el Ton) y si es mayor, abre el PWM (aumenta el Ton), controlando de esta manera la salida a corriente constante.
La resistencia de sensado se calcula haciendo Vref/Ideseada=0.235V/0.350A≈680mΩ
Yo utilicé dos resistencias de 0.47Ω en paralelo, y éstas en serie con otra de 0.47Ω, con lo cual la corriente de salida debería ser 0.235V/0.705 Ω≈330 mA.
El problema es que sólo consigo 290 mA.
Yo supongo que el problema se puede deber a 3 motivos:
- Las resistencias de 0.47 son de carbón al 5%, y no puedo medirlas por su bajo valor. Es posible que no esté poniendo realmente los 0.705Ω
-El integrado cuenta con una protección de sobre corriente, si la tensión sobre el terminal Ipik cae por debajo de 200mV respecto del terminal Vin, el integrado corta la salida hasta que disminuya el consumo.
-Hay mucho sobrepico en la tensión de sensado que ingresa COMP: la media es del orden de 180 mV, pero con picos de ±2V.

Creo que la primera opcion no debe ser la causa, probé con varias configuraciones y varias resistencias y nunca conseguí la corriente que debería.
Con respecto a la segunda opción, la tensión no cae por debajo de 100 mV en media, pero tambien tiene muchos sobrepicos y es posible que la proteccion esté actuando debido a ellos.
La tercera opción me parece que se acerca más al motivo real, si la regulacion de corriente se hace en base a esos sobrepicos,puede que nunca llegue a la corriente deseada sin filtrar.

La preguntas son:¿ alguien trabajó con estos bichos alguna vez?¿ Es normal tener tanto sobrepico en las señales? ¿La regulacion de corriente es tán sensible al valor de resistencia de sensado?¿ Alguna idea de cómo puedo solucionarlo?

Puedo postear algunas formas de onda si alguien cree que puede darme una mano.

Les agradezco desde ya,
Saludos.
 

Adjuntos

#2
Hola. Estoy trabajando sobre un driver para LED de alto brillo y tengo algunos problemas con la corriente de salida. El circuito es el que pongo como adjunto. Las características del circuito son las siguientes:
Tension de entrada: 12 VDC (batería de gel)
número de Leds: 10 (HB white leds)
Corriente de salida: 350 mA
Tensión de salida: 34 V (3,4 V por led @ 350 mA)

El problema es que no consigo los 350 mA a la salida.

El circuito se basa en el integrado NCP3066 de On Semiconductors, un integrado configurable que trabaja como fuente switching (boost en este caso) con salida de corriente constante, configurable. La corriente de salida se sensa mediante la resistencias R4,R5 y R6 (en paralelo). La tensión que se desarrolla sobre esas resistencias se compara en la pata COMP: si es mayor a Vref=0.235V, el integrado cierra el PWM (disminuye el Ton) y si es mayor, abre el PWM (aumenta el Ton), controlando de esta manera la salida a corriente constante.
La resistencia de sensado se calcula haciendo Vref/Ideseada=0.235V/0.350A≈680mΩ
Yo utilicé dos resistencias de 0.47Ω en paralelo, y éstas en serie con otra de 0.47Ω, con lo cual la corriente de salida debería ser 0.235V/0.705 Ω≈330 mA.
El problema es que sólo consigo 290 mA.
Yo supongo que el problema se puede deber a 3 motivos:
- Las resistencias de 0.47 son de carbón al 5%, y no puedo medirlas por su bajo valor. Es posible que no esté poniendo realmente los 0.705Ω
-El integrado cuenta con una protección de sobre corriente, si la tensión sobre el terminal Ipik cae por debajo de 200mV respecto del terminal Vin, el integrado corta la salida hasta que disminuya el consumo.
-Hay mucho sobrepico en la tensión de sensado que ingresa COMP: la media es del orden de 180 mV, pero con picos de ±2V.

Creo que la primera opcion no debe ser la causa, probé con varias configuraciones y varias resistencias y nunca conseguí la corriente que debería.
Con respecto a la segunda opción, la tensión no cae por debajo de 100 mV en media, pero tambien tiene muchos sobrepicos y es posible que la proteccion esté actuando debido a ellos.
La tercera opción me parece que se acerca más al motivo real, si la regulacion de corriente se hace en base a esos sobrepicos,puede que nunca llegue a la corriente deseada sin filtrar.

La preguntas son:¿ alguien trabajó con estos bichos alguna vez?¿ Es normal tener tanto sobrepico en las señales? ¿La regulacion de corriente es tán sensible al valor de resistencia de sensado?¿ Alguna idea de cómo puedo solucionarlo?

Puedo postear algunas formas de onda si alguien cree que puede darme una mano.

Les agradezco desde ya,
Saludos.
porque queres usar esta fuente si solo tenes que calcular una resistencia asi:
12V-3.4V/0.1A(no se la corriente de los led)=86ohm
8.6Vx0.1=0.86W>>2W
ademas pones de a 2 led en serie y listo
holis.jpg /
 
#3
tinchusbest, gracias por la respuesta.
La idea es usar un driver para asegurar corriente constante por los leds(ya que van a ser utilizados para luminaria), posibilidad de dimmerizar y maximizar rendimiento. Todo esto no se puede lograr con solo la fuente de 12Vdc, por eso elegí usar este integrado.
 
#4
Hola:

En general las fuentes, buck o boost suelen basarse en inductores, los cuales deben de ser de las características recomendadas por el fabricante ya que si no lo son pueden provocar que no se alcance la tensión y/o corriente.

saludos
 
#5
Hola:

En general las fuentes, buck o boost suelen basarse en inductores, los cuales deben de ser de las características recomendadas por el fabricante ya que si no lo son pueden provocar que no se alcance la tensión y/o corriente.

saludos
Hola Rojjo. El inductor que tengo es de 100uH y admite una corriente máxima de 1,5 A. En teoría no deberían estar circulando más de 1,2 A de pico por el inductor (por diseño), así que no creo que sea ese el problema..sigo probando.
Gracias
Saludos
 
#6
Hola Rojjo. El inductor que tengo es de 100uH y admite una corriente máxima de 1,5 A. En teoría no deberían estar circulando más de 1,2 A de pico por el inductor (por diseño), así que no creo que sea ese el problema..sigo probando.
Gracias
Saludos
aumenta el diametro de alambre y calcula de nuevo las vueltas,o te gusta como a mi hacerlo a OJIPIO.JAJAJA
CREO que si usas alambre de 1mm te tiene que alcanzar
 

Temas similares

Arriba