iniciando con modulo bluetooth

#1
Hola acabo de adquirir un modulo bluetooth este

y por el momento quiero probar con el notebook si funciona pero tengo mis dudas de como comenzar
se que debo conectar el modulo a 3.3v y a tierra pero que puedo poner en el tx y rx para comprobar conexion una vez que me conecte al note y abra el hyperterminal?
lei el manual pero no me aclaro las dudas.
 
#2
No se ve la imagen del modulo, pero rx y tx los puedes conectar entre si.

LO que envíes de la PC tiene que regresar, si estando en linea con la PC desconectas el cable que une a rx y tx tiene que dejar de regresar el dato. Es un tip simple pero útil.

Saludos!
 
#4
Exacto, mandas un caracter y te tiene que regresar el mismo caracter.

y si quitas el cable, ya no te debe regresar nada.

en
se ve como se configura el modulo y algunas otras funciones.

Saludos!
 
#5
Hola
grax por el video
pero tengo un nuevo problema el note me reconocio el modulo me dijo el puerto q utilizaba pero al realizar la conexion con el hyperterminal no funciona nada si apreto $$$ para entrar en la linea de comandos
q puede ser :confused:
 
#6
los signos se deben presionar antes de 60 segundos de haberse puesto en verde el led.
se manda $$$ y enter.

Prueba hacerlo solo con vcc y tierra conectada al modulo y conectando rx y tx del mismo modulo.

Me parece que tu versión del modulo trabaja solo a 3.3V así que ten cuidado con los voltajes.

Saludos!
 
#7
asi fue como lo probe, con el tx y rx conectados y a tierra y 3.3v pero nunca se me puso en verde niun led, dude que lo tenga puede ser que no lo tenga?
pero como el pc me descubrio el modulo como bluetooth pense que bastaba y lo hice apenas en menos de 60 seg
 
#8
AAAA

Disculpa, ese modulo no trae leds como el otro.

pero ponle un Capacitor grande (unos 1000uF) a la fuente, a veces eso también afecta.

Fuera de las recomendaciones del vídeo no se me ocurre mas.

Saludos!
 
#11
AAAA
Fuera de las recomendaciones del vídeo no se me ocurre mas.

Saludos!
sbes me dijeron que podia ser la velocidad que por defecto viene en 115k pero como tu dices el video muestra como cambiarla pero ingresando al modo comando hay algun modo de hacerlo en el hyperterminal?
me acuerdo haber visto la velocidad en el hyper pero ahroa no la encuentro :rolleyes:

Saludos
 
#12
sbes me dijeron que podia ser la velocidad que por defecto viene en 115k pero como tu dices el video muestra como cambiarla pero ingresando al modo comando hay algun modo de hacerlo en el hyperterminal?
me acuerdo haber visto la velocidad en el hyper pero ahroa no la encuentro :rolleyes:

Saludos
No, en el hyperterminal no se puede cambiar cuando se trabaja con el modulo bluetooth, al parecer windows y el modulo se ponen de acuerdo en eso automaticamente.

saludos!
 
#15
finalmente el problema era que los $$$ hay que escribirlos muy rapido, menos de 1 segundo y asi se conecta al modo comandos
espero sirva para quienes comiencen con el modulo igual que yo

con respecto a la conexion del modulo con un pic, no es llegar y conectar los tx/rx de cada uno?
voy a usar un 16f877
 
Última edición:
Arriba