Modificación lampara por leds

#1
Hola amigos!

Os cuento lo que me pasa:

El otro día se me ocurrió modificar la bombilla que lleva el flexo que tengo por unos led's de alta luminosidad (fue fruto de que ya me ha dejado varias veces medio ciego y se calienta un poco)

Bueno, el circuito lo tengo claro, lo único es que hoy se me ha ocurrido que también podría regular la intensidad luminosa de los led's, pero no se si hacerlo por analógicamente (por potenciómetro) o digitálmente (por PIC16f84).

¿Que creéis que seria mejor?



Muchas gracias por vuestras opiniones
 
#4
Si conectas el potenciometro en serie con los led (si son muchos)es muy probable que se queme, lo que tenes que usar para hacer el "control analogico" es usar un pwm (hecho con el tipico ne555) de los cuales hay muchos en el foro, y muchos mas en la red
y se podri decir que tenes un numero infinito de pasos de intensidad...
 
#5
Serian 9 led's de alta luminosidad, y la fuente de alimentación la pensaba hacer con un puente de diodos, 4 condensadores, 1 7812 y un diodo (1N4004 ó 1n4007) como protección.

¿Como tendría que hacerlo con el pwm? Me refiero si tendria que poner algun pequeño transistor o algo, porque supongo que el 555 no saca la I suficiente como para alimentar a 9 led's

Si me pusieras un pequeño esquema me seria de ayuda


Gracias
 
#8
Vienen mosfets de 1A, con eso ya estarias sobrado... si le vas a poner un transistor bipolar tenes que agregar la resistencia de base... en realidad las 2 alternativas te sirven.
 
#12
He montado el circuito alimentado con la fuente de alimentación que adjunto, y el circuito no funciona, no saca ninguna señal.

Lo monté varias veces y los revisé otras tantas, y nada, no saca los pulsos.

Tengo que anotar que puse condensadores de 1uF por no tener los que ponía, pero el profesor me dijo que no pasa nada por poner los de 1uF, que su funcionamiento debería de ser correcto.
 

Adjuntos

#13
Si es para conseguir impulsos, la salida del 555 es por la patilla 3 (Q) En la patilla 7 es el colector abierto para hacer el astable.

Hay un pequeño defecto en el esquema.
¿Tu profe no te ha dicho nada? unnnhhhmmmm!
 
#14
Donde mediste lo de los pulsos? En la pata 7?... porque si fue ahi no te va a marcar nada.Es una salida "open collector".Deberias probar en la pata 3 del 555, como para estar seguro de que oscila.

El problema me parece que es que lo alimentas con 5V y no alcanza para saturar el mosfet, en ese caso vas a tener que usar un BJT.

Yo ese circuito lo arme y me funciono bien, pero asi es la electronica . En caso de que siga sin funcionar te adjunto otros que tengo.
 

Adjuntos

#15
El nombre dijo:
Si es para conseguir impulsos, la salida del 555 es por la patilla 3 (Q) En la patilla 7 es el colector abierto para hacer el astable.

Hay un pequeño defecto en el esquema.
¿Tu profe no te ha dicho nada? unnnhhhmmmm!
Defectos: ninguno
El circuito es correcto y funciona. Si te fijas bien la resistencia de 10Kohm mantiene el gate del mosfet a positivo, cuando se habilita el terminal "discharge" o sea el 7 el gate se pone directo a masa a travès del transistor interno del 555.
 
#16
A la salida no le puse el mosfet, más que nada porque todavía no lo tengo.

El profesor lo revisó a mi la lado, porque no entendía bien sacar los pulsos por la siete, y me dijo lo mismo que vosotros, que era salida por medio de un transistor con colector abierto.

La señal la medí en la patilla 7 y en la 3, con el osciloscópio y en la 3 no había ninguna señal. y en la 7 la señal era muy rara.

Probaré los otros que me has dejado, Fernandoae, a ver que tal funcionan.


Ya os voy comentando los progresos.


Gracias por la ayuda
 
#17
Aca hay algo mal que no anda bien jaja.
Proba de utilizar algun soft de simulacion, en su momento use el Proteus y funcionò.En la pata 7 si no pusiste la resistencia de 10K no te tiene que marcar nada, el hecho de utilizar la pata 7 es debido a la pequeña capacitancia del gate del mosfet.Aunque es insignificante :)
 
#18
Si que puse la resistencia de 10K.

Ya digo que el circuito lo comprobé varias veces, como 4 ó 5.

Mañana lo volveré a comprobar y montaré también los otros, a ver cual funciona mejor y cual se va a adaptar más al espacio que tengo (que es muy escaso)


Muchas gracias por todo.

Saludos
 
#19
Hey muchachos!
me parece que nos estamos ahogando en un vaso de agua !
ops:
Yo probé el circuito que aca les paso en mi protoboard, y la verdad anduvo perfecto. La unica diferencia es que yo , los probé con leds comunes, no de alto brillo, igualmente no creo que cambie mucho la cosa, a lo sumo, consumirá un poco mas de corriente. La tercera pata del potenciometro no va conectado a nada. El pote tambien puede ser de 50K o 100K o 5K, lo probe con esos valores y anduvo fenomenal, el tip no calento nada, pero no lo probe mucho tiempo, quizas si lo dejas prendido mucho tiempo se caliente, eso no lo se.




bueno espero que mi aporte sirva de algo para simplificar el problema de SELKIR
 

Adjuntos

Temas similares

Arriba