Prender y apagar un mosfet desde el pic16f873a

#1
Hola, alguien sabe como conectar un transistor bipolar (o 2) para prender un mosfet desde la patilla de un pic16f873a, buscando encontré una configuración como en el archivo adjunto, pero lo simule en isis y no funciona. el requerimiento es que no se invierta la salida.

gracias de antemano por la ayuda.
 

Adjuntos

#2
Hola, alguien sabe como conectar un transistor bipolar (o 2) para prender un mosfet desde la patilla de un pic16f873a, buscando encontré una configuración como en el archivo adjunto, pero lo simule en isis y no funciona. el requerimiento es que no se invierta la salida.

gracias de antemano por la ayuda.
Hola..tal vez así te funcione como a mí.

Saludos.

Ric.
 

Adjuntos

#3
Gracias por la respuesta, así si funciona en el isis, pero a la entrada del fet solo llegan 4.5v, en la practica esto no es suficiente para prender bien el fet.....alguna idea???

Saludos
 
#5
Gracias por la respuesta, así si funciona en el isis, pero a la entrada del fet solo llegan 4.5v, en la practica esto no es suficiente para prender bien el fet.....alguna idea???

Saludos
A pero vos querías completito!!!! eso es a otro precio :) :) (es el apuro después de 10 horas de trabajo) acá tenes otra alternativa si no querés mezclar transistores PNP y NPN.

Ric.
 

Adjuntos

#7
Justo anoche estaba en lo mismo. La salida de mi Pic es de solo 3.5v y me sirvió lo que te adjunto, que en esencia es lo mismo que te plantea Darkbytes.

Solo reemplaza el relé (al que le falta el diodo de proteccion) por tu carga.

Doy fé que anda muy bien.

Saludos
 

Adjuntos

Última edición:
#8
Perdon que sea tan metiche, en fin renesas y international rectifier "e imagino que otros muchos", comercializan unos mosfets que tiene la capacidad de conmutar con valores de VGS de hasta 4V, es decir lo conectas directo al pin de tu micro y jala muy bien, que conste que lo menciono por que el titulo dice "Prender y apagar un mosfet desde el pic16f873a".
 
#9
Ok. Después de una tremenda desvelada, no resulto, es decir, el circuito si funciona pero me consume 0.5 amperes y me baja el voltaje de mi fuente de alimentación a 6 volts (cuando debería quedarse en 24)....probare otras estrategias.....Saludos y gracias por la ayuda.
 
#10
Podrías usar un 7805 alimentado de los 12 volt, y la salida de 5 [V] la podrías conectar directamente al gate del MOSFET, mediante un switch por si quieres apagarlo. Espero que te sirva, saludos.

EDIT: Disculpa, no revise el datasheet del modelo de MOSFET que utilizas, pero con el IRF840 me funciona.
 
#13
Por la premura del tiempo y la desesperación, conecte el gate del mosfet al pic a través de una resistencia de 170E, y una de 10k a negativo, y todo empezó a funcionar muy bien, sin calentamiento, y sin que se trabe nada....Gracias a todos por sus ideas.
 

Temas similares

Arriba