Problema Compilando PIC18F14K22 en CCS

#1
Hola a todos! Tengo un pequeño problema a la hora de compilar un programa en el PIC18F14K22

Estoy usando el CCS compiler

Resulta que al compilar con otro micro como por ejemplo, el PIC16f88, compila sin problemas, pero al compilar en el PIC18F14K22, da un error dentro de la libreria .H, que pone:

UNKNOWN DEVICE TYPE PIC18F14K22

Alguien sabe que puede ser?
Sera la libreria que esta mal?
El tipo de compilador?


Gracias!
 
#2
Resulta que al compilar con otro micro como por ejemplo, el PIC16f88, compila sin problemas, pero al compilar en el PIC18F14K22, da un error dentro de la libreria .H, que pone:

UNKNOWN DEVICE TYPE PIC18F14K22
Posiblemente estés escribiendo algo mal.

Para que salgas de dudas adjunto un programa sencillo usando este PIC, que me compila sin problemas.

Si no lo puedes compilar, seguramente tienes un problema con tu instalación.

Suerte.
 

Adjuntos

#3
Muchas gracias por la respuesta!

Pues resulta que me he bajado el programa, y al compilar me da el mismo error!
He llegado a la conclusion que el error esta en la libreria .H que descargue

Me podrias adjuntar la libreria .H que has utilizado al compilar tu programa porfavor?

Muchisimas gracias! :)
 
#5
Muchisimas gracias por la libreria y el programita! :)

Pues resulta que tampoco me complia! hahaha. no entiendo nada! Porque con otros PIC si que me compila!

Que version de CCS compiler es el que utilizas? Yo uso mplab a la hora de compilar, usas ese programa u otro?

Muchisimas gracias y siento mucho las molestias para un problema tan "sencillo", pero esque no se cual sera el problema

Gracias!
 
#6
Muchísimas gracias por la librería y el programita! :)
De nada. (y)
Pues resulta que tampoco me compila! hahaha. no entiendo nada! Porque con otros PIC si que me compila!
Eso ya me lo suponía. :LOL:
¿Que version de CCS compiler es el que utilizas?
Tengo la versión 4.128
Yo uso mplab a la hora de compilar, usas ese programa u otro?
Yo también utilizo MPLAB, pero por lo regular exclusivamente para programas en ensamblador.
Siempre suelo usar para cada lenguaje de programación, su propio entorno de desarrollo.
Al hacer esto me evito muchos problemas y puede ser que te este sucediendo alguno de tantos. :cool:
Muchísimas gracias y siento mucho las molestias para un problema tan "sencillo", pero es que no se cual sera el problema

Gracias!
No es ninguna molestia, al contrario, espero que la información te sea de utilidad.
Intenta compilando tu programa sin usar MPLAB.
En el post anterior te mencione otras opciones.

Suerte.
 
Arriba