Problema con altura de los sensores cny70

#1
problema con altura sensor CNY70 :

ei !

soy un estudiante de batchillerato que estoy construyendo un robot rastreador, que sigue una linea blanca.

tengo un problema con los sensores cny70 ya que cuando los situo en una altura me funcionan bien, pero cuando vuelvo a encender el robot, luego les tengo que modificar un poquito la altura porque sino en la altura anterior no me lo encuentran !

es un poquito raro el tema, pero, Si alguien a construido un robot con esos sensores, que me diga mas o menos a la altura que los ha situado, y asi los fijare yo, porque la verdad no se que pasa

PD: los sensores estan en perfecto estado.

Oriol
 

Fogonazo

Exorcista & Moderador eventual
#2
Intenta cambiando la corriente del foto-transistor cambiando la resistencia en serie a otro valor mas alto.
 
#3
Yo hice un robot de esos y los puse a unos 2mm de altura, pero funcionaba igual de bien a 1mm y a 3mm, o sea la altura no era tan crítica... quizá tu problema venga por el resto de tu circuito, es decir ¿qué estás conectando a los sensores? En mi caso al transistor del CNY70 le ponía un pull-up de 20K, y esa señal la pasaba por un 74HCT14 para digitalizarla, así la señal llegaba "limpia" a su destino (un PIC). En cuanto al diodo, calcula la resistencia serie para que circulen 20mA.
 
#5
puedes cambiar el 40106 por un 74hc14 o 74ls14 o 74hct14 te recomiendo el 74hct14 ya que es electricamente compatible con los ttl, depende a donde vas a mandar la señal a un pic u otro circuito integrado tambien depende el voltaje que uses en la imagen usan 5 volts si tu usas otro los valores cambian y si son mas de 5 volts hasta 15 tienes que usar forzozamente el 40106
todo depende de las caracteristicas de tu circuito

pon una foto o diagrama de como lo conectaste.
 
#6
El circuito que yo usaba es el mismo que ha puesto javierrbo. En mi caso el pull-up del transistor como dije era de 20K y el integrado digitalizador el 74HCT14, pero el funcionamiento es exactamente el mismo :cool:
 
#8
Mira el CNY70 a mi gusto no me va. ya que es demasiado grande y tiene sus problemas...

Pero para el robot sumo uso sensores TCRT 1000 que son mas pequeños y de mejor calidad...
 

Temas similares

Arriba