Problema con CM8870

#1
Hola a todos, he estado siguiendo desde hace un tiempo los temas de este foro. Felicitaciones por su espíritu de colaboración.
Estoy por graduarme de Ingeniería Informática, por lo tanto conozco muy poco de electrónica, digamos que lo más básico. Estoy intentando para mi tesis algo que involucra el decodificador DTMF CM8870, y he probado tres o 4 esquemas que he conseguido aquí para el hacerlo funcionar, sin embargo no he dado con la solución, he llegado a pensar que puede tratarse de un defecto en el IC, de ser así, de qué forma yo podría saberlo.
Lo único que pasa cuando hago las pruebas es que los leds que coloco en los pines de salida se encienden automáticamente apenas conecto la alimentación, todos menos uno, en ocasiones se apagan dos al rato, y a veces se apagan todos y cuando conecto la línea y marco los números no sucede absolutamente nada, como ven estoy un poco perdido. He probado con el esquema original que aparece en el datasheet y con estos otros dos https://www.forosdeelectronica.com/download.php?id=626 y http://web.fi.uba.ar/~ajvega/micro/images/circuito.jpg.
Agradezco toda la ayuda que me puedan proveer.

Hasta luego.
 
#2
Hola... antes que nada que no te funcione el circuito puede deberse a distintas causas:

1) Que el esquematico que estas armando este mal: con respecto a este punto, te puedo asegurar que el esquematico de la datasheet y el del primer enlace (que esta basado en el de la datasheet) andan sin mayores complicaciones, si se conectan adecuadamente. Asi q la unica recomendacion que te puedo hacer es q revises las conexiones de todo el circuito una por una... (aunque probablemente ya lo hallas hecho)

2) Revisar el funcionamiento del integrado: bueno antes que nada desconecta todo del circuito (linea telefonica, alimentacion y salidas).
Primero conecta la alimentacion al circuito y medi entre el pin 18 y el pin 9 con un tester y tiene que haber 5V (con mucho cuidado de no hacer corto medi en las mismas patas del integrado). Si tenes los 5V salta al paso siguiente, sino revisa el las conexiones del integrado a la alimentacion que hay algo mal.
Segundo, con la alimentacion conectada, medi el pin 15 con respecto a masa, si tenes 0V al paso siguiente, sino revisa bien las conexiones del integrado con el circuito que hay algo mal conectado y probablemente tengas que cambiar el integrado por uno nuevo.
Tercero conecta el circuito a la linea telefonica en paralelo con el telefono, y sin tocar nada del telefono medi cada uno de los pines 14, 13, 12 y 11 con respecto a masa, te deberian dar todos 5V o 0V dependiendo del fabricante, sino es asi probablemente tengas quemado el integrado.
Cuarto, nuevamente medi entre el pin 15 con respecto a masa y mientras lo estas midiendo (nuevamente en las patas del integrado) que alguien apriete y mantenga apretada la tecla 1 del telefono. En el momento que la apriete y mientras la mantenga apretada el pin 15 deberia pasar de 0V a 5V hasta que suelte la tecla. Sino es asi revisa las conexiones entre el integrado y la linea telefonica que hay algo mal o el integrado esta quemado.
Quinto, una vez que se dejo de apretar la tecla 1, y sin apretar ninguna otra tecla, medi cada uno de los pines 14, 13, 12 y 11 con respecto a masa, y en ese respectivo orden deberian darte 0V, 0V, 0V, 5V, sino es asi tal vez tenes mal conectadas las salidas o que el integrado esta quemado.

Bueno, seria interesante que revisaras lo anterior y postearas en que fue lo q fallo y con que esquematico hiciste la experiencia, suerte y espero tu rspueta...
 
#4
Muchas gracias Ivan por tu respuesta tan rápida. Hice las pruebas que me comentaste y todo parecia estar bien, finalmente decidi comprar otro CM8870 y lo monte segun el plano original del Datasheet y funcionó a la perfección con la línea telefónica, salvo por un ruido muy leve que se introduce en la línea, que espero me puedas aconsejar para eliminarlo.
Disculpa la molestia, pero una duda que seguro es muy tonta, es que el chip dice CM8870PI. ¿Qué significa ese PI?
Me despido entonces. Muchas gracias tambien a El nombre por su sugerencia.
Como dije mi especialidad es informática, quedo a su disposición con culquier duda de programación o bases de datos que puedan tener.

Hasta luego. :D
 
#5
Hola, te sugiero que utilices la segunda opcion del datasheet, en donde se muestra una conexion a la linea telefonica atravez de 2 condensadores de 0.01uf. El ruido sobre la linea telefonica , es el reflejo de la oscilacion del cristal de 3.57 Mhz con el que opera el integrado. Eso se llama conexion con desacople de tierra y evitan el ruido. Tambien puedes usar un transformador, pero si no usas el adecuado puedes perder calidad y nivel de señal. Suerte
 
#11
No se que qusiste decir con eso, pero si te dire que lo que te dije no lo hice ni por molestar ni nada de eso, sino porque hay una norma que dice no revivr temas viejos, por lo tanto estas en infracción y todo esto ira a moderación
 
#12
hola disculpen quisiera saber si me puden ayudar con el CM8870 quisiera saber como es el circuito realmente es estoy realizando un circuito con el pic_16f84a se trata de una silla de rueda pero ahora quiero acoplar este circuito CM8870 para controlarlo via celular nesesito que el CM8870 me mande señales al pic_16f84a el error que tengo CM8870 es que todos se quedan ecendido cuando pulso las teclas no hace nada siguen encendido
 
Última edición:
Iniciado por Temas similares Foro Respuestas Fecha
G Telemática y Comunicaciones 2
A Telemática y Comunicaciones 50

Temas similares

Arriba