Problema con comandos AT en SonyEricsson

#1
Hola,

Estoy tratando de mandar y recibir mensajes escritos con una PC conectada por puerto serial a un celular SonyEricsson T226. Uso ún programa en VB que yo hice para controlar el puerto serial y tengo un MAX232 conectado a los pines 4 (Rx) y 5 (Tx) del teléfono.

Ya conseguí mandar mensajes con comandos AT pero mi problema es que no recibo nada por el pin de RX (pin 4), que es donde espero me llegue la información de mensajes recibidos, de hecho coloqué un osciloscopio en ese pin y no se ve que salga información. Ya intenté esto con dos equipos diferentes y sucede lo mismo.

Hasta aquí me atoré y probé con la misma configuración pero usando un Ericsson T39m y en este caso solo recibo como respuesta a cada comando AT el texto "AT", sin importar si mando un ATDXXXXXXXXXX, ATH, AT-loquesea, siempre obtengo como respuesta "AT" (ni siquiera "OK") y tampoco recibo la información de los mensajes.

Si ese mismo T39 lo controlo con el puerto infrarrojo, envío y recibo a la perfección.

O sea que ni con el T39 ni el T226 logro recibir mensajes por el puerto serial físico.

¿Puede alguien ayudarme? Se lo agradeceré enormemente.
 
#2
Saludos Che,
Maneje un modem externo conectado a GSM. Cuando recibia mensajes me llegaba una notificacion +CMNI="SM"

y posteriormente yo debeia leer el index dond e se almacenaba el msn, con esto queiro decirte que le mensaje no se va al serie inmediatamente que se recibe por el celular, sino que se lamacena y para leerlo debes manda el AT+CMGR=<Index>, index es la posicion un numero 0-20

saludos espero te ayude en algo