Problema con DC-DC push-pull en DC<50%

#1
Buenas noches compañeros:

Tengo el siguiente problema (duda) que quisiera resolver con uds: inicialmente tengo un conversor DC-DC de 12V a +-24 con un transformador toroidal, el SG3525 y un par de IRFZ44 para la conmutacion de potencia (con sus snubbers de 10Ω+2.2nF)

Sin carga, el Vgs es una onda cuadrada con casi 50% de Duty Cycle.
Vgs.JPG
Con una carga, el Vgs es similar a lo que describen las bibliografías.
Vgswithload.JPG
PERO, cuando modifico el Duty Cycle la cuestion se pone medio "horrible", siendo notable hasta cierta resonancia.
Lessthan50%.JPG
Lessthan50%2.JPG
Cabe mencionar que la tension DC rectificada disminuye (como deberia) pero igual este tipo de señal me parece una pequeña fábrica de EMI.

¿Es normal? ¿Cómo puedo solucionarlo?

Gracias de antemano!
 
#2
Me gustaría ver el circuito, así en el aire, me parece que está saturando el núcleo porque el "pull" no está reseteando lo que dejo el "push"
Pusiste un gráfico en 2 µs y el resto en 5 µs ¿Podes ponerlo en 5 µs para comparar a simple vista?
 
#3
a simple vista parece energia acumulada en el nucleo del trafo que no va a parar a la carga, esto suele aparecer cuando no hay suficiente energia acumulada en el entre hierro del inductor de salida para polarizar en directa los diodos de freeweeling, o para que actuen como freeweeling los diodos de rectificacion, como dijo nilfred, podrias postear el esquematico de potencia?



preguntonta, le pusiste un inductor de CC a la salida no?
 
Última edición:
#4
Le falta mas filtraje hacia el integrado y especialmente hacia los drives si es que los usas. Con una inductancia o resistencia y condensador lo corriges.
 
#8
Le respondo a sus preguntas:


1.-Disculpen mi error, es Vds.

2.-Si, coloque el inductor en antiparalelo.

3.- La alimentacion está bien desacoplada, medi con el osciloscopio y no había rastros de ripple de alta frecuencia (tengo un osciloscopio de 200Mhz)

4.- El problema lo pude resolver modificando el valor de la red snubber, alcanzando 100Ω+100nF, pero como podran ver tales aumentan significativamente la disipación de calor. La corriente en reposo me paso de 220mA a 600mA. (Esto me lleva a pensar que existe un GRAVE problema de resonancia entre la inductancia parásita del primario (de alrededor de 180nH) con la capacitancia del MOSFET)

5.- Usé 5+5 en el primario, el nucleo no se calentaba en uso normal.

6.-El circuito es el clásico SG3525 con drivers hechos a base de transistores PNP con resistencias de gate de 100

Saludos!
 
#9
Cuál es la frecuencia de trabajo y la inductancia del primario del transformador?, por experiencia la frecuencia no la sobrepases de 100kHz para este CI, pero claro depende del núcleo que tengas.
saludos
 
Última edición:
#10
La frecuencia de trabajo es de 50KHz y la inductancia del primario (sin cortocircuitar el secundario) es de aproximadamente 100uH.


PD: Has tenido problemas con el SG3525 por encima de 100Khz??

Saludos!
 
#12
Le respondo a sus preguntas:


1.-Disculpen mi error, es Vds.

2.-Si, coloque el inductor en antiparalelo.

3.- La alimentacion está bien desacoplada, medi con el osciloscopio y no había rastros de ripple de alta frecuencia (tengo un osciloscopio de 200Mhz)

4.- El problema lo pude resolver modificando el valor de la red snubber, alcanzando 100Ω+100nF, pero como podran ver tales aumentan significativamente la disipación de calor. La corriente en reposo me paso de 220mA a 600mA. (Esto me lleva a pensar que existe un GRAVE problema de resonancia entre la inductancia parásita del primario (de alrededor de 180nH) con la capacitancia del MOSFET)

5.- Usé 5+5 en el primario, el nucleo no se calentaba en uso normal.

6.-El circuito es el clásico SG3525 con drivers hechos a base de transistores PNP con resistencias de gate de 100

Saludos!
sacá esos snubbers. no es tan grave lo que se vé, subí el esquema y deliberamos ahí, que inductancia (y como está hecha) tiene entre los diodos de salida y el electrolitico de salida?

esos 100nH de inductancia paracita es MUUUY alta, podrias poner una foto del trafo?
 
#13
La frecuencia de trabajo es de 50KHz y la inductancia del primario (sin cortocircuitar el secundario) es de aproximadamente 100uH.


PD: Has tenido problemas con el SG3525 por encima de 100Khz??

Saludos!
Por encima de los 100kHz los problemas son los componentes inductivos no el CI, todos los recuperados de fuentes de PC trabajan ya muy justos o no trabajan bien a esta frecuencia. Otra cuestión importante es el bobinado del trasformador y hasta el diseño del PCB.
De todas formas, me uno a la petición de los compañeros sin esquema no te podremos ayudar mucho más, si puedes pon el esquema del bobinado del trasformador.
un saludo
 

Temas similares

Arriba