problema con directiva

#1
hola
A la hora de cargar un programa en MPLAB, me da error en esta linea

__CONFIG _CP_OFF & _WDT_OFF & _PWRTE_ON &

Necesitaria saber todas las posibles causas por el que me sale este error.
El mas frecuente consiste en no dejar espacio al principio de la linea. este no es el caso.

saludos
 
#4
de que microcontrolador se trata?
acepta ese microcontrolador esas directivas?
quiza tengas algun caracter esté escondido?


yo lo pongo siempre al principio

Código:
; Counter using a PIC16F628
; PortA : Out; controlling multiplexing transistors
; PortB : Out; turning on 7 segment displays

	list      p=16f628A            ; list directive to define processor
	#include <p16f628A.inc> ; processor specific variable definitions
	
 __CONFIG _CP_OFF & _WDT_OFF & _BOREN_OFF & _PWRTE_OFF  & _XT_OSC

postea el codigo que tienes.
 
#7
debi haberlo preguntado primero ? que error te da



intenta poniendo primero LIST P=16f84a y INCLUDE <P16F84A.INC>
quiza falte los archivos .INC? tal vez se la version de MPLAB?
puedes pasar el programa completo para inetntarlo en mi compu?
 
#8
Yo creo que el fallo no esta en el programa, ya que a mi si me funciona.
A quien le he pasado el programa no esta muy puesto en MPLAB, asi que posiblemente tenga algo mas configurado, o bien tenga alguna version que no acepte esta directiva.

ahora mismo no tengo disponible el error que sale, ya lo subire en otro momento

muchas gracias mabauti
 
#10
hola

Parece ser que mi compañero ya ha solucionado el problema. Resunta que en el Mplab en la opcion de CONFIGURE - SELECT DEVICE no tenia seleccionado el 16F84A.

Mabauti gracias por tu ayuda. saludos
 

Temas similares

Arriba