Problema con LCD

#1
Busque y busque foros y no encontré unproblema similar, lastimosamente no cuento con una camara para poder postear fotos pero intentare ser lo más especifico posible. Hace algubos días trabajo en una aplicación para visualizar en un lcd el valor de los canales adc de un micro 16f876a. En proteus todo funciona bien y el micro funciona bien, pero resulta que el lcd aparece en blanco, cuando oprimo el reset del micro, aparece la información en pantalla y si lo suelto vuelvo a desaparecer, se que el micro funciona bien porque si uso un led que pongo a destellar a 1 seg funciona perfectamente mientras el lcd se inicia correctamente pero no aparece nada, ya intente usar retardos y nada, el lcd es de letra blanca con fondo azul algo extraño, si alguien me puede dar una idea se lo agradeceria.
 
#2
Parece ser que el problema es el contraste, ajusta el potenciometro para ver si esa es la solucion.

Saludos
 
#3
Gracias por tu opinion, pero ya habia probado eso, tengo nueva información, conecte un nuevo lcd y funciona temporalmente, luego se va y luego vuelve, estoy muy indignado con esto, cualquier idea será bien acogida, gracias
 
#4
Verifica bien las conexiones, algunas veces si no tienes un buen filtraje en la alimentacion suceden cosas extrañas con los LCD, agrega capacitores de 1 y .1 uf a la salida de la fuente de voltaje.
 
#5
Verifica la alimentacion del lcd ya que si es iluminado la corriente de consumo es alta, al principio funcionan apropiadamente pero al pasar el tiempo la fuente se calienta con la consecuente caida de voltaje y el pic junto con lcd terminan por resetearse, cuando la fuente se recupera vuelve a funcionar pero repite la falla, yo antes pensaba que el backlight de los lcd eran un siemple led pero es mas complicado que eso y consumen una buena cantidad de corriente, espero esto te ayude.
 
#7
Voy a probar todolo que me han dicho, el micro esta trabajando a 4 mhz, pero ya probe usando retardos, gracias a todos por los aportes
 
Arriba