Problema de corte en transistor

#1
Les cuento,

Debo encender 16 led rojos o verdes con el control de una plataforma arduino con pines digitales de 0v a 5v con max 40mA para ello coloque un transistor 2n2222 como lo ven y sus resistencias

Mi problema surge cuando lo necesito en corte es decir con 0v logico, los leds se encienden un poco lo que es un problema

Todos los datos entregados son medidos cuando estan en estado logico 0.

Ademas coloque la base del transistor al aire y aun estaban un poco encendido los leds con esos datos de corriente. Que yo sepa sin corriente en base esta en completo corte...

De ante mano gracias :)
 

Adjuntos

Última edición:

DOSMETROS

High 2m Modereitor
#2
Los leds mas su resistencia van en colector.

Podrias poner una resistencia de 100 k de base a masa.

Saludos !
 
Última edición:

DOSMETROS

High 2m Modereitor
#9
Un capacitor y/o díodo serían para otra cosa , vos necesitás saturar-encender un transistor NPN polarizando su base positivamente y llevarlo al corte-apagado con la base referida a 0 V, aqui va la resistencia pull-down a masa.

Ya somos dos que te decimos lo mismo :

Los leds mas su resistencia van en colector.
 
Última edición:
#10
Dosmetros, gracias lo he solucionado la resistencia a masa era aprox 50 k



Me ha salido otro problema... casualmente cuando acerco algo al fototransistor se me caen los voltajes ... es decir si tal cual le aplico 5 volt a los transsitores se enciencienden pero si acerco algo al fototransistor y trato de encender los leds ... no llega voltaje suficiente... por que sera?
 
Última edición:

Temas similares

Arriba