Problemas con compuertas

#1
Hola, buenas tardes, noches, días o lo que sea en este momento :LOL:


el día de hoy me decidí a "jugar con unos CI "SN74LS08N" (AND) y "HD74LS32P" y me encontré conque no responden como deberian: al momento de aplicarle tension a la patilla 14 (VCC), y conectar a masa la patilla 7 (GND), las 4 salidas (1Y,2Y,3Y, 4Y)se ponene en "alto", sin importar si las entradas haya o no tension.

estoy utilizando como fuente de alimentacion una bateria de 9V, pero con una resistencia de 5.6Khoms; utilizo LED's azules en las salidas; y en las entradas hay una resistencia de 1Khoms.

Esto sucede en ambos CI's, es casi seguro que sean defectuosos (me imagino) porque son nuevos, pero.... ¿hay algo más que deba saber?






Muchas gracias por su tiempo.... :D

P.D: He leido el "datasheet" de ambos cirucitos
 
#2
Chequeaste de todas maneras la tabla de la verdad? y el circuito en si?

Tambien cabe la posibilidad de que sean truchos y no anden. Todo es posible.

Suerte y un saludo!
 
#3
Esto sucede en ambos CI's, es casi seguro que sean defectuosos (me imagino) porque son nuevos, pero.... ¿hay algo más que deba saber?
Si: Como conectar una compuerta :enfadado:.

1- Tirá esa pila a la basura y alimentá con 5V regulados como corresponde.

2- Los leds no son lámpara incandescentes son diodos. Se alimentan diractamente de la salida solo cuando está limitada la corriente, caso contrario (lo normal) a través de una resistencia.

3- Las entradas nunca se dejan sin conectar. Las que no se usan se conectan a masa o Vcc según corresponda o convenga.
 
#4
Apoyo la recomendación de Eduardo, solo matizo:
Dependiendo de la serie una entrada al aire es un uno lógico o es un "ruido ilógico". De cualquier modo siempre es conveniente ponerlas a 0 ó a 1 "por si las moscas"
Las series hasta la LS, una entrada al aire es 1 lógico, las HC y HCT como en realidad son CMOS es ruido. La F no te lo puedo asegurar.

El circuito va bien a pesar de lo mal que lo has montado, para la serie LS el aire es un 1
 
#5
Si: Como conectar una compuerta :enfadado:.
huuuu... no era para que te me enojes, jejeje :)

1- Tirá esa pila a la basura y alimentá con 5V regulados como corresponde.
Ya la tiré ^^

2- Los leds no son lámpara incandescentes son diodos. Se alimentan diractamente de la salida solo cuando está limitada la corriente, caso contrario (lo normal) a través de una resistencia.
mmm... pues, no tienen resistencia, pero creo aplicarles la tension "adecuada"

3- Las entradas nunca se dejan sin conectar. Las que no se usan se conectan a masa o Vcc según corresponda o convenga.
eso si no lo sabía ^^, estoy checando eso

y si no es mucho molestar... tengo otro problema con los transistores "BC557" y "BC548", con solo aplicarle tension a la base (claro, con una resistencia de 10 Khoms), se enciende un led que tengo en el emisor, pero si le pongo tension al colector (con una resistencia de 1Khoms) destella un poco mas el LED

jejeje, soy novato, apenas estoy "jugando" con las compuertas y los transistores, tengo la teoria, pero siempre hay una PRIMERA VES para la práctica.


Estamos aquí para aprender, ¿que, no? ¿muchachos? :D
 
#6
y si no es mucho molestar... tengo otro problema con los transistores "BC557" y "BC548", con solo aplicarle tension a la base (claro, con una resistencia de 10 Khoms), se enciende un led que tengo en el emisor, pero si le pongo tension al colector (con una resistencia de 1Khoms) destella un poco mas el LED
:confused: Pasa lo que tiene que pasar. Cuál es el problema?

Y se mas preciso. Si decís "aplico tensión" o corriente tenés que decir cuanto.
 
Última edición:
#7
"Tengo la teoría"
No te ofendas, pero permíteme que lo dude mucho a la vista de lo que haces y lo que preguntas

Está bien jugar, pero mirando la teoría, es difícil sacar conclusiones "dando palos de ciego"

Los transistores se comportan como un simple diodo entre base y emisor, por eso se enciende el led, si conectas el colector conducen mas, claro.
 
Última edición:
#8
jajajajajajajajajajajajajajajajajajajajajajajajajaja......

Pasa lo que tiene que pasar. Cuál es el problema?
"Tengo la teoría" No te ofendas, pero permíteme que lo dude mucho a la vista de lo que haces y lo que preguntas

Está bien jugar, pero mirando la teoría, es difícil sacar conclusiones "dando palos de ciego"

Los transistores se comportan como un simple diodo entre base y emisor, por eso se enciende el led, si conectas el colector conducen mas, claro.
....encerio?? :eek:

no me gusta la forma en que explican los videos de internet :/, estan mejor las explicaciones de ustedes, aunque sea a coscorrones :LOL: :LOL:


hay algo mas que deba saber?


P.D.: La bateria no la tiré (como se pudieron haber imaginado).... me va a servir en otro momento ^^
 
#10
Hola.

Como ya te han dicho, los LEDs no son focos o bombillas, son diodos. Como todo diodo tiene un voltaje umbral (que depende del color), que la mayoría de la personas confunde con el voltaje que se le debe aplicar al LED para que funcione, como se hace con los focos o bombillas. La intensidad de luz (brillo) depende de la corriente que pasa por el LED y no por el voltaje que se aplica.
Por lo que, a lo LEDs se les alimenta con una fuente de corriente constante o se le aplica un voltaje determinado al LED que deberá tener una resistencia limitador de corriente.

Dicho de manera simple, los LEDs siempre deben tener una resistencia limitadora de corriente, sí no es alimentado con una fuente de corriente constante.

Chao.
elaficionado.
 
#11
saben... pensandolo bien, tengo mucha que aprender, y varias cosas que aclarar, alguien se ofrece a ayudarme? (aprendo rápido) ^.^

ahora que lo menciones "elaficionado"... me podrias diferenciar bien lo que es la corriente y la tension ( o voltaje)? y me pregunto de que forma se puede controlar la corriente, así como una resistencia lo hace con la tension.

Posiblemente revuelva las cosas, pero...

"Es mejor preguntar y parecer tonto durante 5 minutos, que no preguntar y serlo toda la vida"
no recuerdo quien lo dijo :LOL:
 
Última edición:
#13
Gracias, pero ya aprendí que los LED's no son "focos o bombillas" (he quemado los suficientes :LOL:) pero lo que mas me interesa, es aprender a manipular los transistores.

Los transistores se comportan como un simple diodo entre base y emisor, por eso se enciende el led, si conectas el colector conducen mas, claro.
Eduardo, hay algo que puedas añadir a esto?


Muchas gracias a todos los que han participado ^^
 
#15
Mira aquí: Un poco de teoría básica

tal vez te puede servir.
Gracias, muchas gracias. Creo que ya conosco los fenómenos básicos de la electricidad, he aclarado mis dudas, y he respuesto a algunas preguntas, aunque me falta otras pocas:

¿Alguie me puede explicar, el porque se mantiene el mismo resultado, sin importar si una resistencia se pone "antes o despues" de un led (por ejemplo) que está conectado a una bateria?

¿Y una última, los electrones, solo se encuentran en la fuente de alimentación (bateria), o tambien los hay en el cobre?

Al parecer estás son las preguntas que me quedaron, despues de leer, leer y leer acerca de como interactua la electricidad (no les miento, lo que mas me ayudó, fueron algunos videos que me despejaron las dudas)




este es uno de los videos que mas me sirvió


Bueno.. despues de esto, este tema puede quedar cerrado ^^

Bueno.. despues de esto, este tema puede quedar cerrado ^^
señores!!!, los circuitos integrados no fueron hechos para mi!!!

Tengo el HCF4017BE (un contador/divisor, como recordaran) y me está frustrando!!

solo estoy utilizando 4 salidas con LED's (desde luego) y estos parpadean a toda velocidad, no he econtrado de reducir esa frecuencia, en la entrada del Reloj tengo un Microswitch con una resistencia de 1K a +Vcc; al oprimirlo no sucede nada, y cuando muevo el cable que va al Reloj se detiene, si lo muevo otra ves comiensa la secuencia a toda velocidad.


Que se me está pasando?? Tengo que utilizar las todas las salidas???


MUCHAS GRACIAS POR SU PACIENCIA!!
 
Última edición:
#18
El 4017 va perfectamente con 12 ó 9V
Los CMOS son muy sensibles al ruido, eso es lo que te entra por mal contacto.
Supongo que tienes la R de 1K a positivo y el microswitch a negativo.
 
#19
Cuál es el circuito que estás probando con el 4017
este: 4017B.jpg


--------------------------------------------------------------------------------
ya viste la hoja de base de datos? buscala en www.alldatasheet.com

siempre lo hago, con cada uno de los integrados que toco, precisamente utiliso esa página

la mayoria de las compuertas logicas utilizan un voltaje de 5 volts con .5 de tolerancia, si las polarizas con 9 las dañas por completo
si, ya solucioné el problema con la compuerta, como dijo Eduardo, tenia que conectar las entradas 1A y 1B a tierra o VCC, yo las tenia "al aire" :D

Y si, utilizé una resistencia (no recuerdo de cuantos kilos, creo que de 3 o 10) para bajar la tension.

El 4017 va perfectamente con 12 ó 9V
lo tengo como a 5V (si no me equivoco, está dentro de lo mínimo), lo probaré a 9V

Los CMOS son muy sensibles al ruido, eso es lo que te entra por mal contacto.
si... algo así me imaginaba :unsure:

Supongo que tienes la R de 1K a positivo y el microswitch a negativo.
la resistencia de 1k a positivo en serie con el microswitch, y este a la entrada de el circuito. eso mencionaste?
 
Arriba