Problemas con Flip-Flop D 4013

#1
Buenas, estamos haciendo un semaforo y usamos unos flip flop D como biestable, puenteando el D con el Q|, el problema es que no funciona, tiene un comportamiento errático, que soluciones puede haber? puede ser algún problema de masas? lo estamos alimentando con 9v en el caso de que no hubiera solución, es factible sustituirlo por un 555? solo necesitamos que cuando le de un pulso cambie de estado, hay alguna otra alternativa?
Estamos un poco cortos de tiempo, porque es un proyecto casi terminado para entregar dentro de 4 dias. Gracias.
 
#2
que soluciones puede haber?
Dependiendo del problema, solo una que funcione mejor...

puede ser algún problema de masas?
podria ser, pero no lo creo...

es factible sustituirlo por un 555?
no pudes sustituir un flipflop con un 555, porque sirven para diferentes propositos...
tienes que rediseñar tu circuito

hay alguna otra alternativa?
pon semaforo en el buscador...

o Sube el esquema que estas utilizando...
 
#4
pon a tierra el set y el reset del IC13a y el set del IC13b


verifica que el 555 este pulsando correctamente...

ese tipo de circuitos el livewire los simula muy bien asi que intenta ver tambien posibles errores que hayas cometido en la conexcion real...
y no uso el eagle... pero siquieres subirlo por si alguien quiere darle un mirada....
 
#5
es que el contador con el display funciona perfecto , el tema esta que los flip flop no cambian, lo sacamos del circuito y los conectamos en una protoboard e hicimos algunas pruebas y funciona todo bien, excepto cuando conectamos el D con el Q| que se comporta raro, cuando le doy clock el Q se pone a cero, cuando lo desconecto, en Q y Q| hay 4v en cada una! y cuando vuelvo a conectar el clock, vuelve a ponerse a cero la misma pata...
 
#7
sisi es verdad, pero en la protoboard los conectamos a - y nada... ahora prove con conectar un cable a menos y tocarlo con la mano, y parece que se comportara mejor...
 
#9
en la protoboard, quitamos el led porque en estado bajo nos daba 2v asi que usamos el tester, con el negativo conectado a tierra, como si fuera una punta logica.
 
#15
en teoria el circuito no debería quemar los flip flop vedad? y se supone que como estoy intentando de conectarlo debería funcionar bien si? entonces esto me supera...
 
#16
en teoria el circuito no debería quemar los flip flop vedad?
el circuito no.... una mala conexion si.....

conectarlo debería funcionar bien si?
si intentas que funcione el flipflop pero con un led y su respectiva resistencia limitadora, y en el clock lo mandas a positivo y luego a negativo.... me explico?

osea independiente del resto del circuito
 
Última edición:
#17
Bueno hice todas las pruebas posibles con el flip flor y responde bien a todo excepto cuando puenteo D y Q| se supone que un pulso del clock cambia el estado, ahora viene lo extraño, si conecto el cable a positivo o negativo y le doy un pulso al clock, no pasa nada, PERO si toco el clock con el cable SIN conectar el otro extremo, cambia de estado, todas las veces funciona bien así! que esta pasando??
 
Arriba