Problemas de Interferencia con mi proyecto PIC de PANEL DE LEDS

Haz tenido alguna vez este problema?

  • Si

    Votos: 0 0.0%
  • Nunca

    Votos: 2 66.7%
  • A veces

    Votos: 1 33.3%
  • Casi siempres

    Votos: 0 0.0%

  • Votantes totales
    3
  • Encuesta cerrada .
#1
Necesito de su ayuda por favor, mi amigo y yo elaboramos un panel de leds de 7x64 y cuidamos de tomar las minimas medidas contra ruido e interferncia como poner un condensador de 100nf en cada IC, (Tiene11, PIC 16f628, EEPROM2432, MAX 232 y 8 IC74164), colocar un condensador electrolitico en la alimentacion de 220uf para estabilidad y usamos una pequeñas fuete switiching como las que usan los celulares para sus baterias.
Bueno el punto es que el panel anda de los mas bien, tiene efectos y todo, pero he notado que cuando conectaba cualquier mi taladro o mi ventilador, ojo solo al conectarlo o desconectarlo no al encenderlo, mi panel se resetaba en el mejor de los casos, o dejaba de funcionar en el peor.
Quisiera recalcar que no puedo echarle la culpa al motor del taladro o mi ventilador, ya que ni siquiera me da tiempo de encenderlos, solo es al conectar o desconectar el enchufe a la red de 220. tambien es cierto que no es siempre, pero pasa, mas a menudo de lo que desaria, he probado colcoando filtros de red a la entrada del transformador, tambien probe con una fuente de PC, pero igual cuando hago mis pruebas, conectando y desconectando continuamente mi taladro, se cuelga o se resetea el panel, si alguien pudiera ayudarme se lo agradeceria, la configuracionm es la comun para estos paneles, el PIC envia los datos por filas a los 74164 y habilita cada una de las 7 filas con 7 BD140, el pic trabaja a 20MHZ y la pantalla se refresca a una velocidad de 100HZ.
 
Última edición:
Arriba