Regulador LM317 se niega a colaborar

#1
Muchachos, ¿alguno podrá darme una mano con este problema?.
Realicé el siguiente circuito para obtener 310Vdc, y con eso alimentar una tira de 86leds. (En la imagen dice 87, pero son 86 en realidad)

A la salida estoy obteniendo aproximadamente unos 300Vdc (pudiendo bajar hasta los 290V debido a las fluctuaciones en los 220Vac de entrada. Más que 300Vdc no subió jamás). El problema surge con el regulador LM317. El mismo tiene como finalidad fijar una corriente de 18mA para los diodos, para lo cual puse entre las patas ADJ y VOUT una R de 68ohm.
En un primer momento, el regulador funcionó OK, fijando la corriente. La idea era que a las variaciones en la tensión de 310Vdc las absorbiera el regulador con su tensión Vin-Vout.
Según hoja de datos, se banca hasta 40V.
Acá viene la cuestión. La caída por los leds es en teoría de 3,3V * 86= 284V.
A la hora de probar el circuito, no encendían bien. Brillaban muy poco, mucho menos de lo que los había visto brillar en pruebas anteriores en protoboard.
Entonces probé puentear un par de ellos, ya que supuse que la tensión no alcanzaba para polarizarlos correctamente.
Al probar de nuevo, verifico que la tensión que caía sobre los leds había bajado (ahora estaba en 275V aprox), por lo que el regulador debía estar "comiéndose" esa diferencia. Estuvo funcionando un ratito y de repente... "pum", a la resistencia de 68ohm se le dio por morir.
La reemplacé, volví a dejar los 86leds como estaban, y probé nuevamente. Ahora el circuito vuelve a funcionar, pero sin ningún tipo de regulación. Por los leds circulan unos 35mA (lo sé porque puse una resistencia "testigo" de 100ohm en serie) y la caída de tensión Vin-Vout es de casi 0V.
Mi duda: ¿Murió el regulador? ¿No se suponía que era el rey de las autoprotecciones?
Hablando en serio, no termino de entenderlo. Según mis cuentas sobre el regulador no cayeron más de 300-275= 25V. Y con una corriente menor a 20mA. Si me baso en lo que dice la hoja de datos, no tendría por qué haber muerto.. :confused:
 

Adjuntos

#2
Hola.

Haz tus cálculos con los valores picos. Ten en cuenta que el voltaje de la red tiene una variación +/- X%.

Chao.
elaficionado.
 
#4
Hola elaficionado, gracias por tu respuesta.
Para el cálculo consideré 300Vdc de máximo, por el simple hecho de que en todas las mediciones que realicé, nunca superó ese valor. De hecho, al momento de volar la resistencia, tampoco lo estaba haciendo.
La tensión de red por esta zona no supera jamás los 220Vac, a lo sumo puede ser menor.
Aún con los 310Vdc "full", la caída máxima me da unos 35V. Sí, está cerca del límite, pero estoy casi seguro que en la práctica no me acerqué tanto a esa condición.:unsure:

¿Cómo podría solucionar esta cuestión de la luminosidad de los leds sin bajar la cantidad de los mismos? La corriente, hasta lo que había chequeado, estaba en los 18mA. Mi problema era la tensión.
¿Podrá ser que el regulador sea truchificado?


Edit: Hola 2SC, no me había aparecido tu respuesta. Me sacaste las palabras de la boca... jaja. Voy a ver cómo podría hacerlo, gracias por el aporte!
 
Última edición:
#6
Como explicas que se te queme una resistencia que disipa apenas : 1.25V X 18mA: 0.022W aprox, tiene que ser la entrada como indica elaficionado, la red posee tambien ruido impulsivo.se genera muy facilmente al arrancar la congeladora, encender florescentes,etc. Tienes que proteger tu 317 de sobrevoltaje.
 
Última edición:
#7
Hola.

El voltaje de pico de 220Vca siempre es 311V. En mi país tiene una variación del +/- 10%. De allí que tengo dos voltajes picos, uno cuando el (220V +10%*220)*√2 y el otro es (220V - 10%*220)*√2.

El pico más alto se analiza para que no destruya los componentes del circuito.
El pico más bajo se analiza para que el circuito funcione bien a pesar de la caída de voltaje.

Chao.
elaficionado.
 
#9
Gracias a todos por las respuestas!

papirrin: si yo no entiendo mal, el esquema que publicaste.. no es lo mismo que puse yo, sólo que conectado en distinto orden? :unsure:

elaficionado y opamp: Lo que dicen es cierto. Lo que pasa es que me confié, porque en mi zona no hay nunca 220V+10%, sino todo lo contrario. Al circuito lo hice para que funcionara bien con 220V, y se la aguantara un poco más ante una caída. En todo caso, dejaría de iluminar tanto (y eventualmente, con una caída más grande, se apagarían los led). Pero en todo caso no sería tan grave. Lo del ruido impulsivo no lo había contemplado..:oops:


¿Serviría como protección algo así? Lo único, tengo que buscar un zener de 300V.

Gracias a todos por las respuestas!

papirrin: si yo no entiendo mal, el esquema que publicaste.. no es lo mismo que puse yo, sólo que conectado en distinto orden? :unsure:

elaficionado y opamp: Lo que dicen es cierto. Lo que pasa es que me confié, porque en mi zona no hay nunca 220V+10%, sino todo lo contrario. Al circuito lo hice para que funcionara bien con 220V, y se la aguantara un poco más ante una caída. En todo caso, dejaría de iluminar tanto (y eventualmente, con una caída más grande, se apagarían los led). Pero en todo caso no sería tan grave. Lo del ruido impulsivo no lo había contemplado..:oops:


¿Serviría como protección algo así? Lo único, tengo que buscar un zener de 300V.



Me parece que esta sería una configuración más "definitiva". ¿Qué opinan? :unsure:
 

Adjuntos

Última edición:
#10
Tengo entendido que hay límites para esa R limitadora en tu montaje de regulador de corriente, viene dada aprox por el cálculo de I=1.25/R, con 68 Ohms sobrepasa el Ampere y disipa mucha potencia y entonces PUM!!...
 
#13
Hola Daniel,
No entiendo cómo llegaste a ese 1 Amper que me decís. :confused:
Yo hice simplemente 1.25V/68ohm=18.38 mA
Corrientes mayores debería ser capaz de entregar según la hoja de datos. Según dice es hasta 1.5 A.

Ahora bien, si la R esa de 68ohm se quemó por sobretensión, tengo que concluír que el regulador decididamente pasó a mejor vida, ya que de lo contrario no podrían haber caído más de 1.25V sobre dicha R. ¿no?
 
#14
si yo no entiendo mal, el esquema que publicaste.. no es lo mismo que puse yo, sólo que conectado en distinto orden?
pues por lo que estoy entendiendo de lo que dicen los compañeros, si es lo mismo.. y yo tenia razon dije una burrada :LOL:
ya nada mas los leo y aprendo, no habia visto tal configuracion del 317.
 
Última edición:
#15
:oops: Interpreté mal, creí haber visto 6.8Ohms, ofrezco una disculpa.

Respecto a la muerte del regulador habría que ver también que los leds tengan un voltaje de operación semejante entre ellos. ¿De que que leds son?, en tus cálculos tomas el valor "teórico"
 
#17
Gracias igualmente papirrin, por tu aporte. Estamos acá para aprender. Yo tampoco había usado un 317 así anteriormente (y)

Daniel, los leds son UV. Según la hoja de datos era 3.2V. Sin embargo he medido 3.1 , 3.2 y hasta 3.3 V en diferentes leds. Promediando las caídas creo que con 3.2V por led me acerco bastante a la realidad.

Como está el circuito ahora, "desregulado", si lo mido entre bornes de la tira de leds tengo 290V, pero con algunos leds "intermitentes", cuya tensión no llega ni a 3.1V, y encienden cuando sube un poco la tensión de línea. No voy a seguir conectándolo así, porque no me van a vivir mucho más.

¿Cómo influiría es diferencia en el regulador? ¿Vos me lo preguntás por si la tensión real es menor a la teórica?


2SC: Está muy buena esa pág. Me dió lo siguiente: http://www.ledcalc.net/?betriebsspannung=300&led_anzahl=86&led_spannung=3.2&led_strom=18

En este caso no quería poner una resistencia en serie, ya que en teoría el 317 tenía que ser mi "buffer de tensión".
 
Última edición:
#20
jreyes: Si bien en la teoría yo también creí que funcionaría, en la práctica tengo el problema de variabilidad de la tensión de línea, que me terminó liquidando el regulador.. (n)

elaficionado: está muy bueno el diseño ese en proteus. Simulable con 200 a 240V y todo, fenómeno.
Unas preguntas:
-¿La R de 120K debería ser de 2Watts mínimo, no? (para el caso de 240Vac tenés 0.96W de disipación ahí). A lo mejor con 1Watt ando bien, ya que nunca llego a 240V..
-El transistor MJE se banca los 270V sobre la juntura base-colector, ¿no? busqué en el datasheet pero no dice nada. (Aunque si en la C-E se banca 700V... asumo que sí)
-¿La R de 150K en paralelo con el capacitor qué función cumple ahí?, ¿descargar el capacitor cuando desconecte la carga?
Gracias por las respuestas!
 
Arriba