Reseteo de pic en industria 16f877a

#1
Antes que nada hola a todos . Resulta que diseñe un contador que cuenta hasta 9999. Este contador resibe una señal que proviene de un contactor, es decir yo pogo, en una de las borneras de entrada del contactor, una señal logica de mi fuente y en el NO lo conecto a la pata RB0/INT es decir cuando se desactiva el contactor, el pic recibe una señal de interrupcion, luego se queda esperando que el contactor se active, lo cual, yo tengo la misma señal logica conectada al NC que ingresa a la pata RB1 y recien cuenta.
Ahora bien, el problema es el siguiente, en el banco de prueba, el contador anda barbaro. pero en la entrada RB0 y RB1 yo lo probe con pulsadores. cuando lo lleve y lo instale, el contador nunca andubo, prendia barbaro, pero cuando se accionaba el contador el lcd se apagaba y se me reiniciaba. Como puedo filtrar el ruido que me aparece para que no se me reinicie?
El pic tiene puesto en sus alimentaciones 2 capacitores electroliticos de 47uf y tiene una resistencia de 10k directo al Vcc en la pata MCLR

Desde ya gracias a todos
 

Adjuntos

#3
recien acabo de probar eso y nada. cuando el contactor pasa al NO no hay problema, pero cuando pasa al NC nuevamente ahi se me apaga el displey se vuelve a prender y el contador no avanza (es decir se me resetea el pic).
voy a seguir buscando la manera de filtrar ese ruido
 
#4
utiliza provisionalmente una fuente independiente para alimentar el contador.

¿estas seguro que se resetea devido a la fuente de alimentacion?
 
#5
Hola:
La verdad que no entiendo bien lo que te pasa. Por lo poco que entendí sospecho que no es problema de ruído. Estás trabajando en un ambiente industrial y aparentemente compartes una sola "tierra"; si es así debes asegurarte de que no haya alguna impedancia grosera en tu circuito de tierra. Lo más seguro es usar "contactos secos" para las señales externas que le llegan a tu PIC o en su defecto usar optoacopladores.
Saludos.
 
#6
Acabo de solucionar el reseteo, era el pin RB1 que estaba cagado. Ahora el otro problema es que el ruido no se va. cuenta de 1 en 1 pero en cualquier momento no cuando entra la señal.
Eses ruido no tengo idea como filtrarlo
 
#7
Saludos Alcon99, la entrada del pic, que recibe la senial del contactor debes de ponerle una resistencia de 1k Ohms o algo asi, para que cuando la patita RB0/INT no tenga senial + del contacor, se mantenga aterrizada, asi evitas que lleguen seniales parasitas, que es lo que hace que te cuente sin que tengas conectado nada..

Si es mucho el ruido del contactor al enclavar, trata de alimentar tu circuito de otra fase o recurre a filtrar mas sofisticadamente, como es el uso de bobinas.

En ves de utilizar 2 capacitores de 47uf, utiliza uno de 100uf y el otro de 100nf, este ultimo debe de estar bien pegadito a la entrada de alimentacion del PIC.

Suerte.
 

Temas similares

Arriba