Sobrecalentamiento de pic

#1
Hola que tal,tengo un pic conectado a un pc por max232,y tras estar haciendo pruebas con el noto que esta quizas demasiado caliente.No puedo saber si es demasiado porque es la primera vez que uso pics...pero la verdad es que lo noto muy caliente.

Como es para una alarma va a estar alimentado constantemente.El pic es el 16f628 a y le estoy metiendo 5V... Otra cosa es que la mayor parte del tiempo va a estar en modo sleep esperando una interrupcion qeu viene de un sensor,quizas asi se calentara menos? Saludos.
 
#2
Algo debes de tener conectado mal, un corto seguramente. Los uC no se calientan trabajando bajo condiciónes normales, ni en modo sleep.
 
#4
revisa bien el circuito, asegurate de que lo alimentas a 5volt, que no tienes cortos en las soldaduras ni en las pistas que van conectados a él... además debes tener claro que le conectas en sus registros de entrada y salida...
en condiciones normales no se calienta...

saludos
 
#5
si lo tenia en protoboard y seguramente me he equivocado en algo..en todo caso lo he desmontado todo y me pondre a armarlo desde cero.Gracias por las respuestas.
 
#8
Si tu dices que siguen funcionando, entonces...
el puerto B creo que puede disipar hasta 100ma y al puerto A pobremente 20mA,
asegúrate que todo este bien conectado y como debe de ser...
.si el problema sigue ...proba con otro pic el 16f628 es muy comun y barato
 
#9
no he probado a regrabarlo ni nada...pero sigue comunicandose con el pc.En todo caso ya encontre el fallo,de novato como era de esperar.Me habia equivocado con los condensadores.

Este es el esquema que he utilizado:

En todo caso voy a usar condensadores de 1uf como viene en el datasheet,o algo parecido.¿Alguien puede explicarme porque le meten 10uf?
 

Adjuntos

Última edición:
#10
Porque el Max232 utiliza los capacitores para tirar tensiones de 10v/-10v y que el Rs232 de tu PC pueda reconocer la comunicacion.

Basicamente lo que hace es "switchear" la conexion de los capacitores, primero los pone en paralelo para cargarlos y que tengan 5v y luego los pone en serie para que la suma de las tensiones de 10v, lo mismo hace con las tensiones negativas.

Asi y todo, el max232 tambien funciona con capacitores de 1uF (no recuerdo bien), en el modelo de maxim usaban esos valores. A lo que voy, es que en el peor de los casos si te equivocas en el valor del capacitor a lo sumo la PC no te reconoce la comunicacion serie.
 
#13
Hola.No he probado todavia porque estoy a la espera de nuevos componentes.El pic solo tiene salida hacia el max232...no se donde puedo estarle pidiendo mas salida de la que puede dar.saludos.
 
#14
Mmm, fijate, puede ser lo que te dice cosmefulanito:

¿Sigue calentando el Pic?

Seguro que tenias un corto, o le pedias mucha corriente a la salida de un puerto.
Osino, primero, que tenes conectado a las salidas del Max232?
Y ademas, fijate si has colocado bien los capacitores del max232 y tambien fijate mejor dicho si estan TODOS los capacitores necesarios, los 2 de 100 nF, Todos.

Espero poder ayudarte ;)
 
#15
Claro,se agradece toda ayuda,pero a las salidas del max232 tenia conectado un simple cable de serie...nada mas.Ahora mismo como estaba desmontado el circuito ya no tiene mucho sentido hablar de lo que estaba mal de todas maneras...cuando lo vuelva a montar vere si sigue el problema.Es que en principio pense que el calentamientos de un pic era normal...
 
#16
Claro,se agradece toda ayuda,pero a las salidas del max232 tenia conectado un simple cable de serie...nada mas.Ahora mismo como estaba desmontado el circuito ya no tiene mucho sentido hablar de lo que estaba mal de todas maneras...cuando lo vuelva a montar vere si sigue el problema.Es que en principio pense que el calentamientos de un pic era normal...
Denada, siempre tene en cuenta eso, si se calienta un pic es señal de problemas

nos vemos
 

Temas similares

Arriba